<!DOCTYPE html>
<html lang="hi">
<head>
<!-- Google Tag Manager -->
<script>
var gtmFired = false;
document.addEventListener("mousemove", function() { loadGTM(); });
document.addEventListener("scroll", function() { loadGTM(); });
function loadGTM() {
if(gtmFired) {
return;
}
gtmFired = true;
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PZMZ8RP');
}
</script>
<!-- End Google Tag Manager -->
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=yes">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
<meta property="fb:admins" content="603431824"/>
<meta property="fb:admins" content="1020623816"/>
<meta property="fb:app_id" content="394687130715834" />
<!-- Begin new fb pages meta tags. -->
<meta property="fb:pages" content="116151972998">
<meta property="fb:pages" content="638392079590181">
<meta property="fb:pages" content="1427355644210382">
<meta property="fb:pages" content="1533778130171410">
<meta property="fb:pages" content="353256696613">
<meta property="fb:pages" content="233043350648">
<meta property="fb:pages" content="189419887802605">
<meta property="fb:pages" content="361214257357503">
<meta property="fb:pages" content="161662747254143">
<meta property="fb:pages" content="179374682137817">
<meta property="fb:pages" content="671658282858797">
<meta property="fb:pages" content="235149339867793">
<meta property="fb:pages" content="113039892135516">
<meta property="fb:pages" content="198888153532348">
<meta property="fb:pages" content="480037188813382">
<meta property="fb:pages" content="264363300269574">
<meta property="fb:pages" content="1480789248868135">
<meta property="fb:pages" content="229284143908">
<meta property="fb:pages" content="664341660330270">
<meta property="fb:pages" content="104892801736107">
<!-- End new fb pages meta tags. -->
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta name="google" content="notranslate">
<meta name="google-site-verification" content="jfoGxhn0lKDnzaezDsDeBPtaRA1TcLJHYpboESjADWw" />
<meta name="google-site-verification" content="3huxEurviDoBg-WbkLtZGBmVAfufoT02gMUtYo0enZc" />
<title>Sources of Calcium and Vitamin D in hindi-कैल्शियम और विटामिन डी किसमें पाया जाता है</title>
<link href="https://plus.google.com/101781064736549245960/" rel="publisher" />
<link rel="shortcut" href="https://www.sportskeeda.com/favicon.ico" type="image/x-icon"/>
<link rel="icon" sizes="192x192" href="https://staticg.sportskeeda.com/logo/sk-short-logo.png">
<link href="https://staticg.sportskeeda.com/logo/sk-short-logo.png" rel="apple-touch-icon-precomposed" sizes="196x196" />
<link rel="amphtml" href="https://hindi.sportskeeda.com/amp/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi">
<link rel="canonical" id="canonical-link" href="https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi" />
<meta name="robots" content="index, follow, max-image-preview:large">
<link rel="alternate" href="android-app://com.sportskeeda.topic/http/www.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi" />
<meta property="al:android:url" content="android-app://com.sportskeeda.topic/http/www.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi">
<meta property="al:android:package" content="com.sportskeeda.topic">
<meta property="al:android:app_name" content="Sportskeeda Live">
<meta name="twitter:app:name:googleplay" content="Sportskeeda Live" />
<meta name="twitter:app:id:googleplay" content="com.sportskeeda.topic" />
<meta name="twitter:app:url:googleplay" content="android-app://com.sportskeeda.topic/http/www.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi" />
<meta name="twitter:card" content="app">
<meta name="twitter:app:country" content="India">
<meta name="twitter:site" content="@sportskeeda" />
<meta name="twitter:card" content="summary_large_image"/>
<meta property="article:publisher" content="https://www.facebook.com/SportsKeeda" />
<meta name='keywords' content='Hindi - Health and Fitness, फ़ीचर'><meta property='og:title' content='कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai' /><meta property='og:type' content='article' /><meta property='og:image' content='https://staticg.sportskeeda.com/editor/2022/05/653d5-16528899194315-1920.jpg' /><meta property='og:url' content='https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi' /><meta property='og:description' content='Sources of Calcium and Vitamin D in hindi: उम्र बढ़ने के साथ ही जोड़ों में दर्द की समस्या बढ़ जाती है। हड्डियां कमजोर होने लगती है।' /><!-- for Twitter --><meta name='twitter:title' content='कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai'/><meta name='twitter:description' content='Sources of Calcium and Vitamin D in hindi: उम्र बढ़ने के साथ ही जोड़ों में दर्द की समस्या बढ़ जाती है। हड्डियां कमजोर होने लगती है।' /><meta name='twitter:image' content='https://staticg.sportskeeda.com/editor/2022/05/653d5-16528899194315-1920.jpg' /><meta name='title' content='कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai'/><meta name='description' content='Sources of Calcium and Vitamin D in hindi: उम्र बढ़ने के साथ ही जोड़ों में दर्द की समस्या बढ़ जाती है। हड्डियां कमजोर होने लगती है।'/><meta name='author' content='Ritu Raj'/><link rel='alternate' type='application/rss+xml' title='Sportskeeda &raquo; Feed' href='https://hindi.sportskeeda.com/feed'/>
<link rel="shortcut icon" href="https://www.sportskeeda.com/favicon.ico" type="image/x-icon"/>
<link rel="icon" href="/apple-touch-icon-precomposed.png" type="image/png"/>
<style>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</style>
<script type="text/javascript">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</script>
<script>
function asyncScriptLoader(input) {
var src = input.src;
var attachTo = input.attachTo;
var loadWithAsync = input.loadWithAsync;
var loadWithDefer = input.loadWithDefer;
var attributes = input.attributes;
return new Promise(function(resolve, reject) {
var script = document.createElement("script");
script.src = src;
script.onload = resolve;
script.onerror = reject;
if (loadWithAsync) {
script.setAttribute("async", true);
}
if (loadWithDefer) {
script.setAttribute("defer", true);
}
if (attributes && attributes.length > 0) {
attributes.forEach(function(attribute) {
script.setAttribute(attribute.key, attribute.value);
});
}
if (attachTo) {
attachTo.appendChild(script);
} else {
document.head.appendChild(script);
}
});
}
</script>
<script>
//Code is executed only on .1% of the pages
if(Math.floor(Math.random() * 1000) <= 1) {
asyncScriptLoader({
src : "https://js.sentry-cdn.com/e31f1e9e78bb4320beb2324075c1c6fc.min.js",
loadWithAsync: true
}).then(function() {
Sentry.init({
release: "WithoutIIQ"
});
});
}
</script>
<script>
function loadScriptAsync(scriptSrc, callback, attributes, DOMInto) {
if (typeof callback !== 'function') {
throw new Error('Not a valid callback for async script load');
}
var script = document.createElement('script');
if (attributes && attributes.length > 0) {
for (var attribIter = 0; attribIter < attributes.length; attribIter++) {
script.setAttribute(attributes[attribIter].attribKey, attributes[attribIter].attribValue);
}
}
script.onload = callback;
script.src = scriptSrc;
if (DOMInto) {
DOMInto.appendChild(script);
} else {
document.head.appendChild(script);
}
}
</script>
<!--Query string init -->
<script>
var $ = document.querySelector.bind(document);
var $all = document.querySelectorAll.bind(document);
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.cmd.push(function() {
window && window.tercept && window.tercept.init && window.tercept.init(11446729);
});
</script>
<style>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</style>
<div class="keeda_modal" onclick="modalPopup.dismissPopup(event)">
<div class="keeda_modal_content modal_small">
<div class="keeda_modal_header">
<span class="keeda_modal_header_text"></span>
<div class="actions">
<span class="keeda_modal_header_secondary_action"></span>
<span class="keeda_modal_close" onclick="modalPopup.close()">&times;</span>
</div>
</div>
<div class="keeda_modal_content_text">
</div>
</div>
</div>
<script>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</script>
<script type="text/javascript">
function openCsrfLoginPopup () {
window.location = 'https://a-login.sportskeeda.com/hi/logout?next='+window.location.origin + window.location.pathname;
modalPopup.close();
return false;
}
function cancelCsrfPopup () {
modalPopup.close();
}
function csrfReLogin() {
modalPopup.open();
modalPopup.setHeader('Session Expired');
modalPopup.setContentText('Your session has expired. Please Login again to continue. ');
modalPopup.addCancelOkButton('ReLogin', cancelCsrfPopup, openCsrfLoginPopup);
modalPopup.setModalSize('modal_large');
}
</script><script type="text/javascript">
</script>
<script type="text/javascript">
function setLocalStorageData(key, value) {
localStorage.setItem(key, value);
}
function getLocalStorageData(key) {
var item = localStorage.getItem(key);
return item != null ? item : "";
}
function setLocalStorageWithExpiry(key, value, expiryTimestamp) {
// `item` is an object which contains the original value
// as well as the time when it's supposed to expire
var item = {
value: value,
expiry: expiryTimestamp,
};
localStorage.setItem(key, JSON.stringify(item));
}
function getLocalStorageWithExpiry(key) {
var itemStr = localStorage.getItem(key);
// if the item doesn't exist, return null
if (!itemStr) {
return null;
}
var item = JSON.parse(itemStr);
var now = new Date();
// compare the expiry time of the item with the current time
if (now.getTime() > item.expiry) {
// If the item is expired, delete the item from storage
// and return null
localStorage.removeItem(key);
return null;
}
return item.value;
}
</script>
<script type="text/javascript">
</script>
<script type="text/javascript">
/*
The code below creates an interface for sending GA events
The below functions can be called directly or be attached with HTML attributes
like data-category, data-action, data-label
*/
function ga_event(category, action, label) {
gtag('event', action, {
'event_category': category,
'event_label': label,
'non_interaction': true
});
}
/*
Function for 'click' events like an item clicked in feed
*/
function ga_event_click(action, label) {
ga_event('click', action, label);
}
/*
Function for 'metric' events like number of pages user scrolled while infinite scrolling.
Action can be used as the page where user was and label as the page number
*/
function ga_event_metric(action, label) {
ga_event('metric', action, label);
}
</script>
<script type="text/javascript">
function hasClass(domNode, className) {
if (!className) return;
if(!domNode || !domNode.classList || typeof(domNode.classList.contains) !== "function") {
return;
}
return domNode.classList.contains(className);
}
function addClass(domNode, className) {
if (!className) return;
if(!domNode || !domNode.classList || typeof(domNode.classList.add) !== "function") {
return;
}
return domNode.classList.add(className);
}
function removeClass(domNode, className) {
if (!className) return;
if(!domNode || !domNode.classList || typeof(domNode.classList.remove) !== "function") {
return;
}
return domNode.classList.remove(className);
}
// This function detects whether localStorage is both supported and available. Params can be `localStorage` or `sessionStorage`.
function storageAvailable(type) {
try {
var storage = window[type],
x = '__storage_test__';
storage.setItem(x, x);
storage.removeItem(x);
return true;
}
catch(e) {
return e instanceof DOMException && (
// everything except Firefox
e.code === 22 ||
// Firefox
e.code === 1014 ||
// test name field too, because code might not be present
// everything except Firefox
e.name === 'QuotaExceededError' ||
// Firefox
e.name === 'NS_ERROR_DOM_QUOTA_REACHED') &&
// acknowledge QuotaExceededError only if there's something already stored
storage.length !== 0;
}
}
function stringToHTML(str) {
var parser = new DOMParser();
var doc = parser.parseFromString(str, 'text/html');
return doc.body;
}
var MEDIA_TAGS = ["figure", "embed", "video", "iframe"]
function isMediaElement(element) {
if (element) {
if (element.classList && element.classList.contains && element.classList.contains("sportskeeda-embed")) {
return true;
}
if (element.tagName) {
var tagName = String(element.tagName).toLowerCase();
return MEDIA_TAGS.indexOf(tagName) > -1;
}
}
return false;
}
function countMetaChanges(elements) {
var charactersChanged = 0;
var wordsChanged = 0;
var mediaChanged = 0;
for (var i = 0; i < elements.length; i++) {
var element = elements[i];
if (isMediaElement(element)) {
mediaChanged += 1;
continue;
}
var content = element.innerHTML || "";
content = content.replace(/[\u200B-\u200D\uFEFF]/g, "");
if (content.length < 1) {
continue;
}
charactersChanged += content.length;
wordsChanged += content.split(" ").filter(Boolean).length;
}
var metaChanges = {
charactersChanged : charactersChanged,
wordsChanged : wordsChanged,
mediaChanged : mediaChanged
};
return metaChanges;
}
</script>
<script type="text/javascript">
function capitalizeFirstLetter(string) {
if (!string) return;
return string.charAt(0).toUpperCase() + string.slice(1);
}
function toTitleCase(str) {
return str.replace(/\w\S*/g, function(txt) {
return txt.charAt(0).toUpperCase() + txt.substr(1).toLowerCase();
});
}
function escapeString(text) {
if (!text) {
return "";
}
var map = {
'&': '&amp;',
'<': '&lt;',
'>': '&gt;',
'"': '&quot;',
"'": '&#039;'
};
return text.replace(/[&<>"']/g, function(m) { return map[m]; });
}
</script>
<script type="text/javascript">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</script>
<script type="text/javascript">
function roundOffTo (num, factor) {
var quotient = num / factor;
var result = Math.round(quotient) * factor;
return result;
}
function getOrdinalForNumber(number) {
if (number > 3 && number < 21) return "th";
switch (number % 10) {
case 1:
return "st";
case 2:
return "nd";
case 3:
return "rd";
default:
return "th";
}
}
</script>
<script type="text/javascript">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</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script type="text/javascript">
// limits calls to a func to once every given timeframe
function debounce(func, duration) {
var timeout;
return function () {
var context = this, args = arguments;
var effect = function effect() {
timeout = null;
return func.apply(context, args);
};
clearTimeout(timeout);
timeout = setTimeout(effect, duration);
};
}
function generateRandomString() {
var allCharacters = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789";
var base = allCharacters.split('');
var randomstr = "";
for (var i=0; i<30; i++) {
randomstr += base[Math.random()*base.length|0];
}
return randomstr;
}
function getImageWidthTransformedURL(imageURL, width) {
if (!imageURL) {
return "";
}
if (isNaN(width)) {
return imageURL;
}
imageURL = imageURL.replace("http://", "https://");
var imageURI = new URL(imageURL);
imageURI.searchParams.set("w", width);
return imageURI.toString();
}
function getImageHeightTransformedURL(imageURL, height) {
if (!imageURL) {
return "";
}
if (isNaN(height)) {
return imageURL;
}
imageURL = imageURL.replace("http://", "https://");
var imageURI = new URL(imageURL);
imageURI.searchParams.set("h", height);
return imageURI.toString();
}
function getNumFormat(num) {
var num_format = Math.round(num);
if (num >= 1000 && num < 1000000) {
num_format = (Math.round(num) / 1000).toFixed(1) + 'K';
} else if (num >= 1000000 && num < 1000000000) {
num_format = (Math.round(num) / 1000000).toFixed(1) + 'M';
} else if (num >= 1000000000) {
num_format = (Math.round(num) / 1000000000).toFixed(1) + 'B';
}
return num_format;
}
function isOverflow(element) {
if (!element) return false;
return element.scrollWidth > element.clientWidth;
}
</script>
<script>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</script>
<script >
var getLocation = function(href) {
var l = document.createElement("a");
l.href = href;
return l.pathname;
};
var besideH1Links = $all('ul.desktop-h1-side-menu li a')
for(i=0; i< besideH1Links.length; i += 1) {
var currentPath = document.location.pathname;
if(currentPath === getLocation(besideH1Links[i].href)) {
besideH1Links[i].className = besideH1Links[i].className + " active";
}
}
</script>
<meta property="article:published_time" content="2022-05-18T21:35:33+05:30" /><meta property="article:modified_time" content="2022-05-18T21:35:33+05:30" />
<script>
window.addEventListener('message',function(e) {
if(e.data && e.data.SKNative) {
var expansionEligibleIframe = e.source.frameElement;
expansionEligibleIframe.style.width = "100%";
}
});
</script>
<script>
function showHideTimelessSectionByPosts(posts, element) {
if (!element) {
return;
}
if (!posts.length && element) {
element.classList.add("hidden");
} else {
if(element && Array.from(element.classList).indexOf("hidden")) {
element.classList.remove("hidden");
}
}
}
function adjustTimelessPostContainerWidth(posts, storyElement, rightScrollElement) {
if (!storyElement || !rightScrollElement) {
return;
}
if (posts.length === 1) {
storyElement.style.maxWidth = "100%";
$(".one-story").classList.add("full-width");
}
if (isOverflow(storyElement)) {
if (Array.from(rightScrollElement.classList).indexOf("hidden") >= 0) {
rightScrollElement.classList.remove("hidden");
}
} else {
if (Array.from(rightScrollElement.classList).indexOf("hidden") < 0) {
rightScrollElement.classList.add("hidden");
}
}
}
function addTimelessPostScrollListener(storyElement, rightScrollElement, leftScrollElement) {
if (!storyElement || !rightScrollElement || !leftScrollElement) {
return;
}
storyElement.addEventListener("scroll", function() {
if (storyElement.scrollLeft > 0) {
if (Array.from(leftScrollElement.classList).indexOf("hidden") >= 0) {
leftScrollElement.classList.remove("hidden");
}
}
if (storyElement.scrollLeft <= 0) {
if (Array.from(leftScrollElement.classList).indexOf("hidden") < 0) {
leftScrollElement.classList.add("hidden");
}
}
if ((storyElement.scrollWidth-storyElement.scrollLeft) === storyElement.offsetWidth) {
if (Array.from(rightScrollElement.classList).indexOf("hidden") < 0) {
rightScrollElement.classList.add("hidden");
}
} else {
if (Array.from(rightScrollElement.classList).indexOf("hidden") >= 0) {
rightScrollElement.classList.remove("hidden");
}
}
});
}
function slideLeftTimelessPosts() {
sideScrollTimelessPost('left', 10, 270, 15);
}
function slideRightTimelessPosts() {
sideScrollTimelessPost('right', 10, 270, 15);
}
function sideScrollTimelessPost(direction,speed,distance,step){
var timelessPostContainer = $("#timeless-posts-list");
var leftScrollElem = $(".timeless-posts-anchors #left");
scrollAmount = 0;
var slideTimer = setInterval(function(){
if(direction == 'right'){
timelessPostContainer.scrollLeft -= step;
} else {
timelessPostContainer.scrollLeft += step;
}
scrollAmount += step;
if(scrollAmount >= distance){
window.clearInterval(slideTimer);
}
if (timelessPostContainer.scrollLeft === 0) {
leftScrollElem.classList.add("hidden");
}
}, speed);
if(Array.from(leftScrollElem.classList).indexOf('hidden') >= 0) {
leftScrollElem.classList.remove("hidden");
}
}
function timelessPostGaEvent(type, postId, category, title, taxonomy, slug) {
var gaSubSet = {
'event_name': 'Timeless clicked',
'post_id': postId,
'sport_category': category,
'title': title.replace(/-/gi, " "),
'taxonomy': taxonomy,
'page_type': 'Articlepage'
};
if (type == 'author') {
gaSubSet['author_slug'] = slug;
} else {
gaSubSet['url'] = slug;
}
gtag('event', 'Timeless clicked', gaSubSet);
}
function isInViewport(el) {
var rect = el.getBoundingClientRect();
return (
rect.top >= 0 &&
rect.left >= 0 &&
rect.bottom <= (window.innerHeight || document.documentElement.clientHeight) &&
rect.right <= (window.innerWidth || document.documentElement.clientWidth)
);
}
function trackTimelessPostImpressions(pageSource) {
var timelessStories = $all(".timeless-story");
var observer = new IntersectionObserver(function(entries) {
entries.forEach(function(entry) {
if (!entry.target || !entry.isIntersecting || entry.intersectionRatio < 1 || !entry.target.dataset) return;
var postId = entry.target.dataset["postId"];
var postSlug = entry.target.dataset["postSlug"];
var postCategorySlug = entry.target.dataset["postSportCategorySlug"];
var postTaxonomy = entry.target.dataset["postTaxonomy"];
if (postId) {                        
setTimeout(function(element) {
if (isInViewport(element)) {
console.log("sending GA event 'Timeless post impression' for post id " + postId + " page source " + pageSource);
timelessPostImpressionGAEvent(postId, postSlug, postCategorySlug, postTaxonomy, pageSource);
}
}, 1000, entry.target);
}
});
}, {
threshold: 1
});
timelessStories.forEach(function(story) {
observer.observe(story);
});
}
function timelessPostImpressionGAEvent(postId, title, category, taxonomy, pageSource) {
var gaSubSet = {
'post_id': postId,
'sport_category': category,
'title': title.replace(/-/gi, " "),
'taxonomy': taxonomy,
'page_source': pageSource
};
gtag('event', 'Timeless post impression', gaSubSet);
}
</script>
<script type="text/javascript">
</script>
<script type="text/javascript">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</script>
<script type="text/javascript">
</script>
<script>
function deepCopy(o) {
var out, v, key;
out = Array.isArray(o) ? [] : {};
for (key in o) {
v = o[key];
out[key] = (typeof v === "object" && v !== null) ? deepCopy(v) : v;
}
return out;
}
</script>
<script>
var KeedaPrebidUtilsInstance = (function() {
var SK_SEGMENT = Number(String(getCookie('sk_segment') || "100"));
var USER_COUNTRY = String(getCookie('country_code') || "").toUpperCase();
var IS_DESKTOP = "1";
var LANG = String("hi").toLowerCase();
var PAGE_TYPE = "Articlepage";
var CATEGORY = "health-and-fitness" || "sources-of-calcium-and-vitamin-d-in-hindi";
var PRICING_COHORTS = {
group1: {
label: "India",
values: [25, 0, 17]
},
group2: {
label: "T1",
values: [50, 0, 30]
},
group3: {
label: "ROW",
values: [21, 0, 17]
}
};
var PRICING_COHORTS_BY_COUNTRY = {
IN: PRICING_COHORTS.group1,
US: PRICING_COHORTS.group2,
UK: PRICING_COHORTS.group2,
GB: PRICING_COHORTS.group2,
CA: PRICING_COHORTS.group2,
AU: PRICING_COHORTS.group2
}
function KeedaPrebidUtils() {
this.bidderFilterCriteria = {};
this.bidderParamsEnhancers = {};
this.pricingCohortGroup = PRICING_COHORTS_BY_COUNTRY[USER_COUNTRY] || PRICING_COHORTS.group3;
var cohortValueIndex = 2;
if (SK_SEGMENT <= 5) {
cohortValueIndex = 0;
} else if (SK_SEGMENT <= 10) {
cohortValueIndex = 1;
} else if (SK_SEGMENT <= 100) {
cohortValueIndex = 2;
}
this.floorPricingValue = this.pricingCohortGroup.values[cohortValueIndex];
}
KeedaPrebidUtils.prototype.addBidderFilter = function(bidderName, callback) {
if (!callback || typeof callback !== "function") {
return;
}
this.bidderFilterCriteria[bidderName] = callback;
}
KeedaPrebidUtils.prototype.filterBidders = function(bidders, adUnitName) {
var self = this;
return bidders.filter(function(bidderData) {
var filterCallback = self.bidderFilterCriteria[bidderData.bidder];
if (!filterCallback) {
return true;
}
return filterCallback(getCallbackPayload(bidderData, adUnitName));
});
}
KeedaPrebidUtils.prototype.addBidderParamsEnhancer = function(bidderName, callback) {
if (!callback || typeof callback !== "function") {
return;
}
this.bidderParamsEnhancers[bidderName] = callback;
}
KeedaPrebidUtils.prototype.enhanceBiddersParams = function(bidders, adUnitName) {
var self = this;
return bidders.map(function(bidderData) {
var enhancerCallback = self.bidderParamsEnhancers[bidderData.bidder];
if (!enhancerCallback) {
return bidderData;
}
return enhancerCallback(getCallbackPayload(bidderData, adUnitName));
});
}
KeedaPrebidUtils.prototype.getFloorPricing = function() {
return this.floorPricingValue;
}
KeedaPrebidUtils.prototype.getFloorPricingForGAM = function(toString) {
return [
this.pricingCohortGroup.label,
this.getFloorPricing()
].join(" - ");
}
function getCallbackPayload(bidderData, adUnitName) {
return {
adUnitName: adUnitName,
bidderData: bidderData,
userCountryCode: USER_COUNTRY,
lang: LANG,
isDesktop: IS_DESKTOP,
pageType: PAGE_TYPE,
category: CATEGORY,
};
}
function addDefaultPrebidBidderFilters(utilInstance) {
conversantFilter();
synacorFilter();
ixFilter();
function conversantFilter() {
var allowedCountries = ["US", "CA", "UK", "FR"];
utilInstance.addBidderFilter("conversant", function(params) {
return allowedCountries.includes(params.userCountryCode);
});
}
function synacorFilter() {
var allowedCountries = ["US", "CA"];
utilInstance.addBidderFilter("synacormedia", function(params) {
return allowedCountries.includes(params.userCountryCode);
});
}
function ixFilter() {
var excludeCountries = ["IN", "BD", "PH", "NE", "NG", "PK", "KE", "NP"];
utilInstance.addBidderFilter("ix", function(params) {
return !excludeCountries.includes(params.userCountryCode);
});
}
}
function addDefaultPrebidBidderEnhancers(utilInstance) {
adagioParamsEnhancer();
yahooParamsEnhancer();
smartAdServerParamsEnhancer();
function adagioParamsEnhancer() {
utilInstance.addBidderParamsEnhancer("adagio", function(params) {
params.bidderData["params"]["environment"] = params.isDesktop ? "Desktop" : "Mobile";
if (params.pageType) {
params.bidderData["params"]["pagetype"] = params.pageType;
}
if (params.category) {
params.bidderData["params"]["category"] = params.category;
}
return params.bidderData;
});
}
function yahooParamsEnhancer() {
utilInstance.addBidderParamsEnhancer("yahoossp", function(params) {
params.bidderData["params"] = params.bidderData["params"][params.lang];
return params.bidderData;
});
}
function smartAdServerParamsEnhancer() {
utilInstance.addBidderParamsEnhancer("smartadserver", function(params) {
if(params.adUnitName == "MatchCenter_Commentary_300x250_2021") {
if(!params.isDesktop){
params.bidderData["params"]["formatId"] = 105246;
}
}
return params.bidderData;
});
}
}
return (function(utilInstance) {
addDefaultPrebidBidderFilters(utilInstance);
addDefaultPrebidBidderEnhancers(utilInstance);
return utilInstance;
})(new KeedaPrebidUtils());
})();
</script>
<script>
var adUnitsToLoad = [];
var prebidAdSlotsByCodeMapping = {};
var prebidAdUnitDivMapping = {};
function requestBidsFromPrebidForAdSlots(slots, adUnitCodes) {
slots = slots.filter(Boolean);
adUnitCodes = adUnitCodes.filter(Boolean);
if (!slots.length || !adUnitCodes.length) {
return false;
}
pbjs.que.push(function() {
console.info("Going to request bids for ad-units: ", adUnitCodes);
pbjs.requestBids({
adUnitCodes: adUnitCodes,
bidsBackHandler: function(res) {
console.info("Received bids response: ", res);
pbjs.setTargetingForGPTAsync(adUnitCodes);
googletag.pubads().refresh(slots);
},
});
});
return true;
}
function requestBidsFromPrebidForAdSlot(slot, adUnitCode) {
if (!slot) {
return;
}
if (!slot.hasOwnProperty("getSlotElementId")) {
return;
}
adUnitCode = adUnitCode || slot.getSlotElementId();
prebidAdSlotsByCodeMapping[adUnitCode] = slot;
return requestBidsFromPrebidForAdSlots([slot], [adUnitCode]);
}
function addAdUnitToPrebid(input) {
var adUnitCode = input.adUnitCode;
var mediaTypes = input.mediaTypes;
var adUnitName = input.adUnitName;
var adUnitPath = input.adUnitPath;
mediaTypes.banner.sizes = mediaTypes.banner.sizes.filter(function(size) {
return size !== "fluid";
});
var bids = KeedaPrebidUtilsInstance.enhanceBiddersParams(
KeedaPrebidUtilsInstance.filterBidders(input.bids || [], adUnitName),
adUnitName
);
var tags = [
adUnitName + ":sportskeeda.com",
"pubstack_tag_version:sportskeeda.com",
];
tags.push("Floor:" + KeedaPrebidUtilsInstance.getFloorPricingForGAM());
pbjs.que.push(function() {
pbjs.addAdUnits({
code: adUnitCode,
mediaTypes: mediaTypes,
bids: bids,
pubstack: {
adUnitName: adUnitName,
adUnitPath: adUnitPath,
tags: tags,
},
});
});
}
function registerAdUnit(adUnitName) {
if (!adUnits[adUnitName]) {
return;
}
if (!adUnitsToLoad.includes(adUnitName)) {
adUnitsToLoad.push(adUnitName);
}
}
function initAdUnit(adUnitName, params) {
if (!adUnits[adUnitName]) {
return;
}
params = Object.assign({
withDynamicDivId: false
}, params);
if (adUnits[adUnitName]["defined"] && !params.withDynamicDivId) return;
adUnits[adUnitName]["defined"] = true;
registerAdUnit(adUnitName);
var adUnit = deepCopy(adUnits[adUnitName]);
var adSlot = defineAdSlot(adUnit, adUnitName, params);
if (!adSlot) {
return;
}
if (!adUnit.div) {
adUnit.div = adSlot.getSlotElementId();
}
addAdUnitToPrebid({
adUnitCode: adUnit.div,
mediaTypes: adUnit.mediaTypes,
adUnitName: adUnitName,
adUnitPath: "/11446729/" + adUnitName,
bids: adUnit.bids,
});
prebidAdSlotsByCodeMapping[adUnit.div] = adSlot;
prebidAdUnitDivMapping[adUnit.div] = adUnitName;
return adSlot;
}
function initInfiniteContentAdUnit(adUnitName, params) {
return initAdUnit(adUnitName, Object.assign({}, params, {
withDynamicDivId: true
}));
}
function initLoadAdUnits() {
adUnitsToLoad.forEach(function(adUnitName) {
initAdUnit(adUnitName);
});
}
function requestBidsFromPrebid() {
initLoadAdUnits();
var adUnitCodes = Object.keys(prebidAdSlotsByCodeMapping);
var adUnitSlots = Object.values(prebidAdSlotsByCodeMapping);
var acknowledged = requestBidsFromPrebidForAdSlots(adUnitSlots, adUnitCodes);
if (acknowledged) {
if (!pbjs.firstBidRequestSent) {
pbjs.firstBidRequestSent = true;
}
}
}
function requestPrebidInitRefresh() {
if (pbjs.firstBidRequestSent) return;
pbjs.firstBidRequestSent = true;
googletag.cmd.push(function() {
pbjs.que.push(function() {
console.info(
"No bid request has been made yet. Going to refresh all registered ad units."
);
pbjs.setTargetingForGPTAsync && pbjs.setTargetingForGPTAsync();
googletag.pubads().refresh();
});
});
}
</script>
<script>
(function() {
var IS_GDPR_APPLICABLE = getCookie("gdpr") == "true";
function initAdServer() {
if (IS_GDPR_APPLICABLE) return;
requestPrebidInitRefresh();
}
setTimeout(initAdServer, 3000);
})();
</script>
<script>
</script>
<script type='text/javascript'>
pbjs.que.push(function() {
pbjs.setConfig({
bidderTimeout: 2000,
enableSendAllBids: false,
priceGranularity: {
buckets: [{
precision: 2,
min: 1,
max: 900,
increment: 1,
},
{
precision: 2,
min: 905,
max: 3150,
increment: 5,
},
],
},
});
pbjs.setConfig({
currency: {
adServerCurrency: "INR",
defaultRates: { USD: { INR: 75 } },
},
});
pbjs.setConfig({
floors: {
enforcement: {
bidAdjustment: true,
},
data: {
currency: "INR",
schema: {
fields: ["bidder", "gptSlot"],
},
values: {
"openx|*": KeedaPrebidUtilsInstance.getFloorPricing() / 1000,
"*|*": KeedaPrebidUtilsInstance.getFloorPricing(),
},
},
additionalSchemaFields: {
bidder: function(bidRequest) {
return bidRequest.bidder;
}
}
},
});
pbjs.setConfig({
criteo: {
fastBidVersion: "latest",
}
});
pbjs.setConfig({
userSync: {
aliasSyncEnabled: true,
filterSettings: {
iframe: {
bidders: "*",
filter: "include",
},
},
userIds: [{
name: "identityLink",
params: {
pid: "13672",
},
storage: {
type: "cookie",
name: "idl_env",
expires: 15,
},
}],
},
});
if (adopsdecisions.gdprApplies) {
pbjs.setConfig({
consentManagement: {
gdpr: {
cmpApi: "iab",
allowAuctionWithoutConsent: false,
timeout: 10000,
},
},
});
}
pbjs.que.push(function() {
pbjs.enableAnalytics([{
provider: "atsAnalytics",
options: {
pid: "13672"
}
}]);
});
});
</script>
<script type="text/javascript">
function deepCopy(o) {
var out, v, key;
out = Array.isArray(o) ? [] : {};
for (key in o) {
v = o[key];
out[key] = (typeof v === "object" && v !== null) ? deepCopy(v) : v;
}
return out;
}
</script><script>
var LiveRampUtilsInstance = (function() {
var USER_DETAILS_URL = "https://a-gotham.sportskeeda.com/user/info-from-cookies";
var OBJECT_TYPE_KEY__EMAIL = "email";
var OBJECT_TYPE_KEY__MOBILE = "phoneNumber";
function LiveRampUtils() {
}
LiveRampUtils.prototype.init = function() {
var self = this;
return loadAtsScript().then(function() {
return self.getEnvelopeData();
}).then(function(envelopeData) {
return envelopeData ? whenEnvelopeIsPresent(self) : whenEnvelopeIsNotPresent(self);
}).then(function() {
return self;
});
}
LiveRampUtils.prototype.initAtsData = function(userData) {
if (userData && userData.user_email) {
setAtsEnvelopeData(userData.user_email, OBJECT_TYPE_KEY__EMAIL);
}
}
LiveRampUtils.prototype.getEnvelopeData = function() {
return window.ats.retrieveEnvelope();
}
LiveRampUtils.prototype.clearEnvelopeData = function() {
return window.ats.invalidateEnvelope();
}
function whenEnvelopeIsPresent(self) {
if (!isUserLoggedIn()) {
self.clearEnvelopeData();
}
}
function whenEnvelopeIsNotPresent(self) {
if (isUserLoggedIn()) {
var email = decodeURIComponent(getCookie("fw_email")) || "";
if (email != "") {
self.initAtsData({"user_email": email})
} else {
getLoggedInUserDetails().then(self.initAtsData);
}
}
}
function isUserLoggedIn() {
return !!getCurrentUserID();
}
function getLoggedInUserDetails() {
return pureJSAjaxGetWithPromise(USER_DETAILS_URL)
.then(function(res) {
return jsonParse(res);
}).catch(function(err) {
console.error(err);
});
}
function loadAtsScript() {
return new Promise(function(resolve) {
loadScriptAsync(
"https://launchpad-wrapper.privacymanager.io/8bab80e3-fc47-48f9-a2f1-5b9a6ff3f649/launchpad-liveramp.js",
function() {
__launchpad("addEventListener", 1, function(launchPadData, success) {
resolve(launchPadData, success);
}, "atsWrapperLoaded");
});
});
}
function setAtsEnvelopeData(id, type) {
if (!window.atsenvelopemodule) return;
window.atsenvelopemodule.setAdditionalData({
type: type,
id: id
});
}
function jsonParse(res) {
try {
return JSON.parse(res);
} catch (err) {
return res;
}
}
return (function(liveRampUtilsInstance) {
var liveRampInitCalled = false;
function initLiveRamp() {
if (liveRampInitCalled) return;
liveRampInitCalled = true;
liveRampUtilsInstance.init();
}
initLiveRamp();
return liveRampUtilsInstance;
})(new LiveRampUtils());
})();
</script>
<script type="text/javascript">
!function(e){var t={};function n(o){if(t[o])return t[o].exports;var r=t[o]={i:o,l:!1,exports:{}};return e[o].call(r.exports,r,r.exports,n),r.l=!0,r.exports}n.m=e,n.c=t,n.d=function(e,t,o){n.o(e,t)||Object.defineProperty(e,t,{enumerable:!0,get:o})},n.r=function(e){"undefined"!=typeof Symbol&&Symbol.toStringTag&&Object.defineProperty(e,Symbol.toStringTag,{value:"Module"}),Object.defineProperty(e,"__esModule",{value:!0})},n.t=function(e,t){if(1&t&&(e=n(e)),8&t)return e;if(4&t&&"object"==typeof e&&e&&e.__esModule)return e;var o=Object.create(null);if(n.r(o),Object.defineProperty(o,"default",{enumerable:!0,value:e}),2&t&&"string"!=typeof e)for(var r in e)n.d(o,r,function(t){return e[t]}.bind(null,r));return o},n.n=function(e){var t=e&&e.__esModule?function(){return e.default}:function(){return e};return n.d(t,"a",t),t},n.o=function(e,t){return Object.prototype.hasOwnProperty.call(e,t)},n.p="",n(n.s=1)}([,function(e,t){var n="GWD_PARALLAX",o="GWD_PARALLAX_CUSTOM_CREATIVE",r="GWD_PARALLAX_CARPET",i="ADOBE_ANIMATE",a="register-events",l="expand-ad",c="collapse-ad",s=[o,r],d=window.innerHeight,u=window.innerWidth,f=document.documentElement.clientWidth,g=document.documentElement.clientHeight;function p(e,t){for(;(e=e.parentElement)&&!e.classList.contains(t););return e}function m(e){var t=e[e.message?"message":"data"]||{};try{t=JSON.parse(t)}catch(e){}return t}function h(e){var t,n=m(e);try{t=function(e){if(e.source)for(var t=document.getElementsByTagName("iframe"),n=0;n<t.length;n++)if(t[n].contentWindow===e.source)return t[n];return null}(e)}catch(e){}return t||(t=function(e){if(void 0!==(e=adUnits&&adUnits[e])){return document.getElementById(e.div).querySelector("iframe")}return null}(n.adUnit)),t}var v={};var y=!0;function w(e,t,n){var o,r;if(t?(o=t.getBoundingClientRect(),r=.5*t.offsetHeight):(o=e.getBoundingClientRect(),r=.5*e.offsetHeight),W(o,r)){var i=function(e){var t=1-e.bottom/(d+e.height),n=e.right/(u+e.width),o=e.top,r=e.left;return{creativeFramePercentY:t,creativeFramePercentX:n,creativeFrameTop:o,creativeFrameLeft:r}}(o),a=Object.assign(i,{isInitial:y,hostpageScrollX:window.scrollX,hostpageScrollY:window.scrollY,eventType:"hostpageScroll",windowHeight:d,windowWidth:u});y&&(y=!1),s.includes(n)?e.contentWindow.postMessage(JSON.stringify(a),"*"):e.contentWindow.frames&&e.contentWindow.frames.length>0&&e.contentWindow.frames[0].postMessage(JSON.stringify(a),"*")}}var b=0,E=0;function O(){var e=document.documentElement.scrollTop+document.body.scrollTop,t=document.documentElement.scrollLeft+document.body.scrollLeft,n=b-e,o=E-t;return b=e,E=t,{top:n,left:o}}function W(e,t){return!!e&&(e.bottom>0&&e.right>0&&e.left<(u||f)&&e.top+t<(d||g))}window.addEventListener("message",(function(e){var t=m(e);if(t.sk)if(t.type===a)console.log("Register event type received",t.provider),(s=h(e))&&t.globalEvents&&Array.isArray(t.globalEvents)&&t.globalEvents.forEach((function(e){!function(e,t,a){if(v[e])-1===v[e].indexOf(t)&&v[e].push(t);else{var l;v[e]=[],a===r&&(l=t.parentNode.parentNode.parentNode.parentNode),window.addEventListener(e,(function(t){v[e].map((function(t){a===n||a===o?w(t,null,a):a===r?w(t,l,a):a===i&&function(e,t){if(e&&e.contentWindow&&e.contentWindow.frames.length>0){var n=e.getBoundingClientRect(),o=.5*e.offsetHeight,r={eventType:t,scrollDelta:O(),scroll:{x:window.scrollX||window.pageXOffset,y:window.scrollY||window.pageYOffset},inViewPort:W(n,o)};e.contentWindow.frames&&e.contentWindow.frames.length>0?e.contentWindow.frames[0].postMessage(JSON.stringify(r),"*"):e.contentWindow.postMessage(JSON.stringify(r),"*")}}(t,e)}))})),v[e].push(t)}}(e,s,t.provider)}));else if(t.type===c||t.type===l){var s;if(console.log("Expand/collapse event type received"),s=h(e)){if(t.height&&(s.style.height=t.height,s.parentElement.style.height="auto",s.parentElement.style.minHeight="auto",t.type===c)){var d=p(s,"mobile-ad-negative-space");d&&(d.style.minHeight="auto",d.style.height="auto");var u=p(s,"mobile-ad-holder-parallax");u&&(u.style.minHeight="auto",u.style.height="auto",u.style.paddingBottom="10px")}t.width&&(s.style.width=t.width)}}}))}]);</script>
<script type='text/javascript'>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</script>
<style>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</style>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "NewsArticle",
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi"
},
"headline": "कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai",
"image": {
"@type": "ImageObject",
"url": "https://staticg.sportskeeda.com/editor/2022/05/653d5-16528899194315-1920.jpg",
"width": 800,
"height": 600
},
"articleBody": "Sources of Calcium and Vitamin D in hindi: उम्र बढ़ने के साथ ही जोड़ों में दर्द की समस्या बढ़ जाती है। हड्डियां कमजोर होने लगती है। ऐसे में अपने खान-पान पर बेहद ही ध्यान देना होता है, खासकर उनपर जो हमारे हड्डियों को मजबूती प्रदान करे। कैल्शियम और विटामिन डी स्वस्थ हड्डियों के दो मुख्य घटक हैं। जहां कैल्शियम आपकी हड्डियों और दांतों के लिए लाभकारी है। वहीं, विटामिन डी कैल्शियम के अवशोषण और हड्डियों के विकास में सुधार करने मदद करता है। ये पोषक तत्व बढ़ती उम्र में बेहद ही महत्वपूर्ण हैं। ऑस्टियोपोरोसिस या गठिया से पीड़ित लोग कैल्शियम और विटामिन डी वाले आहार का सेवन करने से छुटकारा पा सकते हैं।इन 6 चीजों में कैल्शियम और विटामिन डी पाया जाता हैसारडाइन फिश (Sardine fish for Calcium aur Vitamin D)सारडाइन मछली में कैल्शियम के साथ-साथ विटामिन डी का उच्च स्तर होता है। सार्डिन का सेवन ऑस्टियोपोरोसिस के जोखिम को कम करने में मदद कर सकता है। आप अपने दैनिक आहार में शामिल कर इसका लाभ उठा सकते हैं।सैल्मन फिश (Salmon fish is Source of Calcium aur Vitamin D)सैल्मन फिश में ओमेगा-3 फैटी एसिड भरपूर मात्रा में पाई जाती है। इसके साथ ही सैल्मन फिश विटामिन डी का एक बड़ा स्रोत है। स्वस्थ हृदय, मजबूत हड्डियों और ऑस्टियोपोरोसिस की रोकथाम के लिए सैल्मन को अपने आहार में शामिल किया जा सकता है।टूना (Eat Tuna fish for Calcium aur Vitamin D)टूना फिश एक वसायुक्त मछली है जो विटामिन डी का एक बड़ा स्रोत है। यानी इसमें फैट नहीं पाया जाता है। टूना फिश के सेवन से आप सूर्य की रोशनी से मिलने वाले विटामिन डी की कमी को पूरा कर सकते हैं। माना जाता है कि टूना फिश के सेवन से आप 39% विटामिन डी हासिल कर सकते हैं।दही (Yogurt)कई ऐसे खाद्य पदार्थ हैं जिनकी सेवन से आप कैल्शियम के साथ ही विटामिन डी की कमी को पूरा कर सकते हैं। दही उनमें से एक है। दही कैल्शियम और विटामिन डी की मदद से आपके शरीर में कैल्शियम के साथ ही विटामिन डी की कमी भी पूरा होगा। ये ऑस्टियोपोरोसिस को रोकने में मदद कर सकता है।अंडे (Benefits of Egg)अंडे में कई सारे पोषक तत्व होते हैं जो हमारे स्वस्थ शरीर के लिए बेहद जरूरी होते हैं। इसके सेवन से विटामिन डी की कमी को पूरा किया जा सकता है।दूध (Milk for Bones)दूध कैल्शियम का बेहतरीन स्त्रोत है। जिसके चलते बचपन से लेकर बुढ़ापे तक दूध का सेवन करना जरूरी होता है। नियमित रूप से दूध पीने से ऑस्टियोपोरोसिस के खतरे को कम किया जा सकता है। इसके साथ ही हड्डियों की मजबूती बनी रहती है और जोड़ों का दर्द भी कम हो सकता है।अस्वीकरण: सलाह सहित यह सामग्री केवल सामान्य जानकारी प्रदान करती है। यह किसी भी तरह से योग्य चिकित्सा राय का विकल्प नहीं है। अधिक जानकारी के लिए हमेशा किसी विशेषज्ञ या अपने चिकित्सक से परामर्श करें। स्पोर्ट्सकीड़ा हिंदी इस जानकारी के लिए ज़िम्मेदारी का दावा नहीं करता है।",    "datePublished": "2022-05-18T21:35:33+05:30",
"dateModified": "2022-05-18T21:35:33+05:30",
"author": {
"@type": "Person",
"name": "Ritu Raj",
"url": "https://hindi.sportskeeda.com/profile/ritu-raj-1vcei"
},
"publisher": {
"@type": "Organization",
"name": "Sportskeeda Hindi",
"logo": {
"@type": "ImageObject",
"url": "https://staticg.sportskeeda.com/logo/sk-logo-full-60.png",
"width": 115,
"height": 60
}
},
"description": "Sources of Calcium and Vitamin D in hindi: उम्र बढ़ने के साथ ही जोड़ों में दर्द की समस्या बढ़ जाती है। हड्डियां कमजोर होने लगती है।"
}
</script>
</script>
<style>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</style>
<style>
.yt-aspect-ratio-container {
position: relative;
display: block;
}
.yt-aspect-ratio-container iframe {
position: absolute;
top: 0;
left: 0;
width: 100%;
height: 100%;
border-radius: 4px;
}
</style>
<style type="text/css">
.share-bottom-holder {
display: flex;
justify-content: space-between;
padding: 8px 16px 8px 0;
}
.share-container {
display: flex;
align-items: center;
margin: 0 0 10px;
}
.content-holder .post-share,
.content-holder .share-container,
.content-holder .share-icons-container {
overflow: visible;
}
.share-bottom-holder .share-container {
margin: 0;
}
.share-container .share-btn:focus {
outline: none;
}
.share-container .share-btn {
display: flex;
border: 1px solid transparent;
border-radius: 23px;
background: none;
align-items: center;
cursor: pointer;
user-select: none;
}
.forward-share {
width: 16px !important;
height: 16px !important;
object-fit: contain;
}
.share-btn img {
display: inline-block;
background: none;
}
.share-btn span {
font-size: 16px;
font-weight: 500;
color: #474747;
margin-left: 8px;
}
.share-icon-holder {
width: 40px;
height: 40px;
margin: 0px 4px;
display: inline-block;
position: relative;
}
.share-top .share-icon-holder {
text-decoration: none;
}
.share-icon-holder img {
width: 100%;
height: 100%;
display: inline-block !important;
background: none !important;
vertical-align: top;
}
.share-icons-container {
height: 56px;
background: #FFFFFF;
border: 1px solid #E9E9E9;
box-sizing: border-box;
box-shadow: 0px 6px 12px rgba(0, 0, 0, 0.1);
border-radius: 50px;
display: flex;
justify-content: center;
align-items: center;
padding: 8px 5px;
position: absolute;
bottom: 30px;
left: -55px;
}
@media (max-width: 360px) {
.share-icon-holder {
margin: 5px;
}
}
</style>
<style type="text/css">
.content-holder .reaction-icons-container {
overflow: visible;
}
.reaction-icon-holder {
display: flex;
justify-content: center;
overflow: visible !important;
}
.reaction-icon-holder img {
width: 38px !important;
height: 38px !important;
display: inline-block !important;
background: none !important;
max-width: unset;
}
.reaction-icons-container {
height: 54px;
background: #FFFFFF;
border: 1px solid #E9E9E9;
box-sizing: border-box;
box-shadow: 0px 6px 12px rgb(0 0 0 / 10%);
border-radius: 50px;
display: flex;
justify-content: center;
align-items: center;
padding: 8px 5px;
position: absolute;
bottom: 35px;
z-index: 999;
}
.icon-style {
margin: 0 6px !important;
}
.reaction-icon-holder:hover > img {
height: 58px !important;
width: 58px !important;
margin: -2px -2px 15px !important;
}
.reaction-icon-holder:hover > span {
display: block !important;
}
.reaction-text {
background-color: #2D2D2D;
font-size: 12px !important;
font-weight: 400 !important;
color: #fff !important;
text-align: center;
padding: 2px 8px;
border-radius: 18px;
position: absolute;
z-index: 1;
top: -36px;
display: none;
}
.user-action-element .share-icons-container {
z-index: 999;
top: unset;
left: unset !important;
right: 10px !important;
}
.user-action-element .reaction-icons-container {
z-index: 999;
left: -70px !important;
top: unset;
}
</style>
<style>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</style>
<style>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</style>
</head>
<body>
<style>
#gdpr__consent_revocation_container {
position: fixed;
left: 10px;
bottom: 10px;
width: 40px;
height: 40px;
z-index: 2147483646;
}
#gdpr__consent_revocation_btn {
background-color: #6aaae4;
border-radius: 10px;
box-shadow: 0 4px 8px 0 rgb(0 0 0 / 20%);
border: none;
cursor: pointer;
padding: 5px;
width: 100%;
height: 100%;
opacity: 0.5;
}
#gdpr__consent_revocation_btn:hover {
opacity: 1;
}
#gdpr__consent_revocation_btn svg {
width: 100%;
height: 100%;
}
</style>
<div id="gdpr__consent_revocation_container" class="hidden">
<button type="button" id="gdpr__consent_revocation_btn" onclick="revokeGdprPermissions();">
<svg role="presentation" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" viewBox="0 0 28 38">
<path class="ot-floating-button__svg-fill"
d="M14.588 0l.445.328c1.807 1.303 3.961 2.533 6.461 3.688 2.015.93 4.576 1.746 7.682 2.446 0 14.178-4.73 24.133-14.19 29.864l-.398.236C4.863 30.87 0 20.837 0 6.462c3.107-.7 5.668-1.516 7.682-2.446 2.709-1.251 5.01-2.59 6.906-4.016zm5.87 13.88a.75.75 0 00-.974.159l-5.475 6.625-3.005-2.997-.077-.067a.75.75 0 00-.983 1.13l4.172 4.16 6.525-7.895.06-.083a.75.75 0 00-.16-.973z"
fill="#FFF" fill-rule="evenodd"></path>
</svg>
</button>
</div>
<script>
var googlefc = googlefc || {};
googlefc.ccpa = googlefc.ccpa || {}
googlefc.callbackQueue = googlefc.callbackQueue || [];
function revokeGdprPermissions() {
googlefc.callbackQueue.push(googlefc.showRevocationMessage);
}
(function() {
var container = $("#gdpr__consent_revocation_container");
if (getCookie("gdpr") == "true") {
googlefc.callbackQueue.push(function() {
if (typeof __tcfapi === "function") {
__tcfapi("addEventListener", 2, function(tcData, success) {
if (success) {
if (tcData.eventStatus === "cmpuishown") {
container.classList.add("hidden");
return;
}
if (tcData.eventStatus === "tcloaded" || tcData.eventStatus === "useractioncomplete") {
container.classList.remove("hidden");
}
}
});
}
});
}
})();
</script>
<!-- Google Tag Manager (noscript) -->
<noscript>
<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PZMZ8RP" height="0" width="0" style="display:none;visibility:hidden"></iframe>
</noscript>
<!-- End Google Tag Manager (noscript) -->
<style>
.feedback-section {
display: flex;
justify-content: space-around;
align-items: center;
padding: 28px 8px;
clear: both;
width: 100%;
flex-direction: column;
}
.feedback-section .feedback-button {
padding: 8px 12px;
text-decoration: none;
border: 1px solid #0B65F0;
box-sizing: border-box;
border-radius: 4px;
color: #fff;
margin: 0;
background: #E1EBFF;
color: #0B65F0;
font-weight: bold;
font-size: 12px;
line-height: 15px;
display: flex;
justify-content: center;
align-items: center;
margin-bottom: 12px;
width: 144px;
}
.feedback-button img {
width: 16px;
height: 16px;
margin-right: 8px;
object-fit: cover;
background: none;
}
</style>
<div class="masthead">
<div id="top-brand-bar" class="container" style="position:relative;overflow:visible;height:50px;padding: 16px 0;">
<div id="main-menu" class="no-select">
<img style="width: 18px;" width="18" height="12" src="https://staticg.sportskeeda.com/skm/assets/header/btn-menu.svg" alt="" />
</div>
<div class="masthead-container" >
<span class="logo" style="display: inline-flex;">
<a class="navbar-brand"  href="/" >
<img class="img-responsive homepage-logo" width="200" height="24" style="display: inline-block;width: 200px" alt="Sports news" title="Sports news" src="//staticg.sportskeeda.com/logo/brand_logos/full-vector.svg" />
<span class="lang-text">हिन्दी</span>
</a>
</span>
<span class="write-an-article" onclick="window.location=('/creator')">Create</span>
<style>
#keeda-notifications-container {
position: relative;
display: none;
color: black;
font-weight: bold;
text-decoration: none;
padding: 10px 8px;
margin: -11px 15px 0px 0px;
background-color: white;
text-align: center;
border-radius: 40px;
float: right;
line-height: 15px;
font-size: 14px;
cursor: pointer;
}
#keeda-notifications-container {
float: right;
}
#kn-content-container {
display: none;
position: absolute;
left: -110px;
top: 60px;
z-index: 0;
width: 373px;
background: white;
border-radius: 4px;
overflow: scroll;
max-height: 400px;
box-shadow: #585858 1px 1px 6px;
overflow-x: hidden;
}
#kn-pointer {
content: "";
position: absolute;
display: none;
top: 36px;
left: 8px;
border: solid 12px transparent;
border-bottom-color: #fff;
z-index: 1;
}
#kn-bell-icon {
background: url(https://staticg.sportskeeda.com/skm/assets/header/btn-notifications-speaker.svg) no-repeat;
background-size: 20px 20px;
height: 20px;
width: 20px;
margin-right: 5px;
}
#kn-bell-count {
position: absolute;
right: -5px;
top: 0;
font-size: 10px;
background-color: #b22222;
color: white;
padding: 0px 5px 0px 5px;
border-radius: 2px
}
.kn-card-wrapper {
display: block;
text-align: left;
white-space: nowrap;
width: 373px;
height: 70px;
border-bottom: 1px solid #dddddd;
}
.kn-card-wrapper:hover {
background: #f5f5f5;
}
.kn-card-wrapper .kn-image-container, .kn-card-wrapper .kn-info-container {
display: inline-block;
vertical-align: middle;
}
.kn-card-wrapper .kn-image-container {
margin: 5px 0px 5px 10px;
}
.kn-card-wrapper .kn-info-container {
margin: 8px;
width: 76%;
}
.kn-card-wrapper:last-child {
margin-bottom: 0;
}
.kn-card-pic {
display: inline-block;
width: 50px;
height: 50px;
border-radius: 100px;
}
.kn-card-a {
display:block;
white-space: normal;
text-decoration: none;
font-size: 13px;
color: #555;
font-weight: 300;
overflow: hidden;
max-height: 3.6em;
display: -webkit-box;
-webkit-line-clamp: 3;
-webkit-box-orient: vertical;
}
.kn-card-date {
display: inline-block;
font-size: 10px;
text-align: left;
color: #646464;
font-weight: 300;
}
.kn-notification-header {
font-size: 14px;
font-weight: 500;
text-align: left;
color: #808080;
margin: 10px;
text-transform: uppercase;
}
.kn-notification-footer {
height: 15px;
text-transform: uppercase;
font-size: 13px;
font-weight: 500;
letter-spacing: -0.2px;
text-align: center;
color: #808080;
margin: 10px;
}
@media (max-width:768px) {
#keeda-notifications-container {
margin: 13px 0px 12px 16px;
padding: 0;
}
#kn-bell-icon {
margin-right: 12px;
}
#kn-bell-count {
top: -10px;
}
#kn-content-container {
position: fixed;
z-index: 1020!important;
top: 49px;
left: 0;
width: 100%;
border: none;
height: 100%;
max-height: none;
}
#keeda-profile-container:after{
background-image: url('//staticg.sportskeeda.com/down_arrow.svg');
display:block;
}
.kn-card-container {
overflow: scroll;
padding-bottom: 50px;
}
.kn-card-wrapper {
width: 100%;
}
.kn-notification-footer {
position: fixed;
bottom: 0;
left: 50%;
transform: translateX(-50%)
}
}
@media (max-width:360px) {
#keeda-notifications-container {
display: none !important;
}
}
</style>
<div id="keeda-notifications-container">
<div id="kn-bell-icon"></div>
<div id="kn-bell-count"></div>
<div id="kn-pointer"></div>
<div id="kn-content-container">
<div class="kn-notification-header">
Notifications
</div>
<div class="kn-card-container">
</div>
<div class="kn-notification-footer">
<!-- See All -->
</div>
</div>
<template id="kn-card">
<div class="kn-card-wrapper" data-notification-id="">
<span class="kn-image-container">
<img class="kn-card-pic"/>
</span>
<span class="kn-info-container">
<a class="kn-card-a"></a>
<div class="kn-card-date"></div>
</span>
</div>
</template>
</div>
<style>
#keeda-comment-notifications-container {
position: relative;
display: block;
color: black;
text-decoration: none;
padding: 10px 8px;
margin: -11px 8px 8px 8px;
background-color: white;
text-align: center;
border-radius: 40px;
line-height: 15px;
font-size: 14px;
cursor: pointer;
float: right;
}
#kcn-comment-container {
display: block;
position: absolute;
left: -110px;
top: 60px;
z-index: 0;
width: 373px;
background: white;
border-radius: 4px;
overflow: scroll;
max-height: 400px;
box-shadow: #585858 1px 1px 6px;
overflow-x: hidden;
}
#kcn-pointer {
content: "";
position: absolute;
display: block;
top: 36px;
left: 8px;
border: solid 12px transparent;
border-bottom-color: #fff;
z-index: 1;
}
#kcn-comment-info-holder {
display: block;
position: relative;
cursor: pointer;
}
#kcn-comment-icon {
background: url('//staticg.sportskeeda.com/skm/assets/header/comment-notification.svg') no-repeat;
background-size: 20px 20px;
height: 20px;
width: 20px;
}
#kcn-comment-count {
position: absolute;
left: 8px;
top: -10px;
font-size: 10px;
background-color: #b22222;
color: white;
padding: 0px 5px 0px 5px;
border-radius: 2px
}
.kcn-card-wrapper {
display: block;
white-space: nowrap;
margin: 10px;
}
.kcn-notification-header {
font-size: 14px;
font-weight: 500;
text-align: left;
color: #808080;
margin: 10px;
text-transform: uppercase;
}
.kcn-notification-footer {
height: 15px;
text-transform: uppercase;
font-size: 13px;
font-weight: 500;
letter-spacing: -0.2px;
text-align: center;
color: #808080;
margin: 10px;
}
.kcn-single-comment-container .kcn-comment-text {
min-height: 30px;
text-align: left;
background-color: #f5f5f5;
border-radius: 2px;
font-size: 10px;
white-space: break-spaces;
line-height: 10px;
overflow: hidden;
height: auto;
}
.kcn-single-comment-container {
background: #f2f2f2;
padding: 5px;
border-radius: 3px;
box-shadow: #bbb 1px 1px 4px;
margin-bottom: 11px;
}
.kcn-single-comment-container:hover{
box-shadow: #111 1px 1px 4px;
}
.kcn-single-comment-container .kcn-action {
display: flex;
text-align: center;
padding: 2px 0;
}
.kcn-single-comment-container .kcn-action.approved-text {
color: green;
}
.kcn-single-comment-container .kcn-action.rejected-text {
color: red;
}
.kcn-action .approve {
flex: 1;
background-color: green;
color: white;
padding: 5px;
border-radius: 2px;
}
.kcn-action .reject {
flex: 1;
padding: 5px;
border-radius: 2px;
color: rebeccapurple;
border: 1px solid;
margin-left: 5px;
display: none;
}
.kcn-action .delete {
flex: 1;
padding: 5px;
border-radius: 2px;
color: red;
border: 1px solid;
margin-left: 5px;
}
.kcn-action .approve:hover, .kcn-action .reject:hover, .kcn-action .delete:hover{
transform: scale(1.01);
}
.keeda-posts-link-div {
text-align: left;
padding: 2px 0px 10px 0px;
}
@media (max-width:768px) {
#keeda-comment-notifications-container {
margin: 13px 4px 12px 16px;
padding: 0;
}
#kcn-comment-count {
right: -5px;
top: -5px;
}
#kcn-comment-container {
position: fixed;
z-index: 1020!important;
top: 49px;
left: 0;
width: 100%;
border: none;
height: 100%;
max-height: none;
}
.kcn-card-container {
overflow: scroll;
padding-bottom: 50px;
}
.kn-card-wrapper {
width: 100%;
}
.kcn-notification-footer {
position: fixed;
bottom: 0;
left: 50%;
transform: translateX(-50%)
}
}
</style>
<div id="keeda-comment-notifications-container" class="hidden">
<div id="kcn-comment-info-holder">
<div id="kcn-comment-icon"></div>
<div id="kcn-comment-count"></div>
</div>
<div id="kcn-pointer" class="hidden"></div>
<div id="kcn-comment-container" class="hidden">
<div class="kcn-notification-header">
New User posted their first comment
</div>
<div class="kcn-card-container">
</div>
<div class="kcn-notification-footer">
</div>
</div>
<template id="kcn-card">
<div class="kcn-card-wrapper" data-notification-id="">
<div class="kcn-single-comment-container">
<div class="kcn-comment-text">
this is comment text   
</div>
<div class="keeda-posts-link-div">
<a class="keeda-posts-link" href="#" target="_blank">Link</a>
</div>
<div class="kcn-action">
<div class="approve">
👍 Approve
</div>
<div class="reject">
👎 Reject &amp; ban
</div>
<div class="delete">
❌ Delete
</div>
</div>
</div>
</div>
</template>
</div>                    <div class="keeda-search" onclick="window.location='/find';">
<div class="keeda-search-icon"></div>
</div>
</div>
<div id="keeda-profile-container">
<div class="logged-out hidden">
<a class ="login-cta" href="#">Log in</a>
</div>
<div class="toggle hidden">
<style>
.popup .profile-intro {
border-bottom: 1px solid #E9E9E9;
padding: 20px;
display: flex;
}
#user-profile #profile-link {
color: #666666;
text-decoration: underline;
}
.profile-actions .action-img {
margin-right: 10px;
vertical-align: middle;
width: auto;
}
.popup .profile-actions {
height: auto;
padding: 15px 20px;
font-weight: 500;
max-height: 450px;
overflow-y: scroll;
overflow-x: hidden;
}
.profile-actions::-webkit-scrollbar {
-webkit-appearance: none;
width: 7px;
}
.profile-actions::-webkit-scrollbar-thumb {
border-radius: 4px;
background-color: rgba(0,0,0,.5);
box-shadow: 0 0 1px rgba(255,255,255,.5);
}
.profile-actions ul {
display: flex;
flex-direction: row;
flex-wrap: wrap;
padding: 5px 0;
color: #999999;
font-size: 16px;
}
.profile-actions ul li {
padding: 8px 0;
flex: 50%;
font-size: 16px;
}
.profile-actions li a {
display: block;
width: 100%;
text-decoration: none;
color: #999999;
}
.profile-actions span {
font-size: 16px;
}
.profile-pic-div #profile-pic {
border-radius: 50%;
}
.logout-action a {
display: block;
width: 100%;
color: #999999 !important;
text-decoration: none !important;
}
.logout-action:hover a {
transform: scale(1.01);
color: #D32F2F !important;
}
.popup .logout-action {
padding: 5px;
color: #999999;
text-align: center;
vertical-align: middle;
border-top: 1px solid #E9E9E9;
border-bottom: 1px solid #E9E9E9;
margin: 0 15px 15px 15px;
font-weight: 500;
}
#profile-menu-popup {
width: 410px !important;
height: auto;
border-radius: 6px;
right: 0;
top: 45px;
background: #FFFFFF;
box-sizing: border-box;
box-shadow: -1px 6px 12px rgba(0, 0, 0, 0.1);
z-index: 10000;
overflow: hidden;
position: absolute;
border: 1px solid #E9E9E9;
cursor: initial;
}
.profile-intro #user-name {
display: block;
font-size: 16px;
font-weight: 700;
margin-left: 0;
}
.profile-intro #user-status {
display: block;
font-size: 14px;
font-weight: 500;
color: #D32F2F;
}
.profile-intro #user-profile {
display: block;
font-size: 14px;
font-weight: 400;
}
.profile-pic-div {
flex: 0.2;
}
.profile-info-div {
flex: 0.8; padding: 0 10px;
}
.popup .profile-actions {
height: auto;
}
.profile-actions li:hover {
color: #D32F2F !important;
transform: scale(1.01);
}
.profile-actions li:hover a {
color: #D32F2F !important;
}
.popup .logout-action {
font-size: 16px;
}
</style>
<div id="profile-menu-popup" class="popup hidden">
<div class="profile-intro">
<div class="profile-pic-div" onclick="uploadPic();"><a href="/edit-profile"><img id="profile-pic" alt="default-profile-pic" width="68" height="68" src="//staticg.sportskeeda.com/skm/assets/profile-pic-upload.svg"/></a></div>
<div class="profile-info-div">
<span id="user-name"></span>
<span id="user-status"></span>
<span id="user-profile" onclick="manageProfile();"><a id="profile-link">Manage your profile</a></span>
</div>
</div>
<div class="profile-actions">
<div class="editing-actions">
<div><img height="24" width="24" alt="editing-icon" class="action-img" src="//staticg.sportskeeda.com/skm/assets/editing.svg"/><span class="action-text">Editing</span></div>
<ul>
<li id="article-queue-link"><a href="/creator/content-dashboard">Article Queue</a></li>
<li id="video-queue-link"><a href="/creator/video-queue">Video Queue</a></li>
<li id="edit-stats"><a href="/editor/editing-stats-dashboard">Editing Stats</a></li>
<li id="writers-link"><a href="/creator">Writer Home</a></li>
</ul>
</div>
<div class="seo-actions">
<div><img height="24" width="24" alt="seo-icon" class="action-img" src="//staticg.sportskeeda.com/skm/assets/seo.svg"/><span class="action-text">SEO</span></div>
<ul>
<li id="redirection-admin"><a href="/admin/redirect-urls">Redirection Admin</a></li>
<li id="wiki-submissions-link"><a href="/taxonomy/gaming-wiki-edits">Gaming Wiki Edits</a></li>
<li id="taxonomy-link"><a href="/taxonomy">Taxonomy Home</a></li>
<li id="edit-site-menu"><a href="/creator/menu-edit">Edit Site Menu</a></li>
<li id="mappings-dashboard-link"><a href="/admin/mapping-dashboard">Mapping Dashboard</a></li>
<li id="tagPages-link"><a href="/taxonomy/post_tag">Tag Pages</a></li>
</ul>
</div>
<div class="community-actions">
<div><img height="24" width="24" alt="community-icon" class="action-img" src="//staticg.sportskeeda.com/skm/assets/community.svg"/><span class="action-text">Community</span></div>
<ul>
<li id="social-feed-queue-link"><a href="/creator/social-queue">Social Feed Queue</a></li>
<li id="feed-center-link"><a href="/feed-center">Feed Center</a></li>
<li id="notification-center-link"><a href="/admin/notification-center">Notification Center</a></li>
<li id="new-affiliate-link"><a href="/affiliate-v2">Affiliate Home</a></li>
<li id="manage-page-link"><a href="/page/manage">Manage Pages</a></li>
<li id="bottom-tagline-dashboard-link"><a href="/admin/bottom-tagline-dashboard">Bottom Tagline Dash</a></li>
<li id="timeless-posts-manager-link"><a href="/admin/timeless-posts-dashboard">Timeless Posts</a></li>
</ul>
</div>
</div>
<div class="logout-action">
<a href="https://a-login.sportskeeda.com/hi/logout?next='+ window.location.origin + window.location.pathname + window.location.search +'">Logout</a>
</div>
</div>
<script>
function manageProfile() {
gtag('event', 'MangeProfileClicked');
}
function uploadPic() {
gtag('event', 'ProfilePictureClicked');
}
document.addEventListener("click", function(event) {
// If user either clicks outside the popup
if (!event.target.closest("#profile-menu-popup") && !event.target.classList.contains("toggle")) {
addClass($("#profile-menu-popup"), "hidden");
}
}, false
)
</script>
</div>
</div>
</div>
</div>
<script type="text/javascript">
function isScrolledIntoView(el, topOffset) {
if(!topOffset) {
topOffset = 0;
}
var elemTop = el.getBoundingClientRect().top;
var elemBottom = el.getBoundingClientRect().bottom;
var elemLeft = el.getBoundingClientRect().left;
if (elemTop === 0 && elemBottom === 0) {
return false;
}
return ((elemTop < window.innerHeight + topOffset) && elemLeft < window.innerWidth);
}
function lazyLoadAll() {
var lazyElements = $all('[data-lazy]');
for (var i = 0; i < lazyElements.length; i++) {
var lazyElement = lazyElements[i];
if (isScrolledIntoView(lazyElement)) {
lazyLoadElement(lazyElement);
}
}
}
function lazyLoadElement(lazyElement) {
var dataLazy = lazyElement.getAttribute('data-lazy');
if(lazyElement.tagName == 'IMG') {
lazyElement.src = dataLazy;
} else {
lazyElement.style.backgroundImage = 'url(' + dataLazy + ')';
}
addClass(lazyElement, 'lazy-img-bg');
lazyElement.removeAttribute('data-lazy');
}
</script>
<noscript>
<style>
.lazy-img {
display:none !important;
}
</style>
</noscript>        <script type="text/javascript">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</script>
<!-- Homepage main menu links -->
<div style="height:50px;width:100%; display:block;">
</div>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"item": {
"@id": "https://hindi.sportskeeda.com/health-and-fitness",
"name": "Hindi - Health and Fitness"
}
}
,
{
"@type": "ListItem",
"position": 2,
"item": {
"@id": "https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi",
"name": "फ़ीचर"
}
}
]
}
</script>
<div class="bc-holder" style="width: 100%;">
<div class="container desktop-bc-container">
<ul class="keeda-breadcrumb">
<li><a href="/"><img style="width:12px;padding-top:5px;" width="12" height="15" src="https://staticg.sportskeeda.com/skm/assets/images/breadcrumb-home.svg" alt="Sports News" /></a></li>
<li class="masthead-breadcrumb">
<a href="/health-and-fitness">Hindi - Health and Fitness</a>
</li>
<li class="masthead-breadcrumb">
<a>फ़ीचर</a>
</li>
</ul>
</div>
</div>
<div class="leadercont" style="background: transparent; position: relative; width: 1100px; z-index: 2; margin: 0 auto; text-align: center;">
<div class="leaderadcont">
<div class="ad-unit-72890_1 hide-in-editor">                                                                        
<div class="ad-container" id=''
style="
min-height: 114px;
width: 100%; text-align: center;clear:both;
">
<div class="ad-declare-explicit"></div>
<!-- /11446729/Desktop_72890_1 -->
<div id='div-gpt-ad-1471942863237-0' class="">
<script>
if (typeof displayAdSlot !== 'undefined') {
displayAdSlot('div-gpt-ad-1471942863237-0');
}
</script>
</div>
</div>
<script>
window.addEventListener('message',function(e) {
if(e.data && e.data.SKNative) {
var expansionEligibleIframe = e.source.frameElement;
expansionEligibleIframe.style.width = "100%";
}
});
</script>
</div>
<!-- Interstitial -->
<div id='div-gpt-ad-1423053234910-0' style='width:1px; height:1px;'>
<script type='text/javascript'>
if(typeof displayAdSlot !== 'undefined') {
displayAdSlot('div-gpt-ad-1423053234910-0');
}
</script>
</div>
</div>
<h1 id="heading" class="title">कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai</h1>
<div class="intro">
<figure class="image"><noscript><img class="sk-app-thumbnail" alt="&#2325;&#2376;&#2354;&#2381;&#2358;&#2367;&#2351;&#2350; &#2324;&#2352; &#2357;&#2367;&#2335;&#2366;&#2350;&#2367;&#2344; &#2337;&#2368; &#2325;&#2367;&#2360;&#2350;&#2375;&#2306; &#2346;&#2366;&#2351;&#2366; &#2332;&#2366;&#2340;&#2366; &#2361;&#2376;" src="https://staticg.sportskeeda.com/editor/2022/05/653d5-16528899194315-1920.jpg"></noscript><img class="lazy-img" width="1200" height="650" data-img="https://staticg.sportskeeda.com/editor/2022/05/653d5-16528899194315-1920.jpg" srcset="https://staticg.sportskeeda.com/editor/2022/05/653d5-16528899194315-1920.jpg?w=720 720w ,https://staticg.sportskeeda.com/editor/2022/05/653d5-16528899194315-1920.jpg?w=840 840w, https://staticg.sportskeeda.com/editor/2022/05/653d5-16528899194315-1920.jpg?w=1200 1200w , https://staticg.sportskeeda.com/editor/2022/05/653d5-16528899194315-1920.jpg 1920w" sizes="(max-width: 360px) 720w,(max-width: 420px) 840w,(max-width: 600px) 1200w, 1920w" alt="&#2325;&#2376;&#2354;&#2381;&#2358;&#2367;&#2351;&#2350; &#2324;&#2352; &#2357;&#2367;&#2335;&#2366;&#2350;&#2367;&#2344; &#2337;&#2368; &#2325;&#2367;&#2360;&#2350;&#2375;&#2306; &#2346;&#2366;&#2351;&#2366; &#2332;&#2366;&#2340;&#2366; &#2361;&#2376;" data-img-low="https://staticg.sportskeeda.com/editor/2022/05/653d5-16528899194315-1920.jpg" src="data:image/svg+xml,&lt;svg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201200%20650%22&gt;&lt;/svg&gt;"><figcaption class="sk-app-thumbnail">&#2325;&#2376;&#2354;&#2381;&#2358;&#2367;&#2351;&#2350; &#2324;&#2352; &#2357;&#2367;&#2335;&#2366;&#2350;&#2367;&#2344; &#2337;&#2368; &#2325;&#2367;&#2360;&#2350;&#2375;&#2306; &#2346;&#2366;&#2351;&#2366; &#2332;&#2366;&#2340;&#2366; &#2361;&#2376;</figcaption></figure>
</div>
<div style="width:100%;">
<style>
.country-flag {
background-image: url(//staticg.sportskeeda.com/skm/assets/flags/16/in.png);
background-repeat: no-repeat;
display: block;
width: 16px;
height: 16px;
}
div i {
display : inline-block !important;
vertical-align: middle;
margin-right: 4px;
}
.post-profile {
width: 560px;
padding: 5px 0;
box-sizing: border-box;
margin: 0 32px;
overflow: hidden;
background-color: #F5F5F5;
display: flex;
padding: 8px 18px!important;
}
.post-profile .image{
width: 40px;
height: 40px;
background-size: cover;
border-radius: 100%;
box-shadow: 0 2px 10px 0 rgba(0, 0, 0, 0.05);
margin: 0 16px;
}
.post-profile .mid-info{
width:48%;
margin-left: 10px;
clear: none;
}
.mid-info .name {
float:left;
}
.font-style {
color: #2D2D2D!important;
line-height: 17px;
}
.post-profile .mid-info .name a{
font-size: 14px;
text-decoration:none;
}
.post-profile .mid-info .add-info{
clear: both;
font-size: 10px;
}
.post-profile .right-info {
width:59%;
clear:both;
text-align:right;
font-size: 12px;
font-weight: normal;
font-style: normal;
font-stretch: normal;
line-height: 1.67;
letter-spacing: normal;
text-align: left;
color: #ababab;
display:block;
}
.post-profile .right-info .down span img {
background: transparent !important;
width: 14px;
height: 14px;
margin: 0px 3px 0px 0px;
display: block;
float: left;
opacity: .6;
}
.post-profile .right-info .top > span+span:before {
content: "|\00a0"; padding: 1px 1px; display: inline-block;
}
div.seperator{
border: solid 1px #e8e8e8;
height: 30px;
clear:none;
margin: 6px 0px 0px 15px;
}
div.post-share {
clear:none;
margin-top: 7px;
display: block;
width: 229px;
}
i.writer-title-tick {
width: 12px;
height: 12px;
margin-left: 4px;
background-image:url('//staticg.sportskeeda.com/skm/assets/images/verified_tick.png');
display: inline-block !important;
vertical-align: sub;
margin-bottom: 2px;
}
.btn-follow {
height: 20px;
border-radius: 3px;
font-size: 11px;
font-weight: 500;
font-style: normal;
font-stretch: normal;
line-height: 18px;
letter-spacing: normal;
text-align: left;
outline: none;
cursor: pointer;
margin-left: 6px;
}
.btn-follow.follow {
color: #d32f2f;
background-color: #ffffff;
border: solid 1px #d32f2f;
}
.btn-follow.follow:hover {
background-color: rgba(211, 47, 47, 0.05);
border: solid 1px #d74343;
}
.btn-follow.following {
width: 100px;
position: relative;
color: #808080;
background-color: #f5f5f5;
border: solid 1px #f5f5f5;
}
.btn-follow.following:hover {
background-color: #e8e8e8;
border: solid 1px #e8e8e8;
}
.btn-follow.following::after {
position: absolute;
content: "×";
top: -1px;
right: 0px;
width: 14px;
height: 14px;
font-size: 14px;
}
.top, .down {
color: #808080;
}
</style>
<style>
.comments-total-container {
float: left;
clear: none !important;
text-align: revert;
justify-content: flex-end;
}
.comments-total a, .comments-total-container a {
display: flex;
align-items: center;
padding: 0px 2px 0px 10px;
color: #757575;
text-decoration: none;
font-size: 16px;
font-weight: 200;
}
.comments-total-container img {
width: 28px;
height: 28px;
object-fit: cover;
background: none;
}
.comments-total-container span.comments-count {
margin-left: 4px;
font-weight: 400;
font-size: 18px;
}
.comments-like-div {
display: flex;
border-top: 1px solid #E9E9E9;
border-bottom: 1px solid #E9E9E9;
overflow: visible !important;
padding: 6px 0;
position: relative;
}
.comments-like-div .story-user-actions {
justify-content: flex-end;
}
.article-meta {
width: 560px;
text-align: left;
margin: 16px 32px 0;
color: #999999;
font-size: 14px;
}
.section-pill-container {
display: inline-block;
margin-left: 10px;
vertical-align: middle;
}
.section-pill {   
padding: 2px 8px;
border-radius: 2px;
vertical-align: top;
font-size: 10px;
text-transform: uppercase;
}
.section-pill.pill-info {
color: #0b65f0;
background: #e1ebff;
}
.timezone-date p {
width: auto;
margin-right: 10px;
}
.section-container{
margin-left: 10px;
vertical-align: middle;
display: inline-block;
}
.section-container.pill-tag {
position: absolute;
bottom: 0px;
left: 69px;
top: 25px;
}
.author-image {
display: inline-block;
}
.author-image img {
height: 40px !important;
width: 40px !important;
vertical-align: middle;
}
.name-author {
display: inline-block;
float: left;
font-weight: 400;
font-size: 14px !important;
text-align: left;
width: 55%;
padding: 0 10px;
}
.name-author a {
text-decoration: none;
}
.name-author div {
text-decoration: none !important;
color: #2D2D2D;
}
.name-author .title {
text-transform: uppercase;
font-style: normal;
font-weight: normal;
font-size: 10px;
line-height: 12px;
color: #666666;
margin-top: 0;
}
.follow-btn {
background: #F5F5F5;
border: 1px solid #D32F2F;
box-sizing: border-box;
border-radius: 30px;
padding: 2px 10px;
color: #D32F2F;
margin: auto;
cursor: pointer;
}
.follow-btn img {
margin-right: 5px;
height: 10px;
width: 10px;
}
.article-meta .date-pub {
display: inline-block;
}
.user-story {
width: 560px;
margin: 16px 32px;
display: flex;
overflow: visible !important;
}
.name-author {
padding: 4px 10px;
width: 65%;
}
</style>
<div class="user-story">
<script type="text/javascript">
function updateLikesCountOnUI(res) {
if (typeof res['total_reactions'] !== "undefined" && typeof fetchLatestLikesCount !== "undefined" && typeof res['has_user_reacted'] !== "undefined") {
fetchLatestLikesCount(res);
}
}
</script>
<script>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</script>
<style>
.reaction-count {
margin-inline-start: unset !important;
min-width: auto !important;
min-height: auto !important;
display: flex;
}
.reaction-count a {
cursor: pointer;
padding-top: 1px;
}
.reaction-count img {
background: none;
display: inline-block;
}
.likes-count {
align-self: center;
font-size: 12px !important;
color: #999999 !important;
font-weight: 500;
padding: 0 0 0 4px !important;
}
.comments-count-container {
margin-inline-start: unset !important;
min-width: auto !important;
min-height: auto !important;
width: auto !important;
padding: 0 !important;
}
.comments-count-container a {
text-decoration: none  !important;
}
.comments-count-container span.comments-count {
font-weight: 500;
font-size: 12px !important;
line-height: 28px !important;
color: #999999 !important;
vertical-align: middle;
}
.action-counts {
display: flex;
align-items: center;
width: 100%;
flex: 1;
flex-shrink: 0;
justify-content: flex-start;
}
.reaction-count .separator-img {
height: 2px !important;
width: 2px !important;
margin: 0 10px !important;
}
.separator-img img {
height: 100%;
width: 100%;
vertical-align: middle;
}
.comments-like-div {
display: flex;
}
</style>
<div class="action-counts" >
<div class="reaction-count" id="like-button">
<span class="likes-count"></span>
</div>
<div class="comments-count-container " style="margin-left: 0 !important;">
<a href="#keeda-comments-container" title="Total comments">
<span class="comments-count comment-text">
</span>
</a>
</div>
</div>
<style>
.comment-action {
text-decoration: none !important;
}
</style>
<div class="story-user-actions" >
<div class="user-action-element like-action"  onmouseover="actionHover(this);" onmouseout="actionUnhover(this);">
<div class="reaction-bottom share-container">
<button type="button" class="reaction-text-holder share-btn" data-id="3580720" data-likes-count="0" data-url="https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi" data-title="कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai" onclick="showReactionsPost(this);" data-reaction-type=false data-type="" data-page-type="article" data-feed= >
<img src="//staticg.sportskeeda.com/skm/assets/feed/ic-like-gray.svg" alt="like story" width="16" height="16" />
<span class="action-text">Like</span>
</button>
<div class="reaction-icons-container hidden"  style="">
<div class="reaction-icon-holder" title="Like reaction" onclick="togglePostLike(this)" data-type="like" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-like.svg" alt="like reaction icon" height="38" width="38"/>
<span class="reaction-text">Like</span>
</div>
<div class="reaction-icon-holder" title="Excited reaction" onclick="togglePostLike(this)" data-type="excited" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-excited.svg" alt="exited reaction icon" height="38" width="38"/>
<span class="reaction-text">Excited</span>
</div>
<div class="reaction-icon-holder" title="Happy reaction" onclick="togglePostLike(this)" data-type="happy" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-happy.svg" alt="happy reaction icon" height="38" width="38"/>
<span class="reaction-text">Happy</span>
</div>
<div class="reaction-icon-holder" title="Anxious reaction" onclick="togglePostLike(this)" data-type="anxious" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-anxious.svg" alt="anxious reaction icon" height="38" width="38"/>
<span class="reaction-text">Anxious</span>
</div>
<div class="reaction-icon-holder" title="Angry reaction" onclick="togglePostLike(this)" data-type="angry" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-angry.svg" alt="angry reaction icon" height="38" width="38"/>
<span class="reaction-text">Angry</span>
</div>
<div class="reaction-icon-holder" title="Sad reaction" onclick="togglePostLike(this)" data-type="sad" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-sad.svg" alt="sad reaction icon" height="38" width="38"/>
<span class="reaction-text">Sad</span>
</div>
</div>
</div>
</div>
<button class="user-action-element comment-action" data-type="article" data-id="3580720" data-title="&#2325;&#2376;&#2354;&#2381;&#2358;&#2367;&#2351;&#2350; &#2324;&#2352; &#2357;&#2367;&#2335;&#2366;&#2350;&#2367;&#2344; &#2337;&#2368; &#2325;&#2367;&#2360;&#2350;&#2375;&#2306; &#2346;&#2366;&#2351;&#2366; &#2332;&#2366;&#2340;&#2366; &#2361;&#2376;- Calcium aur Vitamin D kisme paya jata hai" data-href="https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi" data-thumbnail="https://staticg.sportskeeda.com/editor/2022/05/653d5-16528899194315-1920.jpg" onclick="toggleFeedComments(this)" onmouseover="actionHover(this);" onmouseout="actionUnhover(this);">
<img src="//staticg.sportskeeda.com/skm/assets/feed/ic-comment-gray.svg" alt="comment" width="20" height="20" />
<span class="action-text">Comment</span>
</button>
<div class="user-action-element share-action" onmouseover="actionHover(this);" onmouseout="actionUnhover(this);">
<style type="text/css">
.content-holder div {
overflow: visible;
}
.post-profile {
overflow: visible;
}
.share-text-holder button {
display: inline-flex;
padding: 4px 0;
background: none;
border: 1px solid transparent;
box-sizing: border-box;
border-radius: 40px;
cursor: pointer;
}
.forward-share {
width: 16px !important;
height: 16px !important;
display: inline-block !important;
background: none !important;
}
.share-text-holder span {
font-size: 14px;
font-weight: 500;
color: #A7A7A7;
padding-left: 2px;
}
.share-icon-holder {
width: 40px;
height: 40px;
margin: 0px 4px;  
}
.share-top {
float:right;
position: relative;
}
.share-top .share-icon-holder {
margin: 0px 8px; 
text-decoration:none;
}
.share-icon-holder img {
width: 40px;
height: 40px;
display: inline-block !important;
background: none !important;
vertical-align: top;
}
.share-icons-container {
height: 56px;
background: #FFFFFF;
border: 1px solid #E9E9E9;
box-sizing: border-box;
box-shadow: 0px 6px 12px rgb(0 0 0 / 10%);
border-radius: 50px;
display: flex;
justify-content: center;
align-items: center;
padding: 8px 5px;
position: absolute;
top: 40px;
z-index: 999;
}
</style>
<div class="share-top share-container">
<button type="button" class="share-text-holder share-btn" data-url="https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi" data-title="कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai" onclick="shareContent(this, 'top', 'ShareArticleClick', 'ShareArticle')">
<img src="//staticg.sportskeeda.com/skm/assets/feed/ic-share-gray.svg" width="16" height="16" class="forward-share" alt="share icon"/>
<span class="action-text">Share</span>
</button>
<div class="share-icons-container hidden">
<a class="share-icon-holder" href="https://web.whatsapp.com/send?text=%E0%A4%95%E0%A5%88%E0%A4%B2%E0%A5%8D%E0%A4%B6%E0%A4%BF%E0%A4%AF%E0%A4%AE+%E0%A4%94%E0%A4%B0+%E0%A4%B5%E0%A4%BF%E0%A4%9F%E0%A4%BE%E0%A4%AE%E0%A4%BF%E0%A4%A8+%E0%A4%A1%E0%A5%80+%E0%A4%95%E0%A4%BF%E0%A4%B8%E0%A4%AE%E0%A5%87%E0%A4%82+%E0%A4%AA%E0%A4%BE%E0%A4%AF%E0%A4%BE+%E0%A4%9C%E0%A4%BE%E0%A4%A4%E0%A4%BE+%E0%A4%B9%E0%A5%88-+Calcium+aur+Vitamin+D+kisme+paya+jata+hai https%3A%2F%2Fhindi.sportskeeda.com%2Fhealth-and-fitness%2Fsources-of-calcium-and-vitamin-d-in-hindi%3Futm_source%3Dwww.sportskeeda.com%26utm_medium%3Dwhatsapp%26utm_campaign%3DShareArticle " target="_blank" title="Share on Whatsapp" onclick="ga_event('ShareArticleClick', 'Desktop-Top', 'WhatsApp'); gtag('event', 'social share', { 'event_category': 'NTG social', 'event_label': 'whatsapp', 'non_interaction' : false })">
<img src="//staticg.sportskeeda.com/skm/assets/share/whatsapp-icon.svg" alt="Whatspp share icon" />
</a>
<a class="share-icon-holder" href="https://facebook.com/sharer/sharer.php?u=https%3A%2F%2Fhindi.sportskeeda.com%2Fhealth-and-fitness%2Fsources-of-calcium-and-vitamin-d-in-hindi%3Futm_source%3Dwww.sportskeeda.com%26utm_medium%3Dfacebook%26utm_campaign%3DShareArticle"
target="_blank" rel="noopener noreferrer" title="Share on Facebook" onclick="ga_event('ShareArticleClick', 'Desktop-Top', 'Facebook'); gtag('event', 'social share', { 'event_category': 'NTG social', 'event_label': 'facebook', 'non_interaction' : false })">
<img src="//staticg.sportskeeda.com/skm/assets/share/facebook-icon.svg" alt="Facebook share icon" />
</a>
<a class="share-icon-holder" href="https://twitter.com/share?url=https%3A%2F%2Fhindi.sportskeeda.com%2Fhealth-and-fitness%2Fsources-of-calcium-and-vitamin-d-in-hindi%3Futm_source%3Dwww.sportskeeda.com%26utm_medium%3Dtwitter%26utm_campaign%3DShareArticle&amp;text=%E0%A4%95%E0%A5%88%E0%A4%B2%E0%A5%8D%E0%A4%B6%E0%A4%BF%E0%A4%AF%E0%A4%AE+%E0%A4%94%E0%A4%B0+%E0%A4%B5%E0%A4%BF%E0%A4%9F%E0%A4%BE%E0%A4%AE%E0%A4%BF%E0%A4%A8+%E0%A4%A1%E0%A5%80+%E0%A4%95%E0%A4%BF%E0%A4%B8%E0%A4%AE%E0%A5%87%E0%A4%82+%E0%A4%AA%E0%A4%BE%E0%A4%AF%E0%A4%BE+%E0%A4%9C%E0%A4%BE%E0%A4%A4%E0%A4%BE+%E0%A4%B9%E0%A5%88-+Calcium+aur+Vitamin+D+kisme+paya+jata+hai&amp;via=SK_Hindi&amp;related=sportskeeda" 
target="_blank" rel="noopener noreferrer" title="Share on Twitter" onclick="ga_event('ShareArticleClick', 'Desktop-Top', 'Twitter'); gtag('event', 'social share', { 'event_category': 'NTG social', 'event_label': 'twitter', 'non_interaction' : false })">
<img src="//staticg.sportskeeda.com/skm/assets/share/twitter-icon.svg" alt="Twitter share icon" />
</a>
</div>
</div>
<script>
var url = "https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi"
var title = "कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai"
var text = "कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai"
var nativeShareEnabled = false;
window.addEventListener("DOMContentLoaded", function() {
if (navigator && navigator.share) {
nativeShareEnabled = true;
} else {
console.log("Native share is not supported!")
}
})
function shareContent(ele, btnPosition, eventName, campaignName) {
if (nativeShareEnabled) {
url = url + "?utm_source=www.sportskeeda.com&utm_medium=native&utm_campaign=" + campaignName
navigator.share({ title, url, text })
.then(function() {
ga_event(eventName, 'Desktop-native-' + (btnPosition || 'top'), '')
})
.catch(function(err) {
console.log("Error while sharing article using native share", err)
});
}
else {
var shareContainers = ele.parentElement.parentElement.querySelectorAll(".share-icons-container");
if (shareContainers && shareContainers.length) {
for(var i = 0; i < shareContainers.length; i++) {
shareContainers[i].classList.remove("hidden")
}
}
}
}
window.addEventListener("mouseup", function() {
var shareContainers = document.getElementsByClassName("share-icons-container");
if (shareContainers && shareContainers.length) {
for(var i = 0; i < shareContainers.length; i++) {
if (Array.from(shareContainers[i].classList).indexOf("hidden") === -1) {
shareContainers[i].classList.add("hidden")
}
}
}
})
</script>
</div>
</div>
<script>
function actionHover(ele) {
if (hasClass(ele, "like-action") && ele.querySelector('button').dataset.reactionType == "false") {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-like-red-new.svg")
} else if (hasClass(ele, "comment-action")) {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-comment-red.svg")
} else if (hasClass(ele, "share-action")) {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-share-red.svg")
}
}
function actionUnhover(ele) {
if (hasClass(ele, "like-action") && ele.querySelector('button').dataset.reactionType == "false") {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-like-gray.svg");
} else if (hasClass(ele, "comment-action")) {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-comment-gray.svg")
} else if (hasClass(ele, "share-action")) {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-share-gray.svg")
}
}
window.addEventListener("mouseup", function() {
var reactionContainers = $all(".reaction-icons-container");
if (reactionContainers && reactionContainers.length) {
for(var i = 0; i < reactionContainers.length; i++) {
if (Array.from(reactionContainers[i].classList).indexOf("hidden") === -1) {
reactionContainers[i].classList.add("hidden")
}
}
}
})
</script>
</div>
<div class="post-profile" style="background-color: #F5F5F5; display: flex;">
<div class="author-image">
<a href="/profile/ritu-raj-1vcei"><img src="https://keedag.sportskeeda.com/user-pic/591532-1643788095-200.jpg?w=80" alt="Ritu Raj" height="40" width="40" style="border-radius: 100%;"></a>
</div>
<div class="name-author">
<a href="/profile/ritu-raj-1vcei"><div class="font-style">Ritu Raj</div></a>
<a href="/profile/ritu-raj-1vcei">
<div class="title">
ANALYST
</div>
</a>
</div>
<div class="follow-btn"><img src="//staticg.sportskeeda.com/skm/assets/plus-icon.svg" height="10" width="10" alt="follow"><span>Follow</span></div>
<div style="margin: auto;"><a href="/profile/ritu-raj-1vcei"><img src="//staticg.sportskeeda.com/skm/assets/right-arrow.svg" height="12" width="7" alt="visit"></a></div>
</div>
<div class="article-meta">
<div class="date-pub timezone-date" data-iso-string="2022-05-18T21:35:33+05:30">
<span>Modified May 18, 2022 09:35 PM IST</span>
</div>
<div class="section-pill-container">
<span class="section-pill pill-info">फ़ीचर</span>
</div>
</div>
<script>
if ('May 18, 2022 09:35 PM IST'.indexOf(' ') === -1 && !1) {
var friendly_date = getFriendlyModifiedTime('May 18, 2022 09:35 PM IST');
document.querySelector(".article-modified-date").textContent = "Modified " + friendly_date;
}
if ('May 18, 2022 09:35 PM IST'.indexOf('<p>')  > -1) {
addClass($('.section-container'), 'pill-tag');
}
</script>
</div>
</div>
<div class='container editor-width-100-pc'>
<div class="fragments-container">
<div class="content-holder">
<div class="feed-header">
</div>
<style>
.post-excerpt{
padding:8px 24px;
}
body{
background:#fff;
}
body .editor-width-100-pc {
overflow:visible;
}
.fragments-container .content-holder {
overflow:visible;
}
.article-related .keeda_widget_header {
font-size: 23px;
font-weight: bold;
margin-bottom:15px;
}
.leaderadcont{
background: #fff;
}
#article-content h4{
float: left;
padding: 10px 24px;
clear:both;
font-size: 17px;
}
.tags-wrapper {
display:block;
width:100%;
margin-top:10px;
padding-bottom:10px;
}
.tags{
width: 80%;
float: left;
clear: none !important;
margin-left: 7px;
overflow-x: scroll !important;
white-space: nowrap;
height: 48px;
padding-top: 8px;
}
a.tag {
border-radius: 3px;
background-color: #f7f7f7;
color: #666;
padding: 4px 10px;
font-size: 12px;
margin-right: 7px;
margin-top: 7px;
text-decoration:none;
}
a.tag:hover{
text-decoration: none;
}
.article-bottom-info {
display: flex;
justify-content: space-between;
padding: 0 8px;
align-items: center;
}
.publisher-name{
font-size: 10px;
text-align: right;
color: #757575;
display: block;
margin-right: 5px;
}
#article-content h1 {
display: inline-block;
margin: 6px 24px;
padding-top:15px;
}
#articleLeftAdCont {
width:260px;
float:left;
height:800px;
position:relative;
overflow:visible;
}
#article-content p a{
font-family: "Georgia", serif;
}
.rightStickyTopWrap {
position:relative;
overflow:visible;
height:700px;
clear:both;
}
.rightStickyTop {
position:sticky;
top:90px;
height:600px;
}
.comments-like-div {
display: flex;
position: relative;
}
</style>
<style>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</style>
<style>
.yt-aspect-ratio-container {
position: relative;
display: block;
}
.yt-aspect-ratio-container iframe {
position: absolute;
top: 0;
left: 0;
width: 100%;
height: 100%;
border-radius: 4px;
}
</style>
<div id="article-content" class="keeda_widget"
data-postid="3580720" data-slug-id="1105028" >
<p><strong>Sources of Calcium and Vitamin D in hindi:</strong> उम्र बढ़ने के साथ ही जोड़ों में दर्द की समस्या बढ़ जाती है। हड्डियां कमजोर होने लगती है। ऐसे में अपने खान-पान पर बेहद ही ध्यान देना होता है, खासकर उनपर जो हमारे हड्डियों को मजबूती प्रदान करे। कैल्शियम और विटामिन डी स्वस्थ हड्डियों के दो मुख्य घटक हैं। जहां कैल्शियम आपकी हड्डियों और दांतों के लिए लाभकारी है। वहीं, विटामिन डी कैल्शियम के अवशोषण और हड्डियों के विकास में सुधार करने मदद करता है। ये पोषक तत्व बढ़ती उम्र में बेहद ही महत्वपूर्ण हैं। ऑस्टियोपोरोसिस या गठिया से पीड़ित लोग कैल्शियम और विटामिन डी वाले आहार का सेवन करने से छुटकारा पा सकते हैं।</p>
<h2>इन 6 चीजों में कैल्शियम और विटामिन डी पाया जाता है</h2><style>
.connatix-container #connatixHolder {
position: absolute;
top: 0;
left: 0;
bottom: 0;
right: 0;
}
.connatix-container {
width: 100%;
padding-top: 60%;
position: relative;
}
</style>
<script>
var loadConnatix = false;
(function(){
var connatixFired = false;
function loadConnatixTag() {
if(connatixFired || (!!adopsdecisions.gdprApplies && !loadConnatix)) {
return;
}
connatixFired = true;
!function(n){if(!window.cnx){window.cnx={},window.cnx.cmd=[];var t=n.createElement('iframe');t.src='javascript:false'; t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.player.js?cid=22243a37-a7f3-439e-9587-3a573b687987',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
var connatixCheckerInterval = setInterval(function() {
if(window.cnx) {
clearInterval(connatixCheckerInterval);
initialiseConnatixPlayer();
}
},100)
}
function initialiseConnatixPlayer() {
var script_tag = document.createElement('script');
script_tag.type = 'text/javascript';
script_tag.setAttribute("id","b437f267a74f4ba597cb7f030b908708");
script_tag.text = `(new Image()).src = 'https://capi.connatix.com/tr/si?token=92f64fb9-cc28-41f8-8d6a-d598ecbc2287&cid=22243a37-a7f3-439e-9587-3a573b687987';cnx.cmd.push(function() { cnx({ playerId: "92f64fb9-cc28-41f8-8d6a-d598ecbc2287"}).render("b437f267a74f4ba597cb7f030b908708");});`;
document.getElementById("connatixHolder").appendChild(script_tag);
}
document.addEventListener("scroll", loadConnatixTag, { once: true });
document.addEventListener("mousemove", loadConnatixTag, { once: true });
})();
</script>
<div class="connatix-container" id="container-connatix">
<div id="connatixHolder"></div>
</div>
<p><strong>सारडाइन फिश (Sardine fish for Calcium aur Vitamin D)</strong></p>
<p>सारडाइन मछली में कैल्शियम के साथ-साथ विटामिन डी का उच्च स्तर होता है। सार्डिन का सेवन ऑस्टियोपोरोसिस के जोखिम को कम करने में मदद कर सकता है। आप अपने दैनिक आहार में शामिल कर इसका लाभ उठा सकते हैं।</p>
<p><strong>सैल्मन फिश (Salmon fish is Source of Calcium aur Vitamin D)</strong></p>
<p>सैल्मन फिश में ओमेगा-3 फैटी एसिड भरपूर मात्रा में पाई जाती है। इसके साथ ही सैल्मन फिश विटामिन डी का एक बड़ा स्रोत है। स्वस्थ हृदय, मजबूत हड्डियों और ऑस्टियोपोरोसिस की रोकथाम के लिए सैल्मन को अपने आहार में शामिल किया जा सकता है।</p>
<p><strong>टूना (Eat Tuna fish for Calcium aur Vitamin D)</strong></p>
<p>टूना फिश एक वसायुक्त मछली है जो विटामिन डी का एक बड़ा स्रोत है। यानी इसमें फैट नहीं पाया जाता है। टूना फिश के सेवन से आप सूर्य की रोशनी से मिलने वाले विटामिन डी की कमी को पूरा कर सकते हैं। माना जाता है कि टूना फिश के सेवन से आप 39% विटामिन डी हासिल कर सकते हैं।</p>
<p><strong>दही (Yogurt)</strong></p>
<p>कई ऐसे खाद्य पदार्थ हैं जिनकी सेवन से आप कैल्शियम के साथ ही विटामिन डी की कमी को पूरा कर सकते हैं। दही उनमें से एक है। दही कैल्शियम और विटामिन डी की मदद से आपके शरीर में कैल्शियम के साथ ही विटामिन डी की कमी भी पूरा होगा। ये ऑस्टियोपोरोसिस को रोकने में मदद कर सकता है।</p>
<p><strong>अंडे (Benefits of Egg)</strong></p>
<p>अंडे में कई सारे पोषक तत्व होते हैं जो हमारे स्वस्थ शरीर के लिए बेहद जरूरी होते हैं। इसके सेवन से विटामिन डी की कमी को पूरा किया जा सकता है।</p>
<p><strong>दूध (Milk for Bones)</strong></p>
<p>दूध कैल्शियम का बेहतरीन स्त्रोत है। जिसके चलते बचपन से लेकर बुढ़ापे तक दूध का सेवन करना जरूरी होता है। नियमित रूप से दूध पीने से ऑस्टियोपोरोसिस के खतरे को कम किया जा सकता है। इसके साथ ही हड्डियों की मजबूती बनी रहती है और जोड़ों का दर्द भी कम हो सकता है।</p>
<style>
.related-articles-container {
position: relative;
}
.related-articles {
position: relative;
}
div.related-articles-scroll {
overflow: scroll !important;
width: 100%;
display: flex;
padding: 8px 4px;
position: relative;
}
.related-articles-scroll::-webkit-scrollbar {
display: none;
}
.article-single-related {
height: auto !important;
padding: 0 0 15px;
display: inline-block;
background-color: #fff;
box-shadow: 0 2px 3px 0 rgba(0, 0, 0, 0.1);
margin-right: 10px;
vertical-align: top;
flex-shrink: 0;
width: 31.7%;
min-height: 208px;
border-radius: 8px;
overflow: hidden;
}
.article-single-related a {
color: #000;
text-decoration: none !important;
}
.article-related-image {
opacity: 1;
border-radius: 3px 3px 0 0;
background-position: center center;
background-size: cover;
}
.article-related-recommend-image {
width: 100%;
height: 130px;
border-radius: 4px 4px 0 0;
object-fit: cover;
background-position: center;
}
.article-related-title {
font-size: 14px;
font-weight: 400;
padding: 10px;
line-height: 1.4;
height: 65px;
overflow: hidden !important;
}
.related-articles-carousel-anchors div {
position: absolute;
width: 40px;
height: 40px;
top: 48%;
background: #fff;
display: flex;
align-items: center;
justify-content: center;
border-radius: 50%;
cursor: pointer;
border: 1px solid #e9e9e9;
}
.related-articles-carousel-anchors div img {
background-color: transparent;
}
.related-articles-carousel-anchors #left {
left: -20px;
}
.related-articles-carousel-anchors #right {
right: -20px;
}
.article-related-title.article-related-recommend-title {
display: block;
display: -webkit-box;
max-width: 100%;
height: 63px;
margin: 0 auto;
font-size: 14px;
line-height: 1;
-webkit-line-clamp: 3;
-webkit-box-orient: vertical;
overflow: hidden;
text-overflow: ellipsis;
line-height: 18px;
}
div.related-heading {
position: relative;
height: auto;
float: none !important;
font-size: 16px !important;
font-weight: 400;
font-family: -apple-system, BlinkMacSystemFont, "Segoe UI", "Liberation Sans", sans-serif;
color: #757575;
display: flex;
justify-content: space-between;
align-items: center;
padding: 4px 12px !important;
border-top: 2px solid #e9e9e9;
border-bottom: 2px solid #e9e9e9;
}
.related-heading .article-continues {
font-size: 14px;
}
.article-single-related:last-child {
padding: 0;
}
.related-play-button {
width: 40px;
height: 40px;
background-image: url("//staticg.sportskeeda.com/skm/assets/images/video/video-play-button.svg");
position: relative;
top: -50px;
float: right;
left: -10px;
margin-bottom: -40px;
}
@media (max-width: 768px) {
.related-articles {
padding: 8px;
}
.article-related-recommend {
min-width: 45.9%;
}
.related-heading {
padding: 4px;
padding-top: 24px;
padding-left: 10px;
}
.article-related-title {
display: inline-block;
font-size: 14px;
padding: 10px;
vertical-align: top;
color: #555;
line-height: 16px;
height: 42px;
}
.article-single-related {
margin-bottom: 12px;
}
.related-heading .also-read {
font-size: 14px;
}
.related-heading .article-continues {
font-size: 12px;
}
}
@media (max-width: 320px) {
.related-heading .also-read {
font-size: 14px;
}
.related-heading .article-continues {
font-size: 12px;
}
}
</style>
<div class="related-articles-container">
<div class="heading-article">
<div class="related-heading">
<span class="also-read">Also Read</span>
<span class="article-continues">Article Continues below</span>
</div>
</div>
<div class="related-articles" id="related-articles">
<div class="related-articles-scroll">
<div class="article-single-related article-related-recommend">
<a href="/cricket/future-fast-bowling-trio-of-indian-odi-team?ref=relatedmid">
<div class="article-related-image article-related-recommend-image" data-lazy="https://staticg.sportskeeda.com/editor/2019/08/34557-15647465533207-800.jpg?w=500">
</div>
<div class="article-related-title article-related-recommend-title">3 तेज गेंदबाज जो आने वाले समय में भारतीय वनडे टीम का नियमित हिस्सा हो सकते हैं</div>
</a>
</div>
<div class="article-single-related article-related-recommend">
<a href="/cricket/three-batsmen-could-be-a-regular-part-of-the-indian-odi-team-in-the-coming-times?ref=relatedmid">
<div class="article-related-image article-related-recommend-image" data-lazy="https://staticg.sportskeeda.com/editor/2019/08/3e9df-15655029076999-800.jpg?w=500">
</div>
<div class="article-related-title article-related-recommend-title">तीन बल्लेबाज आने वाले समय में भारतीय एकदिवसीय टीम का नियमित  हिस्सा हो सकते हैं</div>
</a>
</div>
<div class="article-single-related article-related-recommend">
<a href="/cricket/mumbai-indians-sign-akash-madhwal-as-replacement-for-injured-suryakumar-yadav-for-ipl-2022?ref=relatedmid">
<div class="article-related-image article-related-recommend-image" data-lazy="https://staticg.sportskeeda.com/editor/2022/05/b47da-16527128425702-1920.jpg?w=500">
</div>
<div class="article-related-title article-related-recommend-title">सूर्यकुमार यादव की रिप्लेसमेंट के तौर मुंबई इंडियंस ने युवा तेज गेंदबाज को किया शामिल</div>
</a>
</div>
</div>
</div>
<div class="related-articles-carousel-anchors">
<div id="right" class="hidden">
<img src="//staticg.sportskeeda.com/skm/assets/ic-chevron-right.svg" height="20" width="20" alt="Right arrow for carousel">
</div>
<div id="left" class="hidden">
<img src="//staticg.sportskeeda.com/skm/assets/ic-chevron-left.svg" height="20" width="20" alt="Left arrow for carousel">
</div>
</div>
</div>
<script type="text/javascript">
var KeedaCarousel = function(container, itemWidth, margin, leftArrowEle, rightArrowEle) {
this.container = container;
this.itemWidth = itemWidth;
this.margin = margin || 0;
this.leftArrowEle = leftArrowEle;
this.rightArrowEle = rightArrowEle;
this.speed = 20;
this.step = 20;
this.toggleScrollHandlers = function (container) {
if (container.scrollLeft < 1) {
this.leftArrowEle.classList.add("hidden");
} else {
this.leftArrowEle.classList.remove("hidden");
}
if ((container.clientWidth + container.scrollLeft) >= container.scrollWidth) {
this.rightArrowEle.classList.add("hidden");
} else {
this.rightArrowEle.classList.remove("hidden");
}
}
this.init = function() {
if (this.container.scrollWidth <= this.container.clientWidth) {
return;
}
removeClass(this.rightArrowEle, "hidden");
this.addScrollListener();
this.addArrowClickListeners();
}
this.addScrollListener = function() {
if (typeof this.container === "object" && this.leftArrowEle.nodeName) {
this.container.addEventListener("scroll",this.toggleScrollHandlers.bind(this, this.container));
}
}
this.addArrowClickListeners = function() {
if (typeof this.leftArrowEle === "object" && this.leftArrowEle.nodeName) {
this.leftArrowEle.addEventListener('click', this.sideScroll.bind(this, 'right'))
}
if (typeof this.rightArrowEle === "object" && this.rightArrowEle.nodeName) {
this.rightArrowEle.addEventListener('click', this.sideScroll.bind(this, 'left'))
}
}
this.sideScroll = function (direction) {
var scrollAmount = 0;
var that = this;
var slideTimer = setInterval(function() {
if (direction == 'right') {
that.container.scrollLeft -= that.step;
} else {
that.container.scrollLeft += that.step;
}
scrollAmount += that.step;
if (scrollAmount >= itemWidth + margin) {
window.clearInterval(slideTimer);
}
that.toggleScrollHandlers.call(that, that.container);
}, this.speed);
}
this.init();
}
</script>
<script type="text/javascript">
function init() {
gtag('event', 'view', {
'event_category': 'article',
'event_label': 'related_new',
'non_interaction': true
});
var scrollContainer = $(".related-articles-scroll");
if (scrollContainer && lazyLoadAll) {
scrollContainer.addEventListener('scroll', lazyLoadAll);
}
}
init();
</script>
<script>
(function initReadMoreCarousel() {
if (typeof KeedaCarousel === "undefined") return;
var expertChoiceContainer = $(".related-articles-scroll");
if (!expertChoiceContainer) return;
var expertChoiceLeftArrow = $(".related-articles-carousel-anchors #left");
var expertChoiceRightArrow = $(".related-articles-carousel-anchors #right");
var expertChoiceMargin = 16;
var scrollWidth = 210;
var exportChoiceCarousel = new KeedaCarousel(expertChoiceContainer, scrollWidth, expertChoiceMargin, expertChoiceLeftArrow, expertChoiceRightArrow);
})();
</script>
<p><strong>अस्वीकरण:</strong> सलाह सहित यह सामग्री केवल सामान्य जानकारी प्रदान करती है। यह किसी भी तरह से योग्य चिकित्सा राय का विकल्प नहीं है। अधिक जानकारी के लिए हमेशा किसी विशेषज्ञ या अपने चिकित्सक से परामर्श करें। स्पोर्ट्सकीड़ा हिंदी इस जानकारी के लिए ज़िम्मेदारी का दावा नहीं करता है।</p>
<hr>
<p>
</p>
<div class="tags-wrapper">
<span id="post-rating-widget" class="hidden">
<style>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</style>
<div class="keeda_modal" onclick="modalPopup.dismissPopup(event)">
<div class="keeda_modal_content modal_small">
<div class="keeda_modal_header">
<span class="keeda_modal_header_text"></span>
<div class="actions">
<span class="keeda_modal_header_secondary_action"></span>
<span class="keeda_modal_close" onclick="modalPopup.close()">&times;</span>
</div>
</div>
<div class="keeda_modal_content_text">
</div>
</div>
</div>
<script>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</script>
<style>
#post-rating-layout{
float: right;
margin: 8px 0 5px 0;
font-size: 12px;
}
#post-rating-message{
float: right;
margin: 8px 0 5px 0;
font-size: 12px;
}
.rating > span {
padding-right: 2px;
font-size: 20px;
cursor: pointer;
}
.rating > .active:before {
content: "\2605";
position: absolute;
color: #B22222;
}
#post-rating-feedback-form .post-rating-feedback-note {
margin-top: 15px;
}
#post-rating-feedback-form .post-rating-feedback-note textarea {
display: block;
min-width: 100%;
min-height: 100px;
}
.post-rating-feedback-option label {
padding-left: 5px;
}
.post-rating-error-message {
color: red;
}
</style>
<div id="post-rating-layout">
<div>Rate this article!</div>
<div class="rating">
<span class="rating-star" id="star-1" onclick="ratePost(1)">☆</span>
<span class="rating-star" id="star-2" onclick="ratePost(2)">☆</span>
<span class="rating-star" id="star-3" onclick="ratePost(3)">☆</span>
<span class="rating-star" id="star-4" onclick="ratePost(4)">☆</span>
<span class="rating-star" id="star-5" onclick="ratePost(5)">☆</span>
</div>
</div>
<div id="post-rating-message" class="hidden">Thank You!</div>
<script>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</script>            </span>
</div>
<div style="margin: 25px 5px; overflow: visible !important;">
<span class="publisher-name">Edited by Ritu Raj</span>        <div class="comments-like-div">
<style>
.reaction-count {
margin-inline-start: unset !important;
min-width: auto !important;
min-height: auto !important;
display: flex;
}
.reaction-count a {
cursor: pointer;
padding-top: 1px;
}
.reaction-count img {
background: none;
display: inline-block;
}
.likes-count {
align-self: center;
font-size: 12px !important;
color: #999999 !important;
font-weight: 500;
padding: 0 0 0 4px !important;
}
.comments-count-container {
margin-inline-start: unset !important;
min-width: auto !important;
min-height: auto !important;
width: auto !important;
padding: 0 !important;
}
.comments-count-container a {
text-decoration: none  !important;
}
.comments-count-container span.comments-count {
font-weight: 500;
font-size: 12px !important;
line-height: 28px !important;
color: #999999 !important;
vertical-align: middle;
}
.action-counts {
display: flex;
align-items: center;
width: 100%;
flex: 1;
flex-shrink: 0;
justify-content: flex-start;
}
.reaction-count .separator-img {
height: 2px !important;
width: 2px !important;
margin: 0 10px !important;
}
.separator-img img {
height: 100%;
width: 100%;
vertical-align: middle;
}
.comments-like-div {
display: flex;
}
</style>
<div class="action-counts" >
<div class="reaction-count" id="like-button">
<span class="likes-count"></span>
</div>
</div>
<style>
.comment-action {
text-decoration: none !important;
}
</style>
<div class="story-user-actions" >
<div class="user-action-element like-action"  onmouseover="actionHover(this);" onmouseout="actionUnhover(this);">
<div class="reaction-bottom share-container">
<button type="button" class="reaction-text-holder share-btn" data-id="3580720" data-likes-count="0" data-url="https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi" data-title="कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai" onclick="showReactionsPost(this);" data-reaction-type=false data-type="" data-page-type="article" data-feed= >
<img src="//staticg.sportskeeda.com/skm/assets/feed/ic-like-gray.svg" alt="like story" width="16" height="16" />
<span class="action-text">Like</span>
</button>
<div class="reaction-icons-container hidden"  style="left: -150px !important;">
<div class="reaction-icon-holder" title="Like reaction" onclick="togglePostLike(this)" data-type="like" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-like.svg" alt="like reaction icon" height="38" width="38"/>
<span class="reaction-text">Like</span>
</div>
<div class="reaction-icon-holder" title="Excited reaction" onclick="togglePostLike(this)" data-type="excited" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-excited.svg" alt="exited reaction icon" height="38" width="38"/>
<span class="reaction-text">Excited</span>
</div>
<div class="reaction-icon-holder" title="Happy reaction" onclick="togglePostLike(this)" data-type="happy" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-happy.svg" alt="happy reaction icon" height="38" width="38"/>
<span class="reaction-text">Happy</span>
</div>
<div class="reaction-icon-holder" title="Anxious reaction" onclick="togglePostLike(this)" data-type="anxious" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-anxious.svg" alt="anxious reaction icon" height="38" width="38"/>
<span class="reaction-text">Anxious</span>
</div>
<div class="reaction-icon-holder" title="Angry reaction" onclick="togglePostLike(this)" data-type="angry" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-angry.svg" alt="angry reaction icon" height="38" width="38"/>
<span class="reaction-text">Angry</span>
</div>
<div class="reaction-icon-holder" title="Sad reaction" onclick="togglePostLike(this)" data-type="sad" data-id="3580720" data-count="0" data-type="article">
<img class="icon-style" src="//staticg.sportskeeda.com/post-reactions/reaction-sad.svg" alt="sad reaction icon" height="38" width="38"/>
<span class="reaction-text">Sad</span>
</div>
</div>
</div>
</div>
<div class="user-action-element share-action" onmouseover="actionHover(this);" onmouseout="actionUnhover(this);">
<style type="text/css">
.content-holder div {
overflow: visible;
}
.post-profile {
overflow: visible;
}
.share-text-holder button {
display: inline-flex;
padding: 4px 0;
background: none;
border: 1px solid transparent;
box-sizing: border-box;
border-radius: 40px;
cursor: pointer;
}
.forward-share {
width: 16px !important;
height: 16px !important;
display: inline-block !important;
background: none !important;
}
.share-text-holder span {
font-size: 14px;
font-weight: 500;
color: #A7A7A7;
padding-left: 2px;
}
.share-icon-holder {
width: 40px;
height: 40px;
margin: 0px 4px;  
}
.share-top {
float:right;
position: relative;
}
.share-top .share-icon-holder {
margin: 0px 8px; 
text-decoration:none;
}
.share-icon-holder img {
width: 40px;
height: 40px;
display: inline-block !important;
background: none !important;
vertical-align: top;
}
.share-icons-container {
height: 56px;
background: #FFFFFF;
border: 1px solid #E9E9E9;
box-sizing: border-box;
box-shadow: 0px 6px 12px rgb(0 0 0 / 10%);
border-radius: 50px;
display: flex;
justify-content: center;
align-items: center;
padding: 8px 5px;
position: absolute;
top: 40px;
z-index: 999;
}
</style>
<div class="share-top share-container">
<button type="button" class="share-text-holder share-btn" data-url="https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi" data-title="कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai" onclick="shareContent(this, 'top', 'ShareArticleClick', 'ShareArticle')">
<img src="//staticg.sportskeeda.com/skm/assets/feed/ic-share-gray.svg" width="16" height="16" class="forward-share" alt="share icon"/>
<span class="action-text">Share</span>
</button>
<div class="share-icons-container hidden">
<a class="share-icon-holder" href="https://web.whatsapp.com/send?text=%E0%A4%95%E0%A5%88%E0%A4%B2%E0%A5%8D%E0%A4%B6%E0%A4%BF%E0%A4%AF%E0%A4%AE+%E0%A4%94%E0%A4%B0+%E0%A4%B5%E0%A4%BF%E0%A4%9F%E0%A4%BE%E0%A4%AE%E0%A4%BF%E0%A4%A8+%E0%A4%A1%E0%A5%80+%E0%A4%95%E0%A4%BF%E0%A4%B8%E0%A4%AE%E0%A5%87%E0%A4%82+%E0%A4%AA%E0%A4%BE%E0%A4%AF%E0%A4%BE+%E0%A4%9C%E0%A4%BE%E0%A4%A4%E0%A4%BE+%E0%A4%B9%E0%A5%88-+Calcium+aur+Vitamin+D+kisme+paya+jata+hai https%3A%2F%2Fhindi.sportskeeda.com%2Fhealth-and-fitness%2Fsources-of-calcium-and-vitamin-d-in-hindi%3Futm_source%3Dwww.sportskeeda.com%26utm_medium%3Dwhatsapp%26utm_campaign%3DShareArticle " target="_blank" title="Share on Whatsapp" onclick="ga_event('ShareArticleClick', 'Desktop-Bottom', 'WhatsApp'); gtag('event', 'social share', { 'event_category': 'NTG social', 'event_label': 'whatsapp', 'non_interaction' : false })">
<img src="//staticg.sportskeeda.com/skm/assets/share/whatsapp-icon.svg" alt="Whatspp share icon" />
</a>
<a class="share-icon-holder" href="https://facebook.com/sharer/sharer.php?u=https%3A%2F%2Fhindi.sportskeeda.com%2Fhealth-and-fitness%2Fsources-of-calcium-and-vitamin-d-in-hindi%3Futm_source%3Dwww.sportskeeda.com%26utm_medium%3Dfacebook%26utm_campaign%3DShareArticle"
target="_blank" rel="noopener noreferrer" title="Share on Facebook" onclick="ga_event('ShareArticleClick', 'Desktop-Bottom', 'Facebook'); gtag('event', 'social share', { 'event_category': 'NTG social', 'event_label': 'facebook', 'non_interaction' : false })">
<img src="//staticg.sportskeeda.com/skm/assets/share/facebook-icon.svg" alt="Facebook share icon" />
</a>
<a class="share-icon-holder" href="https://twitter.com/share?url=https%3A%2F%2Fhindi.sportskeeda.com%2Fhealth-and-fitness%2Fsources-of-calcium-and-vitamin-d-in-hindi%3Futm_source%3Dwww.sportskeeda.com%26utm_medium%3Dtwitter%26utm_campaign%3DShareArticle&amp;text=%E0%A4%95%E0%A5%88%E0%A4%B2%E0%A5%8D%E0%A4%B6%E0%A4%BF%E0%A4%AF%E0%A4%AE+%E0%A4%94%E0%A4%B0+%E0%A4%B5%E0%A4%BF%E0%A4%9F%E0%A4%BE%E0%A4%AE%E0%A4%BF%E0%A4%A8+%E0%A4%A1%E0%A5%80+%E0%A4%95%E0%A4%BF%E0%A4%B8%E0%A4%AE%E0%A5%87%E0%A4%82+%E0%A4%AA%E0%A4%BE%E0%A4%AF%E0%A4%BE+%E0%A4%9C%E0%A4%BE%E0%A4%A4%E0%A4%BE+%E0%A4%B9%E0%A5%88-+Calcium+aur+Vitamin+D+kisme+paya+jata+hai&amp;via=SK_Hindi&amp;related=sportskeeda" 
target="_blank" rel="noopener noreferrer" title="Share on Twitter" onclick="ga_event('ShareArticleClick', 'Desktop-Bottom', 'Twitter'); gtag('event', 'social share', { 'event_category': 'NTG social', 'event_label': 'twitter', 'non_interaction' : false })">
<img src="//staticg.sportskeeda.com/skm/assets/share/twitter-icon.svg" alt="Twitter share icon" />
</a>
</div>
</div>
<script>
var url = "https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi"
var title = "कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai"
var text = "कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai"
var nativeShareEnabled = false;
window.addEventListener("DOMContentLoaded", function() {
if (navigator && navigator.share) {
nativeShareEnabled = true;
} else {
console.log("Native share is not supported!")
}
})
function shareContent(ele, btnPosition, eventName, campaignName) {
if (nativeShareEnabled) {
url = url + "?utm_source=www.sportskeeda.com&utm_medium=native&utm_campaign=" + campaignName
navigator.share({ title, url, text })
.then(function() {
ga_event(eventName, 'Desktop-native-' + (btnPosition || 'top'), '')
})
.catch(function(err) {
console.log("Error while sharing article using native share", err)
});
}
else {
var shareContainers = ele.parentElement.parentElement.querySelectorAll(".share-icons-container");
if (shareContainers && shareContainers.length) {
for(var i = 0; i < shareContainers.length; i++) {
shareContainers[i].classList.remove("hidden")
}
}
}
}
window.addEventListener("mouseup", function() {
var shareContainers = document.getElementsByClassName("share-icons-container");
if (shareContainers && shareContainers.length) {
for(var i = 0; i < shareContainers.length; i++) {
if (Array.from(shareContainers[i].classList).indexOf("hidden") === -1) {
shareContainers[i].classList.add("hidden")
}
}
}
})
</script>
</div>
</div>
<script>
function actionHover(ele) {
if (hasClass(ele, "like-action") && ele.querySelector('button').dataset.reactionType == "false") {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-like-red-new.svg")
} else if (hasClass(ele, "comment-action")) {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-comment-red.svg")
} else if (hasClass(ele, "share-action")) {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-share-red.svg")
}
}
function actionUnhover(ele) {
if (hasClass(ele, "like-action") && ele.querySelector('button').dataset.reactionType == "false") {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-like-gray.svg");
} else if (hasClass(ele, "comment-action")) {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-comment-gray.svg")
} else if (hasClass(ele, "share-action")) {
ele.querySelector('img').setAttribute("src", "//staticg.sportskeeda.com/skm/assets/feed/ic-share-gray.svg")
}
}
window.addEventListener("mouseup", function() {
var reactionContainers = $all(".reaction-icons-container");
if (reactionContainers && reactionContainers.length) {
for(var i = 0; i < reactionContainers.length; i++) {
if (Array.from(reactionContainers[i].classList).indexOf("hidden") === -1) {
reactionContainers[i].classList.add("hidden")
}
}
}
})
</script>
</div>
</div>
<div id="in-house-ads"></div>
<style>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</style>
<div class="full-width" id="keeda-comments-container" data-post-id="1105028">
<div class="comments-count-container comments-total hidden">
<span id="comments-count-span"><img id="image-for-no-of-comments" height="20" width="20" src="//staticg.sportskeeda.com/comments/comment-icon-grey.svg" alt="comments icon"/><span class="comments-count comment-text"></span></span>
<div class="comments-sort-container">
<label for="comments-sort-select">Sort by: </label>
<select class="comments-sort-select">
<option value="popular" selected>Most popular</option>
<option value="">Recent</option>
<option value="most-upvote">Most upvotes</option>
</select>
</div>
</div>
<div class="comments-input-holder"></div>
<div class="oauth-button-container comment-oauth hidden comment-login-auth">
<div class="login-support-text">
<span>Login to post your comment</span>
<button class="login-oauth-close" id="login-oauth-close-button">
<img src="//staticg.sportskeeda.com/close.svg" alt="close" width="8" height="8">
</button>
</div>
<div class="oauth-button-group" data-google-interstitial="false">
<a class="oauth-button auto-fill google" href="https://a-login.sportskeeda.com/login/oauth/google" default-href="https://a-login.sportskeeda.com/login/oauth/google" title="Google" data-provider="google">
<img src="//staticg.sportskeeda.com/skm/assets/images/google.svg" alt="google" width="24" height="24">
</a>
<a class="oauth-button auto-fill fb" href="https://a-login.sportskeeda.com/login/oauth/facebook" default-href="https://a-login.sportskeeda.com/login/oauth/facebook" title="Facebook" data-provider="facebook">
<img src="//staticg.sportskeeda.com/comments/fb-icon.svg" alt="facebook" width="24" height="24">
</a>
<a class="oauth-button auto-fill email" href="https://hindi.sportskeeda.com/login" default-href="https://hindi.sportskeeda.com/login" title="Email" data-provider="email">
<img src="//staticg.sportskeeda.com/comments/envelope.svg" alt="email" width="28" height="28">
</a>
</div>
</div>
<div class="comment-input-response comment-add-response-text"></div>
<div class="comments-container" data-post-id="1105028" data-wp-id="3580720" data-page-type="post" data-id="1105028"></div>
<div class="view-more-container hidden">
<button class="view-more-button">Show More Comments
<img class="view-more-button-img" src="//staticg.sportskeeda.com/comments/ic-downvote-fill.svg" alt="show-more" width="20" height="20" />
</button>
</div>
</div>
<template id="login-template">
<div class="oauth-button-container reply-oauth">
<div class="login-support-text">
<span>Login to reply</span>
<button class="reply-oauth-close">
<img src="//staticg.sportskeeda.com/close.svg" alt="close" width="8" height="8">
</button>
</div>
<div class="oauth-button-group" data-google-interstitial="false">
<a class="oauth-button google" href="https://a-login.sportskeeda.com/login/oauth/google" default-href="https://a-login.sportskeeda.com/login/oauth/google" title="Google" data-provider="google">
<img src="//staticg.sportskeeda.com/skm/assets/images/google.svg" alt="google" width="24" height="24">
</a>
<a class="oauth-button fb" href="https://a-login.sportskeeda.com/login/oauth/facebook" default-href="https://a-login.sportskeeda.com/login/oauth/facebook" title="Facebook" data-provider="facebook">
<img src="//staticg.sportskeeda.com/comments/fb-icon.svg" alt="facebook" width="24" height="24">
</a>
<a class="oauth-button email" href="https://hindi.sportskeeda.com/login" default-href="https://hindi.sportskeeda.com/login" title="Email" data-provider="email">
<img src="//staticg.sportskeeda.com/comments/envelope.svg" alt="email" width="28" height="28">
</a>
</div>
</div>
</template>
<template id="comments-placeholder-template">
<div class="comments-placeholder">
<div class="comments-placeholder-image"></div>
<div class="comments-placeholder-info">
<div class="comments-placeholder-title"></div>
<div class="comments-placeholder-text"></div>
</div>
</div>
</template>
<template id="comments-input-template">
<img id="pic-near-comment-box" src ="" alt="Profile picture" width="40" height="40">
<div class="comment-input-container">
<textarea class="post-comment-box" rows="1" placeholder="Type your comment..."></textarea>
<button  class="post-comment-button" type="submit" title="Submit comment">
</button>
</div>
</template>
<template id="comment-template">
<div class="one-comment" comment-id="" reply-to="" id="">
<div class="profile-pic-container">
<a class="commenter-link" href="">
<img class="commenter-img lazy-img" data-img="" data-img-low="" alt="" width="40" height="40"/>
</a>
</div>
<div class="comment-details">
<div class="comment-info">
<div class="profile-name-container">
<a class="name" href=""></a>
<span class='timestamp' title='' timestamp=''></span>
</div>
<div class="profile-status"></div>
<div class='one-comment-text'></div>
</div>
<div class="controls" commenter="">
<button class="vote upvote" data-vote="upvote">
<img src="//staticg.sportskeeda.com/like-articles/upvote-icon-grey.svg" width="16" height="16" alt="upvote icon"/>
<span class="vote-count">0</span>
</button>
<button class="vote downvote" data-vote="downvote">
<img src="//staticg.sportskeeda.com/like-articles/downvote-icon-grey.svg" width="16" height="16" alt="upvote icon"/>
<span class="vote-count">0</span>
</button>
<div class="reply-to-comment"><img class="reply-to-comment-img" src="//staticg.sportskeeda.com/comments/bubble.svg" height="16" width="16" alt="bubble icon"/><span class="reply-to-comment-img"> Reply</span></div>
<div class="comment-options">
<img id="comment-options-icon" class="comment-options comment-options-icon" src="//staticg.sportskeeda.com/comments/three-dots.svg" width="16" height="16" alt="options icon"/>
</div>
<div class="comment-options-box hidden">
<span class="comment-option-single-cancel">x </span>
<span class="comment-option-single edit-option"><img class="comment-option-single-edit" src="//staticg.sportskeeda.com/comments/ic-edit.svg" width="16" height="16"/><span class="comment-option-single-edit">&nbsp;&nbsp;Edit</span></span>
<span class="comment-option-single delete-option" id="delete-option"><img class="comment-option-single-delete" src="//staticg.sportskeeda.com/comments/ic-delete.svg" width="16" height="16"/><span class="comment-option-single-delete">&nbsp;&nbsp;Delete</span></span>
<div class="delete-action-modal">
<div class="delete-actions">
<img src="//staticg.sportskeeda.com/comments/delete-icon.svg" alt="delete icon" height="98" width="25"/>
<span class="delete-action-text">
Delete the comment?
</span>
<span class="delete-action-warning">
</span>
<div class="delete-action-buttons">
<div class="delete-comment-cancel">No thanks</div>
<div class="delete-comment-confirm" comment-id="">Delete</div>
</div>
</div>
</div>
</div>
</div>
<div class="edit-section hidden">
<textarea class="edit-comment-text" rows="2" type="text" value="value to edit" placeholder="Edit your comment!"></textarea>
<div class="cancel-container">
<div class="cancel-edit">Cancel</div>
<button type="submit" class="edit-comment-button">
<img src="//staticg.sportskeeda.com/comments/ic-tick.svg" alt="Send Icon" width="16" height="16"> Update
</button>
</div>
</div>
<div class="edit-comment-input-response comment-input-response hidden"></div>
<div class="reply-section"></div>
<div class="replies"></div>
</div>
</div>
</template>
<template id="reply-input-template">
<div class="reply-section-container" parent-comment-id="">
<img id="pic-near-reply-box" src ="" alt="Profile picture" width="32" height="32">
<textarea class="comment-reply-box" placeholder="Type your reply..."></textarea>
<div class="cancel-container">
<a class="cancel-reply">Cancel</a>
<button class="comment-reply-button reply-edit" type="submit"><img src="//staticg.sportskeeda.com/comments/send-icon.svg" id="reply-send-icon" alt="Send Icon" width="16" height="16"/>Reply</button>
</div>
</div>
</template>
</div>
<script type="text/javascript">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</script>
<script type="text/javascript">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</script>
<script async src="/js/production/content-page-bundle_418714.js" onload="renderPrimaryCommentsWidget()"></script>
<template id="comments-input-template">
<img id="pic-near-comment-box" src ="" alt="Profile picture" width="40" height="40">
<div class="comment-input-container">
<textarea class="post-comment-box" rows="1" placeholder="Type your comment..."></textarea>
<button  class="post-comment-button" type="submit" title="Submit comment">
</button>
</div>
</template>
<template id="comment-template">
<div class="one-comment" comment-id="" reply-to="" id="">
<div class="profile-pic-container">
<a class="commenter-link" href="">
<img class="commenter-img lazy-img" data-img="" data-img-low="" alt="" width="40" height="40"/>
</a>
</div>
<div class="comment-details">
<div class="comment-info">
<div class="profile-name-container">
<a class="name" href=""></a>
<span class='timestamp' title='' timestamp=''></span>
</div>
<div class="profile-status"></div>
<div class='one-comment-text'></div>
</div>
<div class="controls" commenter="">
<button class="vote upvote" data-vote="upvote">
<img src="//staticg.sportskeeda.com/like-articles/upvote-icon-grey.svg" width="16" height="16" alt="upvote icon"/>
<span class="vote-count">0</span>
</button>
<button class="vote downvote" data-vote="downvote">
<img src="//staticg.sportskeeda.com/like-articles/downvote-icon-grey.svg" width="16" height="16" alt="upvote icon"/>
<span class="vote-count">0</span>
</button>
<div class="reply-to-comment"><img class="reply-to-comment-img" src="//staticg.sportskeeda.com/comments/bubble.svg" height="16" width="16" alt="bubble icon"/><span class="reply-to-comment-img"> Reply</span></div>
<div class="comment-options">
<img id="comment-options-icon" class="comment-options comment-options-icon" src="//staticg.sportskeeda.com/comments/three-dots.svg" width="16" height="16" alt="options icon"/>
</div>
<div class="comment-options-box hidden">
<span class="comment-option-single-cancel">x </span>
<span class="comment-option-single edit-option"><img class="comment-option-single-edit" src="//staticg.sportskeeda.com/comments/ic-edit.svg" width="16" height="16"/><span class="comment-option-single-edit">&nbsp;&nbsp;Edit</span></span>
<span class="comment-option-single delete-option" id="delete-option"><img class="comment-option-single-delete" src="//staticg.sportskeeda.com/comments/ic-delete.svg" width="16" height="16"/><span class="comment-option-single-delete">&nbsp;&nbsp;Delete</span></span>
<div class="delete-action-modal">
<div class="delete-actions">
<img src="//staticg.sportskeeda.com/comments/delete-icon.svg" alt="delete icon" height="98" width="25"/>
<span class="delete-action-text">
Delete the comment?
</span>
<span class="delete-action-warning">
</span>
<div class="delete-action-buttons">
<div class="delete-comment-cancel">No thanks</div>
<div class="delete-comment-confirm" comment-id="">Delete</div>
</div>
</div>
</div>
</div>
</div>
<div class="edit-section hidden">
<textarea class="edit-comment-text" rows="2" type="text" value="value to edit" placeholder="Edit your comment!"></textarea>
<div class="cancel-container">
<div class="cancel-edit">Cancel</div>
<button type="submit" class="edit-comment-button">
<img src="//staticg.sportskeeda.com/comments/ic-tick.svg" alt="Send Icon" width="16" height="16"> Update
</button>
</div>
</div>
<div class="edit-comment-input-response comment-input-response hidden"></div>
<div class="reply-section"></div>
<div class="replies"></div>
</div>
</div>
</template>
<template id="reply-input-template">
<div class="reply-section-container" parent-comment-id="">
<img id="pic-near-reply-box" src ="" alt="Profile picture" width="32" height="32">
<textarea class="comment-reply-box" placeholder="Type your reply..."></textarea>
<div class="cancel-container">
<a class="cancel-reply">Cancel</a>
<button class="comment-reply-button reply-edit" type="submit"><img src="//staticg.sportskeeda.com/comments/send-icon.svg" id="reply-send-icon" alt="Send Icon" width="16" height="16"/>Reply</button>
</div>
</div>
</template>
<style>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</style>
<style>
.feed-comments-popover {
position: fixed;
right: 16px;
bottom: 0;
width: 420px;
height: calc(100% - 50px);
z-index: 9999999;
background: #FFFFFF;
box-shadow: 0px 0px 12px rgba(0, 0, 0, 0.1);
transition: 0.4s;
transform: translateX(0px);
overflow: hidden;
}
.feed-comments-popover.inactive {
transition: 0.4s;
transform: translateX(110%);
}
.feed-comments-container {
position: relative;
height: 100%;
display: flex;
flex-direction: column;
}
.feed-comments-container .comments-container {
flex: 1;
padding: 0 8px 12px;
overflow-y: auto;
}
.feed-comments-container .comments-input-holder {
width: 100%;
background: #fff;
border-top: 1px solid #E9E9E9;
border-bottom: 0;
padding: 12px 16px;
}
.feed-comments-container .comment-input-container {
display: inline-flex;
align-items: center;
justify-content: space-between;
}
.feed-comments-container .comment-input-container {
padding: 0;
}
.feed-comments-container textarea.post-comment-box {
flex: 1;
margin-right: 8px;
padding-right: 12px;
}
.feed-comments-container .post-comment-button {
position: relative;
bottom: unset;
right: unset;
}
.feed-comments-header {
display: flex;
position: relative;
top: 0;
left: 0;
padding: 12px 16px;
background-color: #2D2D2D;
align-items: center;
z-index: 1;
}
.feed-comments-header span {
color: #FFFFFF !important;
font-size: 14px;
line-height: 17px;
font-weight: bold;
flex-shrink: 0;
flex: 1;
}
.popover-close {
border: none;
padding: 4px;
background-color: transparent;
display: flex;
align-items: flex-end;
justify-content: flex-end;
cursor: pointer;
flex-shrink: 0;
}
.popover-close img, .reply-tag-container img {
width: 24px;
height: auto;
object-fit: cover;
background-color: transparent;
margin: 0;
cursor: pointer;
}
.reply-tag-container img {
width: 12px;
}
.feed-comments-container .reply-tag-container {
position: relative;
background: #F5F5F5;
padding: 8px 16px;
display: flex;
justify-content: space-between;
align-items: center;
font-size: 12px;
line-height: 14px;
color: #999999;
width: 100%;
}
.comments-empty-state {
height: 100%;
display: flex;
flex-direction: column;
align-items: center;
justify-content: center;
}
.comments-empty-state img {
background-color: transparent;
width: 152px;
object-fit: cover;
margin-bottom: 12px;
}
.comments-empty-state p {
font-weight: 500;
font-size: 16px !important;
line-height: 150%;
width: 75%;
color: #2D2D2D;
text-align: center;
}
.feed-comments-container .oauth-button-container {
background: #fff;
display: flex;
border-radius: 0;
margin-top: 0 !important;
align-items: center;
padding: 4px 12px;
border-top: 1px solid #E9E9E9;
position: absolute;
z-index: 1;
width: 100%;
left: 0;
bottom: 66px;
}
.feed-comments-container .one-comment .oauth-button-container {
position: relative;
bottom: unset;
top: unset;
margin-top: 12px !important;
border-radius: 4px;
border: 1px solid #E9E9E9;
}
.feed-comments-container .reply-oauth-close, .feed-comments-container .login-oauth-close {
display: none;
}
.feed-comments-container .login-support-text {
background: #fff;
color: #2D2D2D;
width: 60%;
text-align: left;
font-size: 16px;
font-weight: 500;
line-height: 24px;
}
.feed-comments-container .login-support-text span {
line-height: 24px;
}
.feed-comments-container .oauth-button-group {
flex: 1;
justify-content: flex-end;
}
a.comments-article-container {
display: flex;
align-items: center;
padding: 12px 16px;
background: #E9F7F2;
text-decoration: none;
box-shadow: 0px 2px 6px rgba(0, 0, 0, 0.05);
}
.comments-article-container .comments-article-image {
border-radius: 4px;
width: 63px;
height: 63px;
object-fit: cover;
margin-right: 12px;
flex-shrink: 0;
}
.comments-article-container p {
margin: 0;
padding: 0;
font-size: 14px !important;
line-height: 17px;
color: #2D2D2D;
flex: 1;
margin-right: 12px;
overflow: hidden;
text-overflow: ellipsis;
display: -webkit-box;
-webkit-line-clamp: 3;
-webkit-box-orient: vertical;
min-height: auto;
}
.comments-article-container .comments-article-ic-right {
width: 24px;
height: 24px;
background: transparent;
}
</style>
<script type="text/javascript">
var isCommentPopupVisible = false;
function toggleFeedComments(element, story) {
var id = element.dataset.id;
if (!id) return;
var popover = document.getElementById("feed-comments-popover");
if (!popover) return;
popover.classList.remove("inactive");
showArticleInfo(element.dataset.title, element.dataset.href, element.dataset.thumbnail);
var feedComments = new KeedaComments({
id: id,
wpId: null,
popup: true,
commentsContainer: document.getElementById("feed-comments-container"),
pageType: "post",
articleLink:  window.location.origin + element.dataset.href + window.location.search,
gaCategory: "Feedpage"
});
feedComments.fetchCommentsAndRender();
window.location.hash = "feed-comments-container";
isCommentPopupVisible = true;
gtag('event', "click", {
'event_category': "Feedpage_Interactions",
'event_label': getGALabelForFeedCommentClick(element.dataset.type)
});
}
function getGALabelForFeedCommentClick(type) {
if (type === "tweet") {
return "Social_Twitter_Comment_Button";
} else if (type === "youtube") {
return "Social_Youtube_Comment_Button";
} else if (type === "instagram") {
return "Social_Instagram_Comment_Button";
}
return "Article_Comment_Button";
}
function hideCommentsContainer(fromWindowPop) {
if (!isCommentPopupVisible) {
return;
}
isCommentPopupVisible = false;
var popover = document.getElementById("feed-comments-popover");
if (!popover) return;
popover.classList.add("inactive");
if (!fromWindowPop) {
window.history.back();
}
}
function showArticleInfo(title, href, thumbnail) {
var articleInfoContainer = document.getElementById("comments-article-info");
if (!articleInfoContainer) return;
if (!title || !href) {
articleInfoContainer.classList.add("hidden");
} else {
articleInfoContainer.classList.remove("hidden");
}
articleInfoContainer.href = href.concat("?ref=feed-comments-popup");
var titleEle = articleInfoContainer.querySelector(".comments-article-title");
if (titleEle) titleEle.innerText = title;
var imageEle = articleInfoContainer.querySelector(".comments-article-image");
if (imageEle) {
if (thumbnail) {
imageEle.src = getImageWidthTransformedURL(thumbnail, 100);
imageEle.classList.remove("hidden");
} else {
imageEle.classList.add("hidden");
}
}
}
function showFeedCommentsContainer() {
if (window.location.hash == "#feed-comments-container") {
var commentEle = $('.user-action-element.comment-action');
if (commentEle) {
toggleFeedComments(commentEle);
}
}
}
window.onpopstate = function() {
// Back button handler, along with hash it'll hide the popover comments UI
hideCommentsContainer(true);
}
</script>
<div class="feed-comments-popover inactive" id="feed-comments-popover">
<div class="feed-comments-container" id="feed-comments-container">
<div class="feed-comments-header">
<span class="comments-count comment-text"></span>
<button class="popover-close" onclick="hideCommentsContainer(false)">
<img src="//staticg.sportskeeda.com/comments/ic-close.svg" width="24" height="24" alt="close"/>
</button>
</div>
<a href="" class="comments-article-container" id="comments-article-info">
<img class="comments-article-image" src="" width="63" height="63" alt="Article image" />
<p class="comments-article-title"></p>
<img class="comments-article-ic-right" src="//staticg.sportskeeda.com/skm/assets/ic-chevron-right.svg" width="24" height="24" alt="Go to article" />
</a>
<div class="oauth-button-container comment-oauth hidden comment-login-auth">
<div class="login-support-text">
<span>Login to post your comment</span>
<button class="login-oauth-close" id="login-oauth-close-button">
<img src="//staticg.sportskeeda.com/close.svg" alt="close" width="8" height="8">
</button>
</div>
<div class="oauth-button-group" data-google-interstitial="false">
<a target="_blank" class="oauth-button auto-fill google" href="https://a-login.sportskeeda.com/login/oauth/google" default-href="https://a-login.sportskeeda.com/login/oauth/google" title="Google" data-provider="google">
<img src="//staticg.sportskeeda.com/skm/assets/images/google.svg" alt="google" width="24" height="24">
</a>
<a target="_blank" class="oauth-button auto-fill fb" href="https://a-login.sportskeeda.com/login/oauth/facebook" default-href="https://a-login.sportskeeda.com/login/oauth/facebook" title="Facebook" data-provider="facebook">
<img src="//staticg.sportskeeda.com/comments/fb-icon.svg" alt="facebook" width="24" height="24">
</a>
<a target="_blank" class="oauth-button auto-fill email" href="https://hindi.sportskeeda.com/login" default-href="/login" title="Email" data-provider="email">
<img src="//staticg.sportskeeda.com/comments/envelope.svg" alt="email" width="28" height="28">
</a>
</div>
</div>
<div class="comment-input-response comment-add-response-text"></div>
<div class="comments-container"></div>
<div class="reply-tag-container hidden">
<span class="reply-tag"></span>
<img class="reply-tag-cancel" src="//staticg.sportskeeda.com/close.svg" width="12" height="12" alt="cancel reply"/>
</div>
<div class="comments-input-holder"></div>
</div>
</div>
<template id="comments-placeholder-template">
<div class="comments-placeholder">
<div class="comments-placeholder-image"></div>
<div class="comments-placeholder-info">
<div class="comments-placeholder-title"></div>
<div class="comments-placeholder-text"></div>
<div class="replies">
</div>
</div>
</div>
<div class="comments-placeholder">
<div class="comments-placeholder-image"></div>
<div class="comments-placeholder-info">
<div class="comments-placeholder-title"></div>
<div class="comments-placeholder-text"></div>
<div class="replies">
</div>
</div>
</div>
<div class="comments-placeholder">
<div class="comments-placeholder-image"></div>
<div class="comments-placeholder-info">
<div class="comments-placeholder-title"></div>
<div class="comments-placeholder-text"></div>
<div class="replies">
</div>
</div>
</div>
</template>
<template id="comments-empty-template">
<div class="comments-empty-state">
<img src="//staticg.sportskeeda.com/comments/ic-no-comments-1.svg" width="152" height="114" alt="empty comments"/>
<p>Be the first one to comment on this post</p>
</div>
</template>
<template id="login-template-popup">
<div class="oauth-button-container reply-oauth">
<div class="login-support-text">
<span>Login to reply</span>
<button class="reply-oauth-close">
<img src="//staticg.sportskeeda.com/close.svg" alt="close" width="8" height="8">
</button>
</div>
<div class="oauth-button-group" data-google-interstitial="false">
<a target="_blank" class="oauth-button google" href="https://a-login.sportskeeda.com/login/oauth/google" default-href="https://a-login.sportskeeda.com/login/oauth/google" title="Google" data-provider="google">
<img src="//staticg.sportskeeda.com/skm/assets/images/google.svg" alt="google" width="24" height="24">
</a>
<a target="_blank" class="oauth-button fb" href="https://a-login.sportskeeda.com/login/oauth/facebook" default-href="https://a-login.sportskeeda.com/login/oauth/facebook" title="Facebook" data-provider="facebook">
<img src="//staticg.sportskeeda.com/comments/fb-icon.svg" alt="facebook" width="24" height="24">
</a>
<a target="_blank" class="oauth-button email" href="/login" default-href="/login" title="Email" data-provider="email">
<img src="//staticg.sportskeeda.com/comments/envelope.svg" alt="email" width="28" height="28">
</a>
</div>
</div>
</template>
</div>
<div style="width:100%; clear:both">
<div style="width: 100%;
clear: both;
background: #fff;
overflow: hidden;
padding: 7px 0;
height: 100%;
overflow: visible;">
<div class="ad-container" id="article_pagesplit_ad" style="min-height:90px; width: 100%; text-align: center;clear:both;top:20px;z-index:10; padding-top: 0px;
padding-bottom: 25px;">
<!-- /11446729/Desktop_72890_2 -->
</div>
<style>
#sk-timeline #stories-list {
background:#fff;
}
</style>
<div style="margin:0 auto;width:620px;overflow:hidden;">
<style>
.one-story.timeless-story {
flex: 1 0 274px;
position: relative;
margin-right: 16px;
}
.timeless-story .one-story-mast {
height: 183px;
}
.timeless-story .title-background-layer {
position: absolute;
width: 100%;
height: 100%;
background: linear-gradient(180deg, rgba(45, 45, 45, 0) 0%, rgba(49, 49, 49, 0.92) 99.09%);
border-radius: 4px;
top: 0;
}
.timeless-story .title-background-layer h4 {
white-space: normal;
position: absolute;
bottom: 12px;
color: #FFFFFF;
left: 12px;
right: 12px;
line-height: 20px;
font-size: 14px;
}
.one-story.timeless-story:last-child {
margin-right: 0;
}
.spotlight-layout, .timless-posts-layout {
background-color: #fff;
overflow: hidden !important;
line-height: 14px;
font-size: 14px;
padding: 12px;
margin: 14px 0 12px 0;
border-radius: 1px;
color: #2D2D2D;
position: relative;
border: 1px solid #E9E9E9;
}
.spotlight-layout a, .timless-posts-layout a {
text-decoration: none;
color: #2D2D2D;
}
.spotlight-header, .timeless-post-header {
height:10%;
font-weight: bold;
font-size: 14px;
margin: 0!important;
color: #474747;
}
.spotlight-header img, .timeless-post-header img {
width: 18px;
height: auto;
background-color: transparent;
display: inline-block;
}
.spotlight-header span, .timeless-post-header span {
position: relative;
bottom: 3px;
left: 10px;
}
#story-list, #timeless-posts-list {
text-align: left;
vertical-align: middle;
width: 100%;
max-width: 1100px;
white-space: nowrap;
overflow: auto;
float: left;
margin: 12px auto 0 0;
position: relative;
-ms-overflow-style: none;  /* IE and Edge */
scrollbar-width: none; 
display: flex;
flex-direction: row;
flex-wrap: nowrap;
}
/* Hide scrollbar for Chrome, Safari and Opera */
#story-list::-webkit-scrollbar, #timeless-posts-list::-webkit-scrollbar {
display: none;
}
.one-story {
flex: 1 0 260px;
display: inline-block;
margin: 2px 0;
margin-right: 20px;
vertical-align: top;
}
.one-story-mast {
height: 145px;
overflow: hidden;
border-radius: 8px;
background-size: cover;
background-repeat: no-repeat;
background-position: center;
cursor: pointer;
}
.timeless-story .one-story-mast {
border-radius: 4px;
}
.one-story-author {
height: 15px;
padding: 0 8px;
position: relative;
bottom: 18px;
cursor: pointer;
}
.one-story-header {
display: inline-block;
width: 100%;
line-height: 24px;
white-space: normal;
overflow: hidden;
padding: 7px 0px 0px 0px;
cursor: pointer;
}
.one-story-header h4 {
padding: 0;
font-size: 14px!important;
word-break: break-word;
line-height: 24px;
margin: 0;
font-weight: normal;
}
.author-img {
display: inline-block;
border: 2px solid white;
border-radius: 50%;
overflow: hidden;
width: 40px;
height: 40px;
background-size: contain;
cursor: pointer;
}
.author-name {
display: inline-block;
display: inline-block;
font-size: 12px;
position: relative;
bottom: 8px;
padding-left: 8px;
}
.spotlight-anchors #left {
height: 248px;
width: 30px;
background-color: #fff;
display: inline;
position: absolute;
left: 0;
text-align: center;
cursor: pointer;
}
.timeless-posts-anchors #right, .timeless-posts-anchors #left {
height: 40px;
width: 40px;
background-color: #fff;
position: absolute;
text-align: center;
cursor: pointer;
top: 53%;
transform: translateY(-50%);
display: flex;
align-items: center;
border-radius: 100%;
justify-content: center;
box-shadow: 1px 1px 7px rgb(0 0 0 / 7%), -1px -1px 7px rgb(0 0 0 / 7%);
}
.timeless-posts-anchors #right {
right: 5px;
}
.timeless-posts-anchors #left {
left: 5px;
}
.spotlight-anchors #right {
height: 248px;
width: 30px;
background-color: #fff;
display: inline;
position: absolute;
right: 0;
text-align: center;
cursor: pointer;
}
.spotlight-anchors #right img {
position: relative;
top: 40%;
transform: translateY(-50%);
width: 20px;
background: transparent;
}
.timeless-posts-anchors #right img, .timeless-posts-anchors #left img {
position: relative;
background: transparent;
width: 10px;
height: 15px;
}
.timeless-posts-anchors #left img {
transform: scaleX(-1);
}
.spotlight-anchors #left img {
position: relative;
top: 40%;
transform: translateY(-50%) rotate(180deg);
width: 20px;
background: transparent;
}
.full-width {
width: 100%;
margin-right: 0;
}
#by-text {
color: #999999;
}
@media screen and (max-width: 768px) {
.spotlight-layout, .timless-posts-layout {
margin: 8px 0;
}
}
</style>
<div id="timeline-loading-div-top" style="display:none;"></div>
<div class="row tabs-data-container width-100 font-common stories-header">
<div id="sk-timeline" class="all-stories " style="overflow: hidden; float: left; width: 100%;">
<div id="stories-list">
</div>
</div>
</div>
<div id="timeline-loading-div">Fetching more content...</div>
<script type="text/javascript">
var socialStoriesObserved = {};
var videoPlayedEventTriggered = {}
var socialStoriesIOConfig = {
root: null,
rootMargin: "0px",
threshold: 0.5
}
var socialStoriesIntersectionObserver = new IntersectionObserver(handlerForSocialStoryIO, socialStoriesIOConfig);
function handlerForSocialStoryIO(entries) {
entries.forEach(function(entry) {
var targetEle = entry.target;
if (entry.isIntersecting) {
var videoEle = targetEle.querySelector("video");
if (videoEle) {
var postId = targetEle.dataset.id;
socialStoriesIntersectionObserver.unobserve(targetEle);
setEventListenerForVideoPlay(videoEle, postId, targetEle.dataset);
} else {
targetEle.setAttribute("data-visible-start", Date.now());
targetEle.removeAttribute("data-visible-end");
}
return
}
if (entry.boundingClientRect.top < 1) {
var dataset = targetEle.dataset
if (dataset.visibleEnd) return;
if (!dataset.visibleStart) return;
var now = Date.now();
targetEle.setAttribute("data-visible-end", now);
if((now - dataset.visibleStart) > 2000) {
// post viewed for more than 2 seconds
sendPageViewTracking(dataset);
socialStoriesIntersectionObserver.unobserve(targetEle);
}
}
})
}
function sendPageViewTracking(dataset) {
if (TrackUsersLive === "undefined") {
return;
}
try {
var storyAbsolutePermalink = new URL(dataset.link);
dataset.link = storyAbsolutePermalink.href;
} catch (error) {
dataset.link = "https://hindi.sportskeeda.com" + dataset.link;
}
var data = 'uri=' + encodeURIComponent(dataset.link) +
'&userIdentifier=' + userId +
'&post_id=' + dataset.wpId +
'&post_type=' + dataset.type +
'&published_date=' + dataset.published +
'&author_id=' + (dataset.authorSlug || "") +
'&tt_id_json=' + (dataset.ttIds || "[]") +
'&session_id=' + TrackUsersLive.getUniqueSessionId() +
'&query_string=' + encodeURIComponent(window.location.search) +
'&pageType=Articlepage' +
'&revenue_share=false&key1=&key2=&key3=&key4=&lang=hi&update_reads=true';
TrackUsersLive.sendPageViewRequest(data, "https://ingestion.sportskeeda.com");
var eventUrl = dataset.link;
if (dataset.ref) {
eventUrl += "?ref="+dataset.ref;
}
sendGAPageViewEventForSocialPost(eventUrl);
}
// sends page view event for the social post to GA
function sendGAPageViewEventForSocialPost(url) {
if (!gtag) return;
gtag('config', 'UA-10769778-10', { 'page_path': url });
}
function setIntersectionObserverSocialPosts() {
var socialStories = $all(".social-story-wrapper .list-story-link");
for (var i = 0; i < socialStories.length; i++) {
var storyEle = socialStories[i];
if (!storyEle || !storyEle.dataset.id || !!socialStoriesObserved[storyEle.dataset.id]) {
continue;
}
socialStoriesIntersectionObserver.observe(storyEle);
}
}
function setEventListenerForVideoPlay(videoEle, postId, dataset) {
if (!videoEle || !postId) return;
videoEle.addEventListener("play", function() {
if (!!videoPlayedEventTriggered[postId]) {
return;
}
videoPlayedEventTriggered[postId] = true;
sendGAEventForSocialStory("video_play", postId, false);
sendPageViewTracking(dataset);
}, { once: true });
}
function sendGAEventForSocialStory(action, postId, nonInteraction) {
if (!gtag || !action) {
return;
}
var params = {
"event_category": "Social_post",
"event_label": "Articlepage" || "",
}
if (nonInteraction) {
params["non_interaction"] = true;
}
gtag("event", action, params);
}
</script>
<script type="text/javascript">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</script>
<script type="text/javascript">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</script>
<script type="text/javascript">
var url = "https://hindi.sportskeeda.com/health-and-fitness/sources-of-calcium-and-vitamin-d-in-hindi"
var title = "कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai"
var text = "कैल्शियम और विटामिन डी किसमें पाया जाता है- Calcium aur Vitamin D kisme paya jata hai"
var nativeShareEnabled = false;
window.addEventListener("DOMContentLoaded", function() {
if (navigator && navigator.share) {
nativeShareEnabled = true;
} else {
console.log("Native share is not supported!")
}
})
function hideShareContainer() {
var activeShareContainer = $(".share-icons-container.active");
if (activeShareContainer && !activeShareContainer.classList.contains("hidden")) {
activeShareContainer.classList.add("hidden");
activeShareContainer.classList.remove("active");
}
}
if (!nativeShareEnabled) {
window.addEventListener("mouseup", hideShareContainer);
}
function shareContent(ele, btnPosition, eventName, campaignName) {
if (nativeShareEnabled) {
var shareUrl = (ele.dataset.url || url) + "?utm_source=www.sportskeeda.com&utm_medium=native&utm_campaign=" + campaignName;
var shareTitle = ele.dataset.title || title;
navigator.share({
title: shareTitle,
url: shareUrl,
text: shareTitle
})
.then(function() {
ga_event(eventName, 'Mobile-native-' + (btnPosition || 'top'), '')
})
.catch(function(err) {
console.log("Error while sharing article using native share", err)
});
} else {
var shareContainers = ele.parentElement.querySelectorAll(".share-icons-container");
if (shareContainers && shareContainers.length) {
for (var i = 0; i < shareContainers.length; i++) {
shareContainers[i].classList.remove("hidden");
shareContainers[i].classList.add("active");
}
}
}
}
</script>
</div>
</div>
</div>
</div>
<div class="right-sidebar">
<style>
.editor-width-100-pc .fragments-container {
width: 670px;
}
.editor-width-100-pc .right-sidebar {
width:390px;
margin-top: 40px;
}
body .editor-width-100-pc  {
overflow: visible;
}
.rightStickyTopWrap {
position:relative;
overflow:visible;
clear:both;
height: 700px;
}
.rightStickyTop {
position:sticky;
top:90px;
height:740px;
}
.rightStickyTop .ad-container {
padding:0;
}
</style>
<div class="rightStickyTopWrap">
<div class="rightStickyTop">
<div class="ad-container" id=''
style="
min-height: 24px;
width: 100%; text-align: center;clear:both;
">
<div class="ad-declare-explicit"></div>
<!-- /11446729/Desktop_300250_3 -->
<div id='div-gpt-ad-1589376019464-0' class="">
<script>
if (typeof displayAdSlot !== 'undefined') {
displayAdSlot('div-gpt-ad-1589376019464-0');
}
</script>
</div>
</div>
<script>
window.addEventListener('message',function(e) {
if(e.data && e.data.SKNative) {
var expansionEligibleIframe = e.source.frameElement;
expansionEligibleIframe.style.width = "100%";
}
});
</script>
<div>
<div class="ad-container" id=''
style="
min-height: 274px;
width: 100%; text-align: center;clear:both;
">
<div class="ad-declare-explicit"></div>
<!-- /11446729/Desktop_300250_1 -->
<div id='div-gpt-ad-1471939034701-0' class="">
<script>
if (typeof displayAdSlot !== 'undefined' && !window['AVOID_LOADING_AD_UNIT__Desktop_300250_1']) {
displayAdSlot('div-gpt-ad-1471939034701-0');
}
</script>
</div>
</div>
<script>
window.addEventListener('message',function(e) {
if(e.data && e.data.SKNative) {
var expansionEligibleIframe = e.source.frameElement;
expansionEligibleIframe.style.width = "100%";
}
});
</script>
</div>
</div>
</div>
<script>
function setAdFloatingParams() {
$(".rightStickyTopWrap").style.height = $('.fragments-container').scrollHeight + "px";
}
window.addEventListener("load", setAdFloatingParams.bind(this));
window.addEventListener("scroll", setAdFloatingParams.bind(this));
</script>
</div>
</div>
<script>
(function () {
function lazyLoadArticle() {
var lazyImages = $all('img.lazy-img');
for (var i = 0; i < lazyImages.length; i++) {
var lazyElement = lazyImages[i];
if (isScrolledIntoView(lazyElement)) {
lazyLoadImage(lazyElement);
}
}
}
function lazyLoadImage(image) {
if (screen.width > 500) {
image.src = image.attributes['data-img'].value;
}
else {
image.src = image.attributes['data-img-low'].value;
}
image.className = image.className.replace('lazy-img', '');
}
window.lazyLoadImages = lazyLoadArticle;
lazyLoadAll();
lazyLoadArticle();
window.addEventListener('scroll', lazyLoadAll);
window.addEventListener('scroll', lazyLoadArticle);
window.addEventListener('load', lazyLoadAll);
})();
</script>                <div style="height:100px;width:100%" id="footer-empty-div">
</div>
<!-- Begin comScore Tag -->
<script>
var _comscore = _comscore || [];
_comscore.push({c1: "2", c2: "13438550"});
(function() {
var s = document.createElement("script"), el = document.getElementsByTagName("script")[0];
s.async = true;
s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
el.parentNode.insertBefore(s, el);
})();
</script>
<noscript>
<img src="//b.scorecardresearch.com/p?c1=2&c2=13438550&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->
<!-- Begin Google adwords remarketing tag -->
<script type="text/javascript">
/* <![CDATA[ */
var google_conversion_id = 944895441;
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */
</script>
<script async type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js" charset="utf-8"></script>
<noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/944895441/?guid=ON&amp;script=0"/>
</div>
</noscript>
<!-- End Google adwords remarketing tag -->                <style>
.message-card {
width: 304px;
height: 70px;
border-radius: 3px;
background-color: #ffffff;
box-shadow: 0 2px 8px 0 rgba(0, 0, 0, 0.2);
display: flex;
position: fixed;
bottom: 20px;
left: 20px;
padding: 10px 10px 0px 15px;
z-index: 2000;
}
.message-icon {
width: 36px;
height: 36px;
background-color: #e8e8e8;
border-radius: 18px;
display: flex;
position: relative;
margin-top: 10px;
}
.message-img {
background: url(https://staticg.sportskeeda.com/skm/assets/header/btn-notification.svg) no-repeat;
background-size: 20px 20px;
height: 20px;
width: 20px;
display: flex;
position: absolute;
top: 8px;
left: 8px;
}
.message-count {
width: 20px;
height: 20px;
border-radius: 10px;
background-color: #d32f2f;
font-size: 13px;
font-weight: 500;
font-style: normal;
font-stretch: normal;
line-height: normal;
letter-spacing: normal;
color: #ffffff;
display: flex;
position: absolute;
top: -8px;
right: -6px;
justify-content: center;
align-items: center;
}
.message-txt {
padding-top: 5px;
padding-left: 15px;
width: 77%;
font-size: 12px;
font-weight: normal;
font-style: normal;
font-stretch: normal;
line-height: 1.33;
letter-spacing: normal;
color: #555555;
vertical-align: middle;
}
.message-close {
width: 20px;
height: 20px;
content: "✕";
color: #808080;
margin-left: auto;
cursor: pointer;
font-size: 10px;
border-radius: 10px;
background-color: #e8e8e8;
display: flex;
justify-content: center;
align-items: center;
}
.message-background {
width: 320px;
height: 200px;
position: fixed;
left: 0px;
bottom: 0px;
background: transparent;
z-index: 1000;
}
</style>
<div class="message-background hidden"></div>
<div class="message-card hidden">
<div class="message-icon">
<div class="message-count">1</div>
<div class="message-img"></div>
</div>
<div class="message-txt">
</div>
<div class="message-close">✕</div>
</div>
<script>
$('.message-close').addEventListener("click", function (event) {
addClass($(".message-card"), 'hidden');
addClass($(".message-background"), 'hidden');
});
function showMessage(message) {
removeClass($(".message-card"), 'hidden');
removeClass($(".message-background"), 'hidden');
$(".message-txt").innerHTML = message;
setTimeout(function(){
addClass($(".message-card"), 'hidden');
addClass($(".message-background"), 'hidden');
}, 10*1000);
}
</script>
<style>
.top-cta-button{
display: block;
width: 78px;
height: 24px;
border-radius: 12px;
background-color: #d32f2f;
border: solid 1px #d32f2f;
color: #fff;
text-transform: uppercase;
padding: 0px 12px;
margin: -4px 10px 0 20px;
cursor: pointer;
font-size: 14px;
text-align: center;
}
.top-cta-button:hover{
background: #BB2F2F;
}
.logged-out .login-cta{
display: block;
width: 78px;
height: 26px;
border-radius: 12px;
background-color: #d32f2f!important;
border: solid 1px #d32f2f;
color: #fff!important;
text-transform: uppercase;
padding: 0px 12px!important;
margin: 0 10px 0 20px!important;
cursor: pointer;
font-size: 14px;
text-align: center;
text-decoration: none!important;
font-weight: normal!important;
}
.youtube {
background-color: #000;
cursor: pointer;
}
.youtube img {
cursor: pointer;
object-fit: cover;
}
.play-button {
position: relative;
display: inline-block;
}
.play-button:before {
content: "";
position: absolute;
width: 100%;
height: 100%;
z-index: 1;
background: transparent url('https://staticg.sportskeeda.com/YouTube_play_button_icon.svg') center center no-repeat;
background-size: 12%;
}
</style>
<!-- Facebook Pixel Code -->
<script> 
var fbPixelFired = false;
document.addEventListener("scroll", function() { loadFBPixel() });
document.addEventListener("mousemove", function() { loadFBPixel() });
function loadFBPixel() {
if(fbPixelFired) {
return;
}
fbPixelFired = true;
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod? 
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window, 
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '952063904834769'); 
fbq('track', "PageView");
fbq('track', 'ViewContent');
}
</script>
<noscript><img height="1" width="1" style="display:none" 
src="https://www.facebook.com/tr?id=952063904834769&ev=PageView&noscript=1" />
</noscript>
<!-- End Facebook Pixel Code -->
<script type="text/javascript">
var SKTrackingModule = (function () {
var COOKIE_NAME = 'HP_ALGO_DATA_V2';
var DATASET_SIZE = 10;
var CLIPPING_SIZE = 100;
function getTrackingCookie(cname, defaultValue) {
var name = cname + "=";
var ca = document.cookie.split(';');
for(var i = 0; i < ca.length; i++) {
var c = ca[i].trim();
if (c.indexOf(name) === 0) {
return c.substring(name.length,c.length).trim();
}
}
return defaultValue;
}
function setTrackingCookie(cname, cvalue) {
document.cookie = cname + '=' + cvalue + ';domain=.sportskeeda.com;path=/;expires=Fri, 31 Dec 9999 23:59:59 GMT';
}
function initializeJSONDataStructure (data, key, identifier, title) {
if (!data.hasOwnProperty(key) || key == 'sport') {
data[key] = [];
}
data[key].push({
name: identifier,
value: "99",
title: title
});
return data;
}
function incrementTrackingLogic(item) {
var clipAll = false;
item['value'] = parseInt(item['value']) + 1;
if (item['value'] >= CLIPPING_SIZE) {
item['value'] = CLIPPING_SIZE.toString();
var clipAll = true;
} else {
item['value'] = item['value'].toString();
}
return {
'value': item,
'clipAll': clipAll
};
}
function clippingMechanism(data, key) {
if (data[key].length >= DATASET_SIZE * 2) {
return data[key].slice(0, DATASET_SIZE);
} else {
return data[key];
}
}
function track(cname, key, identifier, title) {
var data = getTrackingCookie(cname, '{}');
data = JSON.parse(data);
if (!data.hasOwnProperty(key) || key == 'sport') {
data = initializeJSONDataStructure(data, key, identifier, title);
} else {
var item = data[key].filter(function(item) {
return item.name == identifier;
});
if (item.length > 0) {
item = item[0];
var incrementResponse = incrementTrackingLogic(item);
item = incrementResponse['value'];
if (incrementResponse['clipAll']) {
data[key].forEach(function(item){
item['value'] = parseInt(item['value'] / 2).toString();
});
}
} else {
data = initializeJSONDataStructure(data, key, identifier, title);
}
}
data[key].sort(function(a, b) {
return b['value'] > a['value'] ? 1 : -1;
});
data[key] = clippingMechanism (data, key);
setTrackingCookie(COOKIE_NAME, JSON.stringify(data));
}
function trackSport(identifier, title) {
track(COOKIE_NAME, 'sport', identifier, title);
}
function trackEvent(identifier) {
track(COOKIE_NAME, 'event', identifier, "");
}
function trackTeam(identifier) {
track(COOKIE_NAME, 'team', identifier, "");
}
return {
getTrackingCookie: getTrackingCookie,
setTrackingCookie: setTrackingCookie,
trackSport: trackSport,
trackEvent: trackEvent,
trackTeam: trackTeam
};
})();
var hpAlgoCookie = SKTrackingModule.getTrackingCookie('HP_ALGO', null);
if (!hpAlgoCookie) {
var hpAlgoCookieRange = ['false', 'hp_algo_1'];
var hpAlgoCookie = hpAlgoCookieRange[Math.floor(Math.random() * hpAlgoCookieRange.length)];
SKTrackingModule.setTrackingCookie('HP_ALGO', hpAlgoCookie);
}
var category;
try {
var category = JSON.parse('{"slug":"health-and-fitness","title":"Hindi - Health and Fitness"}');
SKTrackingModule.trackSport(category.slug, category.title);
} catch (e) {}
</script>
<script>
function trackHashValueContentSource() {
var keyValueArray = window.location.hash.replace('#', '').split('=');
console.log("VALUES: ", keyValueArray);
if(keyValueArray.length === 2 && keyValueArray[0] === "src") {
history.replaceState({}, document.title, window.location.pathname + window.location.search);  // keep the url with query string
if(keyValueArray[1] === "ARTICLE_PAGE") {
gtag('event', 'TRENDING', {
'event_category': "BELOW_CONTENT_FEED_PAGE_LOADED",
'event_label':  "1",
'non_interaction': true
});
} else if(keyValueArray[1] === "RELATED_WIDGET") {
var currentPagePath = window.location.pathname;
gtag('event', 'RELATED', {
'event_category': "BELOW_CONTENT_FEED_PAGE_LOADED",
'event_label': currentPagePath,
'non_interaction': true
});
}
}
}
trackHashValueContentSource();
</script>    <script>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</script>
<script>
function lazyLoadInFeedNativeAds() {
}
</script>
<script>
var articleContent = $('#article-content');
var articleTitle = $('#heading').innerText;
var scrollPercent = 0;
var scrollEventRecorded = false;
window.addEventListener('scroll', function() {
var rect = articleContent.getBoundingClientRect();
var height = rect.height, bottom = rect.bottom;
if (bottom <= height*0.75 && scrollEventRecorded == false) {
scrollPercent = 25;
scrollEventRecorded = true;
gtag('event','25%', {
'event_category': 'NTG article milestone',
'event_label': articleTitle,
'event_value': 25 ,
'non_interaction' : true
});
}
});
</script>
<style>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</style>
<style>
.sidebar-separator{
height: 1px;
width: 100%;
background: #e5e5e5;
}
.mobile-overlay-profile-menu.active {
display: block;
}
.mobile-overlay-profile-menu {
width: 100%;
height: 100%;
position: fixed;
background: #000;
opacity: 0.5;
display: none;
left: 0;
top: 0;
z-index: 20000;
}
</style>
<div class="mobile-overlay">
</div>
<div class="mobile-overlay-profile-menu">
</div>
<style>
.popup .profile-intro {
border-bottom: 1px solid #E9E9E9;
padding: 20px;
display: flex;
}
#user-profile #profile-link {
color: #666666;
text-decoration: underline;
}
.profile-actions .action-img {
margin-right: 10px;
vertical-align: middle;
width: auto;
}
.popup .profile-actions {
height: auto;
padding: 15px 20px;
font-weight: 500;
max-height: 450px;
overflow-y: scroll;
overflow-x: hidden;
}
.profile-actions::-webkit-scrollbar {
-webkit-appearance: none;
width: 7px;
}
.profile-actions::-webkit-scrollbar-thumb {
border-radius: 4px;
background-color: rgba(0,0,0,.5);
box-shadow: 0 0 1px rgba(255,255,255,.5);
}
.profile-actions ul {
display: flex;
flex-direction: row;
flex-wrap: wrap;
padding: 5px 0;
color: #999999;
font-size: 16px;
}
.profile-actions ul li {
padding: 8px 0;
flex: 50%;
font-size: 16px;
}
.profile-actions li a {
display: block;
width: 100%;
text-decoration: none;
color: #999999;
}
.profile-actions span {
font-size: 16px;
}
.profile-pic-div #profile-pic {
border-radius: 50%;
}
.logout-action a {
display: block;
width: 100%;
color: #999999 !important;
text-decoration: none !important;
}
.logout-action:hover a {
transform: scale(1.01);
color: #D32F2F !important;
}
.popup .logout-action {
padding: 5px;
color: #999999;
text-align: center;
vertical-align: middle;
border-top: 1px solid #E9E9E9;
border-bottom: 1px solid #E9E9E9;
margin: 0 15px 15px 15px;
font-weight: 500;
}
#profile-menu-popup {
width: 410px !important;
height: auto;
border-radius: 6px;
right: 0;
top: 45px;
background: #FFFFFF;
box-sizing: border-box;
box-shadow: -1px 6px 12px rgba(0, 0, 0, 0.1);
z-index: 10000;
overflow: hidden;
position: absolute;
border: 1px solid #E9E9E9;
cursor: initial;
}
.profile-intro #user-name {
display: block;
font-size: 16px;
font-weight: 700;
margin-left: 0;
}
.profile-intro #user-status {
display: block;
font-size: 14px;
font-weight: 500;
color: #D32F2F;
}
.profile-intro #user-profile {
display: block;
font-size: 14px;
font-weight: 400;
}
.profile-pic-div {
flex: 0.2;
}
.profile-info-div {
flex: 0.8; padding: 0 10px;
}
.popup .profile-actions {
height: auto;
}
.profile-actions li:hover {
color: #D32F2F !important;
transform: scale(1.01);
}
.profile-actions li:hover a {
color: #D32F2F !important;
}
.popup .logout-action {
font-size: 16px;
}
</style>
<div id="profile-menu-popup" class="popup hidden">
<div class="profile-intro">
<div class="profile-pic-div" onclick="uploadPic();"><a href="/edit-profile"><img id="profile-pic" alt="default-profile-pic" width="68" height="68" src="//staticg.sportskeeda.com/skm/assets/profile-pic-upload.svg"/></a></div>
<div class="profile-info-div">
<span id="user-name"></span>
<span id="user-status"></span>
<span id="user-profile" onclick="manageProfile();"><a id="profile-link">Manage your profile</a></span>
</div>
</div>
<div class="profile-actions">
<div class="editing-actions">
<div><img height="24" width="24" alt="editing-icon" class="action-img" src="//staticg.sportskeeda.com/skm/assets/editing.svg"/><span class="action-text">Editing</span></div>
<ul>
<li id="article-queue-link"><a href="/creator/content-dashboard">Article Queue</a></li>
<li id="video-queue-link"><a href="/creator/video-queue">Video Queue</a></li>
<li id="edit-stats"><a href="/editor/editing-stats-dashboard">Editing Stats</a></li>
<li id="writers-link"><a href="/creator">Writer Home</a></li>
</ul>
</div>
<div class="seo-actions">
<div><img height="24" width="24" alt="seo-icon" class="action-img" src="//staticg.sportskeeda.com/skm/assets/seo.svg"/><span class="action-text">SEO</span></div>
<ul>
<li id="redirection-admin"><a href="/admin/redirect-urls">Redirection Admin</a></li>
<li id="wiki-submissions-link"><a href="/taxonomy/gaming-wiki-edits">Gaming Wiki Edits</a></li>
<li id="taxonomy-link"><a href="/taxonomy">Taxonomy Home</a></li>
<li id="edit-site-menu"><a href="/creator/menu-edit">Edit Site Menu</a></li>
<li id="mappings-dashboard-link"><a href="/admin/mapping-dashboard">Mapping Dashboard</a></li>
<li id="tagPages-link"><a href="/taxonomy/post_tag">Tag Pages</a></li>
</ul>
</div>
<div class="community-actions">
<div><img height="24" width="24" alt="community-icon" class="action-img" src="//staticg.sportskeeda.com/skm/assets/community.svg"/><span class="action-text">Community</span></div>
<ul>
<li id="social-feed-queue-link"><a href="/creator/social-queue">Social Feed Queue</a></li>
<li id="feed-center-link"><a href="/feed-center">Feed Center</a></li>
<li id="notification-center-link"><a href="/admin/notification-center">Notification Center</a></li>
<li id="new-affiliate-link"><a href="/affiliate-v2">Affiliate Home</a></li>
<li id="manage-page-link"><a href="/page/manage">Manage Pages</a></li>
<li id="bottom-tagline-dashboard-link"><a href="/admin/bottom-tagline-dashboard">Bottom Tagline Dash</a></li>
<li id="timeless-posts-manager-link"><a href="/admin/timeless-posts-dashboard">Timeless Posts</a></li>
</ul>
</div>
</div>
<div class="logout-action">
<a href="https://a-login.sportskeeda.com/hi/logout?next='+ window.location.origin + window.location.pathname + window.location.search +'">Logout</a>
</div>
</div>
<script>
function manageProfile() {
gtag('event', 'MangeProfileClicked');
}
function uploadPic() {
gtag('event', 'ProfilePictureClicked');
}
document.addEventListener("click", function(event) {
// If user either clicks outside the popup
if (!event.target.closest("#profile-menu-popup") && !event.target.classList.contains("toggle")) {
addClass($("#profile-menu-popup"), "hidden");
}
}, false
)
</script>
<div class="keeda-side-menu" id="keeda-side-menu">
<div class="favorites-select-overlay">
</div>
<section class="favorites-search">
<div class="search-container">
<label for="search-input" class="title">🔍 Search</label>
<input id="search-input" class="keeda-search-input" type="text" placeholder="Event, Team, Player, Sport"/>
<div class="search-dismiss">
</div>
</div>
<div class="search-results">
</div>
<div class="no-result-message hidden">
No Results Found
</div>
</section>
<template id="favorites-choice-block">
<div class="favorites-choice-block">
<a class="favorites-choice-name"></a>
</div>
</template>
<a class="sidebar-app-download"  href="https://play.google.com/store/apps/details?id=com.sportskeeda.topic&referrer=utm_source%3DSportskeeda%26utm_medium%3DDesktop%26utm_campaign%3DSiteMenuSIdebar"  onclick="gtag('event', 'click', { 'event_label': 'side-menu', 'event_category': 'app-download', 'transport_type': 'beacon'})">
<img src="//staticg.sportskeeda.com/assets/app/app-download-anim.gif" width="50" height="50" alt="App download animated image">
<span class="span" style="">Get the free App now</span>
</a>
<div class="sidebar-separator"></div>
<script>
function prepareGAEventTracker() {
return function(eventName, eventParams) {
eventParams = eventParams || {};
var params = Object.assign({}, eventParams, {
send_to: "G-QLP13SMT42",
sk_version: "WithoutIIQ",
});
gtag("event", eventName, params);
}
}
</script>
<script>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</script>
<script>
(function() {
var trackGAEvent = prepareGAEventTracker();
window.addEventListener("DOMContentLoaded", onDomLoaded);
function onDomLoaded() {
KeedaPushNotificationsManagerInstance
.onceReady()
.then(function() {
return KeedaPushNotificationsManagerInstance.getToken();
})
.then(initManageNotifications);
}
function initManageNotifications(token) {
var ctaButton = $("#cta__side_menubar_item__manage_notifications");
var getClickHandler = function(callback) {
return function(event) {
event.preventDefault();
$(".mobile-overlay.active") && $(".mobile-overlay").click();
callback();
}
}
if (!KeedaPushNotificationsManagerInstance.isNotificationPermissionAllowed()) {
var handler = KeedaPushNotificationsPreferencesManagerInstance
.showNotificationsDisabledModal.bind(KeedaPushNotificationsPreferencesManagerInstance);
ctaButton.addEventListener("click", getClickHandler(handler), false);
$("#section__side_menubar_item__manage_notifications").classList.remove("hidden");
return;
}
if (!token) {
return;
}
var input = {
token: token,
onNotificationAllowedChange: function(status) {
trackGAEvent("Push_Notification_Allow_Notification_toggle");
if (status) {
trackGAEvent("Push_Notification_Allow_Notification_Yes");
} else {
trackGAEvent("Push_Notification_Allow_Notification_No");
}
},
onModalDismissed: function() {}
}
var handler = KeedaPushNotificationsPreferencesManagerInstance
.showManageModal.bind(KeedaPushNotificationsPreferencesManagerInstance, input);
var clickHandler = getClickHandler(handler);
var clickHandlerWithGAEvent = function(event) {
trackGAEvent("Push_Notification_HamB_ManageNotif");
clickHandler(event);
}
ctaButton.addEventListener("click", clickHandlerWithGAEvent, false);
ctaButton.addEventListener("portalClick", clickHandler, false);
$("#section__side_menubar_item__manage_notifications").classList.remove("hidden");
}
})();
</script>
<style>
#section__side_menubar_item__manage_notifications .favorites-choice-block {
padding-top: 12px;
padding-bottom: 12px;
}
#section__side_menubar_item__manage_notifications .favorites-choice-name {
display: flex;
align-items: center;
cursor: pointer;
}
#section__side_menubar_item__manage_notifications .favorites-choice-name .bell-icon {
display: flex;
flex: 1;
}
</style>
<section class="links hidden" id="section__side_menubar_item__manage_notifications">
<div class="favorites-choice-block">
<a class="favorites-choice-name" title="Manage notifications" id="cta__side_menubar_item__manage_notifications">
<span class="bell-icon">
<img src="//staticg.sportskeeda.com/skm/assets/images/ic-notification-bell.svg" alt="bell-icon" width="18"
height="17" />
</span>
<span>Manage notifications</span>
</a>
</div>
</section>
<div class="sidebar-separator"></div>
<section class="popular active">
<div class="fav-header popular">
<span class="title">🔥 Popular</span>
</div>
<div class="list">
</div>
</section>
<div class="sidebar-separator"></div>
<section class="global-menu collapsed">
<div class="fav-header" id="sport-expansion-container">
<div class="title nav-expand" id="sport-expander"><span class="title">🏃🏻‍♀️ Sports (30+)</span></div>
</div>
<div class="list">
<li class="nav1" data-term-taxonomy-id="" data-title="फ़ुटबॉल" data-image="" data-url="/football"><a class="nav-expand " >फ़ुटबॉल</a><ul class="submenu"><li class=" nav2" data-term-taxonomy-id="" data-title="फ़ुटबॉल Home" data-image="" data-url="/football"><a href="/football">फ़ुटबॉल Home</a></li></ul> </li><li class="nav1" data-term-taxonomy-id="" data-title="Hindi Cricket News" data-image="" data-url="/cricket"><a class="nav-expand " >Hindi Cricket News</a><ul class="submenu"><li class=" nav2" data-term-taxonomy-id="" data-title="Hindi Cricket News Home" data-image="" data-url="/cricket"><a href="/cricket">Hindi Cricket News Home</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="IPL 2022" data-image="" data-url="https://hindi.sportskeeda.com/go/ipl"><a href="https://hindi.sportskeeda.com/go/ipl">IPL 2022</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="आज का आईपीएल मैच" data-image="" data-url="https://hindi.sportskeeda.com/cricket/today-ipl-match"><a href="https://hindi.sportskeeda.com/cricket/today-ipl-match">आज का आईपीएल मैच</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="कल का आईपीएल (IPL) मैच कौन जीता  " data-image="" data-url="https://hindi.sportskeeda.com/cricket/yesterday-ipl-match-result"><a href="https://hindi.sportskeeda.com/cricket/yesterday-ipl-match-result">कल का आईपीएल (IPL) मैच कौन जीता  </a></li><li class=" nav2" data-term-taxonomy-id="" data-title="Dream11 Fantasy " data-image="" data-url="https://hindi.sportskeeda.com/cricket/fantasy-cricket-tips"><a href="https://hindi.sportskeeda.com/cricket/fantasy-cricket-tips">Dream11 Fantasy </a></li><li class=" nav2" data-term-taxonomy-id="" data-title="भारतीय क्रिकेट टीम न्यूज़ " data-image="" data-url="https://hindi.sportskeeda.com/team/india-national-cricket-team"><a href="https://hindi.sportskeeda.com/team/india-national-cricket-team">भारतीय क्रिकेट टीम न्यूज़ </a></li><li class=" nav2" data-term-taxonomy-id="" data-title="ICC रैंकिंग" data-image="" data-url="https://hindi.sportskeeda.com/cricket/icc-rankings"><a href="https://hindi.sportskeeda.com/cricket/icc-rankings">ICC रैंकिंग</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="ICC वर्ल्ड कप सुपर लीग " data-image="" data-url="https://hindi.sportskeeda.com/go/icc-world-cup-super-league"><a href="https://hindi.sportskeeda.com/go/icc-world-cup-super-league">ICC वर्ल्ड कप सुपर लीग </a></li><li class=" nav2" data-term-taxonomy-id="" data-title="ICC WTC 2021-23" data-image="" data-url="https://hindi.sportskeeda.com/go/icc-world-test-championship"><a href="https://hindi.sportskeeda.com/go/icc-world-test-championship">ICC WTC 2021-23</a></li></ul> </li><li class="nav1" data-term-taxonomy-id="" data-title="टेनिस" data-image="" data-url="/tennis"><a class="nav-expand " >टेनिस</a><ul class="submenu"><li class=" nav2" data-term-taxonomy-id="" data-title="टेनिस Home" data-image="" data-url="/tennis"><a href="/tennis">टेनिस Home</a></li></ul> </li><li class="nav1" data-term-taxonomy-id="" data-title="कबड्डी" data-image="" data-url="/kabaddi"><a class="nav-expand " >कबड्डी</a><ul class="submenu"><li class=" nav2" data-term-taxonomy-id="" data-title="कबड्डी Home" data-image="" data-url="/kabaddi"><a href="/kabaddi">कबड्डी Home</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="प्रो कबड्डी के नियम" data-image="" data-url="https://hindi.sportskeeda.com/kabaddi/pro-kabaddi-2018-rules-in-hindi"><a href="https://hindi.sportskeeda.com/kabaddi/pro-kabaddi-2018-rules-in-hindi">प्रो कबड्डी के नियम</a></li></ul> </li><li class="nav1" data-term-taxonomy-id="" data-title="गेमिंग" data-image="" data-url="/esports"><a class="nav-expand " >गेमिंग</a><ul class="submenu"><li class=" nav2" data-term-taxonomy-id="" data-title="गेमिंग Home" data-image="" data-url="/esports"><a href="/esports">गेमिंग Home</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="Wiki Guides" data-image="" data-url="https://www.sportskeeda.com/wiki"><a href="https://www.sportskeeda.com/wiki">Wiki Guides</a></li></ul> </li><li class="nav1" data-term-taxonomy-id="" data-title="MMA" data-image="" data-url="/mma"><a class="nav-expand " >MMA</a><ul class="submenu"><li class=" nav2" data-term-taxonomy-id="" data-title="MMA Home" data-image="" data-url="/mma"><a href="/mma">MMA Home</a></li></ul> </li><li class="nav1" data-term-taxonomy-id="" data-title="WWE" data-image="" data-url="/wwe"><a class="nav-expand " >WWE</a><ul class="submenu"><li class=" nav2" data-term-taxonomy-id="" data-title="WWE Home" data-image="" data-url="/wwe"><a href="/wwe">WWE Home</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="WWE RAW" data-image="" data-url="https://hindi.sportskeeda.com/go/raw"><a href="https://hindi.sportskeeda.com/go/raw">WWE RAW</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="WWE SmackDown" data-image="" data-url="https://hindi.sportskeeda.com/go/smackdown"><a href="https://hindi.sportskeeda.com/go/smackdown">WWE SmackDown</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="WWE Royal Rumble 2022" data-image="" data-url="https://hindi.sportskeeda.com/go/royal-rumble"><a href="https://hindi.sportskeeda.com/go/royal-rumble">WWE Royal Rumble 2022</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="WWE रोस्टर" data-image="" data-url="https://hindi.sportskeeda.com/tag/wwe-roster"><a href="https://hindi.sportskeeda.com/tag/wwe-roster">WWE रोस्टर</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="रोमन रेंस" data-image="" data-url="https://hindi.sportskeeda.com/player/roman-reigns"><a href="https://hindi.sportskeeda.com/player/roman-reigns">रोमन रेंस</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="ब्रॉक लैसनर" data-image="" data-url="https://hindi.sportskeeda.com/player/brock-lesnar"><a href="https://hindi.sportskeeda.com/player/brock-lesnar">ब्रॉक लैसनर</a></li><li class=" nav2" data-term-taxonomy-id="" data-title="जॉन सीना" data-image="" data-url="https://hindi.sportskeeda.com/player/john-cena"><a href="https://hindi.sportskeeda.com/player/john-cena">जॉन सीना</a></li></ul> </li>
</div>
</section>
<section class="favorite-choices">
<div class="list">
</div>
</section>
<div class="sidebar-separator"></div>
<section class="links active">
<div class="fav-header links">
<span class="title">🔗 LINKS</span>
</div>
<div class="favorites-choice-block">
<a class="favorites-choice-name" title="Write For US" href="/creator/getting-started/">Write For Us</a>
</div>
<div class="favorites-choice-block">
<a class="favorites-choice-name" title="Stories" href="/stories/">Stories</a>
</div>
<div class="favorites-choice-block">
<a class="favorites-choice-name" title="Contact Sportskeeda" href="/contact">Contact Us</a>
</div>
<div class="favorites-choice-block">
<a class="favorites-choice-name" title="Sportskeeda Policies" href="/policies">Policies</a>
</div>
<div class="favorites-choice-block">
<a class="favorites-choice-name" title="Sportskeeda committed to GDPR" href="/gdpr-compliance">GDPR Compliance</a>
</div>
<div class="favorites-choice-block">
<a class="favorites-choice-name" title="Sportskeeda Affiliate Program" href="/register-as-an-affiliate">Affiliate</a>
</div>
<div class="favorites-choice-block">
<a class="favorites-choice-name" title="Sportskeeda Writer Awards" href="/writer-awards">Writer Awards</a>
</div>
<div class="favorites-choice-block">
<a class="favorites-choice-name" title="Sportskeeda Editor Awards" href="/editor-awards">Editor Awards</a>
</div>
<div class="favorites-choice-block">
<a class="favorites-choice-name" title="Sportskeeda Careers Page" href="/careers" target="_blank" rel="noopener noreferrer">Careers</a>
</div>
<div class="favorites-choice-block">
<a class="favorites-choice-name" title="Sportskeeda Tech Blog" href="https://tech.sportskeeda.com" target="_blank" rel="noopener noreferrer">Tech Blog</a>
</div>
</section>
<div class="sidebar-separator"></div>
<section class="links active lang-section">
<div class="fav-header language links" onclick="toggleLangContainer()">
<span class="title">Edition: </span>
</div>
<div class="lang-container">
<div class="language-choice-block language-choice-name en">
<a title="English" href="https://www.sportskeeda.com">English</a>
</div>
<div class="language-choice-block language-choice-name hi">
<a title="हिन्दी" href="https://hindi.sportskeeda.com">हिन्दी</a>
</div>
</div>
</section>
<div class="padder">
</div>
</div>
<template id="favorites-block">
<div class="favorite-block">
<a class="favorite-link"></a>
<span class="favorite-name"></span>
<span class="favorite-remove"></span>
</div>
</template>
<script>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</script>
<script type="text/javascript">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</script>
<script type="text/javascript">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</script>
<template id="template__disabled_push_notifications_modal">
<style>
.keeda_modal_content {
border-radius: 8px;
padding-top: 0 !important;
}
.keeda_modal_header {
margin-left: -20px;
margin-right: -20px;
padding: 20px;
border-radius: 8px 8px 0 0;
background-color: #f5f5f5;
}
.keeda_modal_content {
padding: 20px;
}
.keeda_modal_content_text {
padding-top: 0;
padding-bottom: 0;
}
.keeda_modal_header_text {
color: #2D2D2D;
font-size: 16px;
font-weight: bold;
}
.instructions-container {}
.instructions-container .instruction-row {
display: flex;
align-items: start;
margin: 20px 0;
}
.instruction-row .instruction-icon {
display: flex;
width: 20px;
height: 20px;
margin-top: 5px;
}
.instruction-row .instruction-details {
margin-left: 10px;
}
.instruction-row .instruction-details p {
font-size: 13px;
font-weight: 700;
}
.instruction-details .instruction--primary {
color: #474747;
}
.instruction-details .instruction--secondary {
color: #6f6f6f;
}
.instruction-details .highlight {
color: #be3938;
padding: 0;
background: unset;
}
</style>
<div class="instructions-container">
<div class="instruction-row">
<div class="instruction-icon">
<img src="//staticg.sportskeeda.com/assets/pwa/icons/ic_cog.svg" height="20" width="20" alt="icon-settings" />
</div>
<div class="instruction-details">
<p class="instruction--secondary">Go to your</p>
<p class="instruction--primary">Browser"s <span class="highlight">Setting&#39;s</span> page</p>
</div>
</div>
<div class="instruction-row">
<div class="instruction-icon">
<img src="//staticg.sportskeeda.com/assets/pwa/icons/ic_permissions.svg" height="20" width="20"
alt="icon-permissions" />
</div>
<div class="instruction-details">
<p class="instruction--secondary">Tap on</p>
<p class="instruction--primary"><span class="highlight">Site Settings</span>/Site Permissions</p>
</div>
</div>
<div class="instruction-row">
<div class="instruction-icon">
<img src="//staticg.sportskeeda.com/assets/pwa/icons/ic_notification_bell.svg" height="20" width="20"
alt="icon-bell" />
</div>
<div class="instruction-details">
<p class="instruction--secondary">Tap on</p>
<p class="instruction--primary"><span class="highlight">Notifications</span></p>
</div>
</div>
<div class="instruction-row">
<div class="instruction-icon">
<img src="//staticg.sportskeeda.com/assets/pwa/icons/ic_blocked.svg" height="20" width="20"
alt="icon-blocked" />
</div>
<div class="instruction-details">
<p class="instruction--secondary">Tap on</p>
<p class="instruction--primary">the <span class="highlight">Block list</span> and find sportskeeda.com</p>
</div>
</div>
<div class="instruction-row">
<div class="instruction-icon">
<img src="//staticg.sportskeeda.com/assets/pwa/icons/ic_allowed_check.svg" height="20" width="20"
alt="icon-allowed" />
</div>
<div class="instruction-details">
<p class="instruction--secondary">Tap on</p>
<p class="instruction--primary">sportskeeda.com and tap on <span class="highlight">Allow</span></p>
</div>
</div>
</div>
</template>
<template id="template__manage_notifications_modal">
<style>
.keeda_modal_content {
padding: 20px;
}
.keeda_modal_header_text {
color: #2D2D2D;
font-size: 16px;
font-weight: bold;
}
.keeda_modal_actions {
padding-top: 0px;
text-align: center;
}
.switch {
position: relative;
display: block;
width: 35px;
height: 17px;
}
.switch input {
opacity: 0;
width: 0;
height: 0;
margin: 0;
}
.slider {
position: absolute;
cursor: pointer;
top: 0;
left: 0;
right: 0;
bottom: 0;
background-color: #ccc;
transition: background-color ease .4s;
}
.slider:before {
position: absolute;
content: "";
height: 11px;
width: 11px;
left: 3px;
right: auto;
bottom: 3px;
background-color: #fff;
}
.slider.round {
border-radius: 34px;
}
.slider.round:before {
border-radius: 50%;
}
input:checked+.slider {
background-color: #AF2222;
}
input:focus+.slider {
box-shadow: 0 0 1px #AF2222;
}
input:checked+.slider:before {
right: 4px;
left: auto;
}
.preferences-container {
width: 100%;
display: flex;
flex-direction: column;
}
.preferences-container .preferences-row {
display: flex;
flex-direction: column;
margin-bottom: 15px;
}
header.row-header {
display: flex;
align-items: center;
justify-content: space-between;
margin-bottom: 10px;
}
header.row-header .text {
padding-right: 10px;
font-weight: 500;
}
.text .primary {
font-size: 14px;
color: #474747;
}
.text .secondary {
font-size: 12px;
color: #999999;
}
.preferences-row .options {
display: flex;
flex-direction: column;
}
.options .option-row {
display: flex;
align-items: center;
justify-content: space-between;
padding: 10px;
background: #F5F5F5;
border-bottom: 1px solid #dedede;
}
.options .option-row:last-child {
border-bottom-color: transparent;
}
.option-row .text {
font-size: 13px;
color: #474747;
}
.body-header {
padding: 7px 0;
}
.body-header .sub-header {
font-weight: 500;
color: #101010;
font-size: 14px;
}
.row-body hr {
border: 1px solid #e9e9e9;
}
.row-body .preference-options .option-header {
padding: 11px 0 11px 0;
}
.separator-section {
margin-bottom: 10px;
padding-top: 10px;
border-top: 1px solid #e9e9e9;
}
.separator-section .text {
font-weight: 500;
color: #101010;
font-size: 14px;
}
</style>
<div class="preferences-container">
<div class="preferences-row">
<header class="row-header">
<div class="text">
<p class="primary">Allow Notifications</p>
</div>
<div class="action">
<label class="switch">
<input type="checkbox" id="checkbox__notifications_allowed" />
<span class="slider round"></span>
</label>
</div>
</header>
</div>
<div class="separator-section">
<p class="text">Notifications you have enabled</p>
</div>
<div class="preferences-row">
<header class="row-header">
<div class="text">
<p class="primary">Teams</p>
</div>
</header>
<div class="row-body">
<div id="subscribed_teams_list"></div>
</div>
</div>
<div class="preferences-row">
<header class="row-header">
<div class="text">
<p class="primary">Series</p>
</div>
</header>
<div class="row-body">
<div id="subscribed_series_list"></div>
</div>
</div>
</div>
</template>
<template id="template__preference_option">
<style>
.one-option {
cursor: pointer;
padding: 13px 20px;
margin-left: -20px;
margin-right: -20px;
background-color: #F5F5F5;
border-bottom: 1px solid #e9e9e9;
}
.option-header {
display: flex;
justify-content: space-between;
align-items: center;
margin-left: -20px;
margin-right: -20px;
padding-left: 20px;
padding-right: 20px;
}
.option-header .option-title {
font-size: 12px;
color: #474747;
font-weight: 500;
}
.option-header img {
height: 8px;
width: 12px;
background: none;
}
.option-header img:focus {
background: none;
}
.options {
margin-left: -10px;
margin-right: -10px;
padding-top: 10px;
}
.options .option-row {
border-bottom: 1px solid #e9e9e9;
}
.options .option-row:last-child {
border-bottom-color: transparent;
}
.options .option-row input[type="checkbox"] {
margin-right: 0;
}
</style>
<div class="one-option">
<header class="option-header">
<p class="option-title"></p>
<div class="option-icon">
<img src="//staticg.sportskeeda.com/assets/chevron-down.svg" height="8" width="12" />
</div>
</header>
<div class="options hidden">
<div class="option-row">
<div class="text">
<p>Toss and match updates</p>
</div>
<div class="action">
<input type="checkbox" name="option__topic" data-topic="toss_and_match" />
</div>
</div>
<div class="option-row">
<div class="text">
<p>Wickets and Milestones</p>
</div>
<div class="action">
<input type="checkbox" name="option__topic" data-topic="wickets_and_milestones" />
</div>
</div>
<div class="option-row">
<div class="text">
<p>Score updates every 5 overs</p>
</div>
<div class="action">
<input type="checkbox" name="option__topic" data-topic="score_every_5_overs" />
</div>
</div>
<div class="option-row">
<div class="text">
<p>Fantasy Tips updates</p>
</div>
<div class="action">
<input type="checkbox" name="option__topic" data-topic="fantasy_tips" />
</div>
</div>
</div>
</div>
</template>
<template id="template__preference_empty_row">
<style>
.no-value {
padding: 16px 5px;
margin: 0 -20px;
background-color: #F5F5F5;
}
.no-value .text {
font-size: 12px;
color: #999;
text-align: center;
}
</style>
<div class="no-value">
<p class="text"></p>
</div>
</template>
<script>
var KeedaCricketPushNotificationsManagerInstance = (function() {
var APP_METADATA = {"name":"Sportskeeda Cricket","short_name":"Sportskeeda Cricket","description":"Sportskeeda Cricket","theme_color":"#d32f2f","background_color":"#ffffff","scope":"\/live-cricket-score\/","launch_url":"\/live-cricket-score\/welcome?key4=pwacmc","assets":{"badge":"\/\/static.sportskeeda.com\/pwa\/badge.png","icon":"\/\/static.sportskeeda.com\/pwa\/cricket\/icon.png"}};
function KeedaCricketPushNotificationsManager() {
this.notificationIcon = APP_METADATA.assets.icon + "?w=128";
}
KeedaCricketPushNotificationsManager.prototype.isCricketNotification = function(notification) {
return notification.data && notification.data.target && notification.data.target === "cricket";
}
KeedaCricketPushNotificationsManager.prototype.showNotification = function(notification) {
KeedaPushNotificationsManagerInstance.showNotification(notification, {
options: {
icon: this.notificationIcon
}
});
}
KeedaCricketPushNotificationsManager.prototype.onNotificationReceived = function(callback) {
var self = this;
return KeedaPushNotificationsManagerInstance.subscribeForNotifications(function(notification) {
if (!self.isCricketNotification(notification)) {
return false;
}
self.showNotification(notification);
if (callback) {
setTimeout(callback.bind(null, notification));
}
return true;
});
}
KeedaCricketPushNotificationsManager.prototype.getImplicitTopicsToSubscribe = function(subscribedTopicsMap) {
var topicsToSubscribe = [];
var topicId = KeedaPushNotificationsManagerInstance.generateTopic(
KeedaPushNotificationsManagerInstance.ObjectType.Info,
"cricket",
KeedaPushNotificationsManagerInstance.Topic.ManualNotifications
);
if (!subscribedTopicsMap[topicId]) {
topicsToSubscribe.push(topicId);
}
return topicsToSubscribe;
}
KeedaCricketPushNotificationsManager.prototype.subscribeToDefaultTopics = function(subscribedTopicsMap) {
var self = this;
return KeedaPushNotificationsManagerInstance.getToken().then(function(token) {
return KeedaPushNotificationsManagerInstance.subscribeToTopics(
token,
self.getImplicitTopicsToSubscribe(subscribedTopicsMap)
);
});
}
return new KeedaCricketPushNotificationsManager();
})();
</script>
<script>
(function() {
if ("serviceWorker" in navigator) {
var trackGAEvent = prepareGAEventTracker("root");
window.addEventListener("load", function() {
navigator.serviceWorker
.register("/service-workers/root", {
scope: "/",
})
.then(function(registration) {
onServiceWorkerRegistered(registration);
})
.catch(function(err) {
console.info("Root service worker could not be registered", err);
});
});
function onServiceWorkerRegistered(swRegistration) {
initializePushNotifications(swRegistration);
}
function initializePushNotifications(swRegistration) {
return KeedaPushNotificationsManagerInstance.initialize(swRegistration)
.then(function() {
return KeedaPushNotificationsManagerInstance.requestPermission();
})
.then(function() {
if (KeedaPushNotificationsManagerInstance.didUserAllowNotifications()) {
trackGAEvent("Push_Notification_Permission_Granted");
} else if (KeedaPushNotificationsManagerInstance.didUserBlockNotifications()) {
trackGAEvent("Push_Notification_Permission_Blocked");
}
})
.then(function() {
if (KeedaPushNotificationsManagerInstance.isNotificationPermissionAllowed()) {
return whenNotificationPermissionsAreGranted();
}
})
.catch(function(error) {
console.error("Error occurred while configuring push notifications ", error);
});
}
function whenNotificationPermissionsAreGranted() {
return Promise.resolve()
.then(function() {
return KeedaPushNotificationsManagerInstance.setDefaultNotificationHandlerCallback(function() {
console.info("Acknowledged push notification by default handler!");
trackGAEvent("Push_Notification_Received");
});
})
.then(function() {
return KeedaPushNotificationsManagerInstance.addNotificationHandler(
"cricket", KeedaCricketPushNotificationsManagerInstance);
})
.then(function() {
return KeedaPushNotificationsManagerInstance.getToken()
.then(function(token) {
if (token) {
return Promise.all([
KeedaPushNotificationsPreferencesManagerInstance.updateTokenIfChanged(token),
KeedaPushNotificationsPreferencesManagerInstance.fetchAndPersistSubscribedTopicsForSession(token)
])
}
})
.then(function(response) {
return KeedaPushNotificationsManagerInstance.subscribeToDefaultTopics(
KeedaPushNotificationsPreferencesManagerInstance.getSubscribedTopics()
)
})
});
}
}
})();
</script>
</body>
</html>
